Ubuntu 8.10 (Intrepid Ibex) support

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
desertoak Offline
Junior Member
Posts: 31
Joined: Aug 2008
Reputation: 0
Location: Sweden
Star  Ubuntu 8.10 (Intrepid Ibex) support
Post: #1
Hi,

I've read in the online manual:
Supported Linux Operating-System installed on a supported computer, currently supported OS are:

* Ubuntu Desktop Edition 7.10 (Gutsy Gibbon) 32-bit for x86
* Ubuntu Desktop Edition 8.04 (Hardy Heron) 32-bit for x86
* Ubuntu Server Edition 7.10 (Gutsy Gibbon) 32-bit for x86
* Ubuntu Server Edition 8.04 (Hardy Heron) 32-bit for x86
* Ubuntu Mobile and Embedded Edition 7.10 (UME) 32-bit for x86
* Ubuntu Mobile and Embedded Edition 8.04 (UME) 32-bit for x86

I'm running Ubuntu 8.10 (Intrepid Ibex) Daily Build from 07-Oct-2008.

Will Ubuntu 8.10 (Intrepid Ibex) final be supported in the future?
Am i able to run xbmc on Ubuntu 8.10 (Intrepid Ibex) Daily Build now?
find quote
rodalpho Offline
Fan
Posts: 582
Joined: Nov 2006
Reputation: 16
Post: #2
Of course 8.10 final will be supported. The readme.linux mentions 8.10 now, so I imagine the SVN release will probably work.
find quote
althekiller Offline
Retired Team-XBMC Member
Posts: 5,002
Joined: May 2004
Reputation: 12
Post: #3
AFAIK the Hardy PPA works fine on Intrepid.

There are currently problems with pbuilder on Intrepid which launchpad uses to create the release. Hence no Intrepid specific release. Don't use the daily repo. though. It has been disabled since the feature freeze some months ago.
find quote
conza Offline
Junior Member
Posts: 13
Joined: Oct 2008
Reputation: 0
Location: Sweden
Post: #4
I'm running Atlantis Beta 2 from the Hardy PPA on my Ibex install. I originally installed Beta 1 this way, and yesterday when I did the daily "aptitude update && aptitude full-upgrade" XBMC was updated without problems as well.

Just add the PPA to the sources.lst and then aptitude update && apt-get install xbmc

Works like a charm. Smile
find quote
Aenima99x Offline
Donor
Posts: 1,127
Joined: Aug 2007
Reputation: 8
Location: California
Post: #5
conza Wrote:Works like a charm. Smile
Yeah, as long as you don't have an ATI card :mad:NoAngry
find quote
covert Offline
Junior Member
Posts: 25
Joined: Mar 2004
Reputation: 0
Post: #6
Built from SVN on a machine running the Intrepid kernel. Ran really well on my AMD64 machine. The ppa's both cashed a lot. The SVN has not cashed on me yet.
find quote
onesojourner Offline
Aeon Group
Posts: 296
Joined: Jul 2008
Post: #7
I had this running fine then I ran the newest update yesterday and it killed it. Xbmc starts for about 3 seconds then it closes its self. I was going to just uninstall and then reinstall but synaptic can not find xbmc any more. The repos are still listed and checked. Does any one have any idea what would cause this?

ﻪﻥﻋﺸﻷﻜﻈﭚ
find quote
conza Offline
Junior Member
Posts: 13
Joined: Oct 2008
Reputation: 0
Location: Sweden
Post: #8
Aenima99x Wrote:Yeah, as long as you don't have an ATI card :mad:NoAngry


ah, ok. haven't tried with ATI graphics. I run XBMC on my laptop w/ integrated Intel graphics - and here it works like a charm ;-)

HTPC based on a ASUS P5Q-EM running a Intel E4400 @ 2GHz with 8GB of PC6400 RAM. Windows 7 Ultimate x64 installed on a Samsung T166 SpinPoint 320GB while medialibrary is stored on a 2TB WD Caviar Green. Cat6 STP connects to a Linksys WRT610N which is connected to the Internet over a 100mbit/s fiber. HID is a Ace C5 Media wireless Trackball.
find quote
paisley Offline
Junior Member
Posts: 10
Joined: Mar 2008
Reputation: 0
Post: #9
Hi I am trying to install on the Ubuntu Intrepid Beta however get the following error...

sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbmc: Depends: xbmc-common (= 8.10b2-hardy1) but it is not going to be installed
Depends: xbmc-skin-pm3-hd (= 8.10b2-hardy1) but it is not going to be installed
Depends: xbmc-web-pm3 (= 8.10b2-hardy1) but it is not going to be installed
E: Broken packages
find quote
Clumsy Offline
Team-XBMC Forum Moderator
Posts: 641
Joined: Feb 2004
Reputation: 0
Post: #10
Also works with an ati card now with the new ati drivers from ubuntu canonical. Although the tearing problem persists.
find quote
mvdaat Offline
Member
Posts: 50
Joined: Sep 2006
Reputation: 0
Post: #11
paisley Wrote:Hi I am trying to install on the Ubuntu Intrepid Beta however get the following error...

sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbmc: Depends: xbmc-common (= 8.10b2-hardy1) but it is not going to be installed
Depends: xbmc-skin-pm3-hd (= 8.10b2-hardy1) but it is not going to be installed
Depends: xbmc-web-pm3 (= 8.10b2-hardy1) but it is not going to be installed
E: Broken packages

I have the same problem!
find quote
dead2sin Offline
Junior Member
Posts: 2
Joined: Oct 2008
Reputation: 0
Post: #12
Ok, here is the problem.

I am using Intrepid Ibex beta right now.

I recently installed the 8.10 beta and then did a partial upgrade on it because it said it had over 200 packages to install updates to.

One such package is libbluetooth2. It installed the update for this package, which is now called libbluetooth3.

When you go to install XBMC in synaptic using the PPA repos, it says that libbluetooth2 is a dependency for XBMC-common and therefore it gives the message that the previous posters have put on the forum.

The reason the other two packages fail is because they require xbmc-common.

If xbmc-common is updated to use libbluetooth3 insted of libbluetooth2 this will resolve the issues.

I have no idea where to go from here, but these are my findings and I hope someone will be able to use this information to fix the issue.

So, in short, if you are using FULLY patched version on intrepid ibex, at the time of this posting, xbmc will not work using the hardy repositories due to the libbluetooth3 update.

Nate
(This post was last modified: 2008-10-20 00:09 by dead2sin.)
find quote
mvdaat Offline
Member
Posts: 50
Joined: Sep 2006
Reputation: 0
Post: #13
Any news about this problem?
find quote
JackieBrown Offline
Donor
Posts: 231
Joined: Jan 2008
Reputation: 0
Location: San Antonio, TX
Post: #14
I am just using the hardy libbluetooth2 deb.

libbluetooth3 does not conflict with libbluetooth2
find quote
guizmo1974 Offline
Junior Member
Posts: 17
Joined: Aug 2008
Reputation: 0
Location: Montreal, Quebec, Canada
Post: #15
@JackieBrown: Thanks, it worked!

I was having difficulty reinstalling libbluetooth2... until I saw your message mentioning the deb file.

Then, what I did...
1. Got the deb file from Launchpad (https://launchpad.net/ubuntu/hardy/i386/...th2/3.24-1)
2. Installed the deb file (with the Package Installer)
3. Reinstalled XBMC from the repo

N.B. It seems that using "System Tools- System Cleaner" removed libbbluetooth2 and xbmc alltogether...
find quote
Post Reply