screen ripples during movie playback

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Cheekyboy Offline
Junior Member
Posts: 32
Joined: Jun 2007
Reputation: 0
Post: #1
Not sure if anyone else has noticed this on their mac mini but using beta1 & 2 the screen ripples on odd occasions during video playback. Its just like horizontal sections of the screen are just shifted by a few pixels and the sections roll up the screen and flicker about. I dont see this behaviour in plex though even with the latest builds which I assume would be using the same base code. I have tried various render and upscaling settings but its always there. Any ideas?
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #2
Check Settings->Appearance->Screen and ensure that VSync is set to 'Always Enabled'.

EDIT: mwahaha!

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
(This post was last modified: 2008-10-07 23:05 by d4rk.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,228
Joined: Oct 2003
Reputation: 177
Post: #3
Turn on VSync in Settings->Appearance->Screen.

EDIT: d4rk's faster on the reply button Smile

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
Cheekyboy Offline
Junior Member
Posts: 32
Joined: Jun 2007
Reputation: 0
Post: #4
Thanks guys, you were both on the money Smile
find quote
SecretSquirrel Offline
Member
Posts: 62
Joined: Oct 2008
Reputation: 0
Post: #5
I was seriously concerned that AppleTv was not coping with decoding files quickly enough until I found the sync option - now happy as a pig in the proverbial.

Slow panning was causing awful artefacts.

Wink
find quote
ranglin Offline
Junior Member
Posts: 8
Joined: Jul 2008
Reputation: 0
Post: #6
My wife's Macbook Pro was doing the same thing plugged into the TV with S-Video... I just figured it was having trouble with the S-Video connection, but I'll have to go home now and enable V-Sync... Smile

Is there any chance of enabling it by default in future releases, or is there some reason it is disabled?
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #7
On new installs it should be enabled by default.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
muggsy Offline
Member
Posts: 54
Joined: Mar 2007
Reputation: 0
Post: #8
I'm glad I found this out. I had been using Plex for a while because everytime I played back a Video in XBMC on my macbook it was doing that. Finally now I can just stay with XBMC. That was my only gripe.
find quote