What's with the 'Video Scaling Method' / 'High Quality Software Upscaling' thingy?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
DarkHelmet Offline
Fan
Posts: 312
Joined: Jul 2008
Reputation: 0
Location: Hamburg, Germany
Post: #16
Hitcher Wrote:High Quality Software Upscaling will override the OSD settings.

I have that turned off in video settings. However every time I play a video it's greenish. Now if I enter the OSD the "Interlaced" setting is always set to "Blend". This is the only setting that produces this greenish picture though. When I choose another one the picture's good and it stays good until I close xbmc. The "Interlaced" setting however is not saved so I have to do the same again after a restart.

Using ATI Radeon X1250, Driver 8.561.0.0 (01.12.2008) on Vista Home Premium 32 Bit SP1, and XBMC "pre-9.04 SVN unknown (Compiled: Dec 29 2008) "XBMCSetup-Rev16749-jester.exe". ATI hack is in advancedsettings.xml
find quote
DarkHelmet Offline
Fan
Posts: 312
Joined: Jul 2008
Reputation: 0
Location: Hamburg, Germany
Post: #17
I don't know why but all works now. I think all I did was restart windows. All's well now. Interlaced is now set to "Auto" and scaling method is "Bilinear". Render method is set to "Auto". Upscaling is turned off. Vsync is off in xbmc and set to always on in catalyst. Perfect video quality. Laugh

Don't know if it's related but cpu usage dropped significantly as well. It's now around 3-10% when playing videos (regardless which videos I play, dvds or avis)
find quote
ashlar Offline
Donor
Posts: 2,093
Joined: Mar 2006
Reputation: 27
Post: #18
DarkHelmet Wrote:I don't know why but all works now. I think all I did was restart windows. All's well now. Interlaced is now set to "Auto" and scaling method is "Bilinear". Render method is set to "Auto". Upscaling is turned off. Vsync is off in xbmc and set to always on in catalyst. Perfect video quality. Laugh

Don't know if it's related but cpu usage dropped significantly as well. It's now around 3-10% when playing videos (regardless which videos I play, dvds or avis)
Shouldn't you have XBMC set to "let driver decide" for vsync?
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,263
Joined: Aug 2007
Reputation: 80
Location: Eastleigh, UK
Post: #19
Also, what do the various Render Methods actually do?

ie Advanced Shaders (GLSL), Basic Render (ARB).
find quote
DarkHelmet Offline
Fan
Posts: 312
Joined: Jul 2008
Reputation: 0
Location: Hamburg, Germany
Post: #20
ashlar Wrote:Shouldn't you have XBMC set to "let driver decide" for vsync?

Honestly, I don't know what I should have. It was pure try and error until I got it done.

I also don't know what the various Render Methods actually do.
find quote
SpaceMonkey Offline
Posting Freak
Posts: 1,153
Joined: Aug 2008
Reputation: 24
Location: Finland
Post: #21
setting (or trying to set) scaling method to bicubic in osd causes video to freeze and audio to play in loop..
is this still an issue with some gpus? is it possible to change hardware scaling method by editing xmls?
find quote
conners Offline
Member
Posts: 71
Joined: Nov 2004
Reputation: 0
Post: #22
i have a problem. if i turn on upscaling the screen goes fuzzy and green. had to turn ut off in settings, and all is fine. so i guess no upscaling for me, or is there a solution? would this also help with the video tearing?

im using:
windows xp pro sp3 (tinyxp bare)
atlantis 8.10 build
2GB ram
1.6 Dual core
dvi to hdmi converter to 32 inch LCD
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,263
Joined: Aug 2007
Reputation: 80
Location: Eastleigh, UK
Post: #23
Check your interlaced settings - I'm sure one of them made my screen go green.
find quote
herg Offline
Senior Member
Posts: 106
Joined: Dec 2004
Reputation: 0
Location: Virginia USA
Post: #24
d4rk Wrote:However, you are correct, these settings need to be consolidated and they currently are not, leading to confusion.

Any chance this may happen for Babylon?
find quote
Post Reply