home-focus.gif doesn't work on some items

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #1
I rearranged some items on the home screen, and now the bottom two items of the main five don't have the yellow dot, which i'm assuming is home-focus.gif

Otherwise everything works fine. Any idea why it would work on the first three? Here is the code of one that doesn't work.

<description>My Programs normal push button</description>
<posx>53</posx>
<posy>163</posy>
<width>12</width>
<height>14</height>
<hitrect x="45" y="15" w="220" h="40" />
<label>0</label>
<font>special13</font>
<onclick>ActivateWindow(MyPrograms)</onclick>
<onleft>98</onleft>
<onright>96</onright>
<onup>3</onup>
<ondown>4</ondown>
<texturefocus>home-focus.gif</texturefocus>
<texturenofocus>-</texturenofocus>
<textoffsetx>30</textoffsetx>
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #2
looks fine to me so I assume you have the button code on top of the
PHP Code:
<control type="image">
    <
posx>50</posx>
    <
posy>204</posy>
    <
width>22</width>
    <
height>22</height>
    <
texture>homebutton-small.png</texture>
</
control
so the background one gets drawn over the top of it making the focus one invisible
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #3
Thanks for your quick reply! Unfortunately I'm not really sure if you're asking me a question or pointing out the problem. Could you elaborate for me? Much appreciated!
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #4
the xmls are drawn from top to bottom
if you have the nonfocus background image control (<texture>homebutton-small.png</texture> The one I posted above) below the actual button control in the home.xml file (the one you posted) the nonfocus one will be drawn on top of it making the focus drawn under it ( so you can't see it )
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #5
That makes sense. For some reason this home.xml has "My Weather normal push button" control listed twice along with the other ones that are working. Where as the two that aren't are listed once, i guess they're not repeated below the nonfocus image control like you said. I'll blame whoever made this home.xml!
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #6
or, its just because when I changed the posy on the buttons, I didn't realize i had to change the ones below. I get it now.
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #7
marcusjb Wrote:I'll blame whoever made this home.xml!

Laugh That would be me Wink

Just post the whole thing to pastebin.com if your still having troubles and I'll look at it
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #8
I'm sure I'll get it working now. Why are there two My Pictures controls with different posx and posy, along with the other controls, am I missing something?
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #9
Ok, i've gotten myself pretty lost, and i don't want to start over, so if you don't mind looking at it, it would be great.

http://pastebin.ca/1230788
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #10
Yeah its all to do with what I said the order of the things in the xml getting drawn over the top of the others
try this one
http://pastebin.ca/1230806
note I changed the Y pos and the layout a bit of all the menu ones
find quote
marcusjb Offline
Member
Posts: 56
Joined: Jun 2008
Reputation: 0
Post: #11
works perfectly! You're awesome!
find quote