Ubuntu 8.10 +780G ATI HD3200 screen messed up

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Andrewishy Offline
Junior Member
Posts: 33
Joined: Oct 2008
Reputation: 0
Post: #46
Hi All
Just tried the sudo xbmc and full screen works for me when doing this.
I do have audio issues (whihc i think are addresses in other threads, and the video seems to be speeded up!

Well this solves all my video tear issues and I now have 1080p running smothly (well at least watchable)

Going to work now so will have a play when i'm home but if anyone knows why sudo xbmc works then please post details as although i've been a software engineer for over 10 years i'm rusty to say the least with my linux config

PS. thanks for all the help
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #47
What does this mean?

htpc@htpc-desktop:~$ sudo xbmc
Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.ScreenSaver was not provided by any .service files
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
CRITSEC[0x8bc1e24]: Trying to enter destroyed section.
CRITSEC[0x8bc1e24]: Trying to leave destroyed section.
CRITSEC[0x8bc1e24]: Trying to enter destroyed section.
CRITSEC[0x8bc1e24]: Trying to leave destroyed section.
CRITSEC[0x8bc3320]: Trying to enter destroyed section.
CRITSEC[0x8bc3320]: Trying to leave destroyed section.
CRITSEC[0x8bc3320]: Trying to enter destroyed section.
CRITSEC[0x8bc3320]: Trying to leave destroyed section.
CRITSEC[0x8bc3320]: Trying to enter destroyed section.
CRITSEC[0x8bc3320]: Trying to leave destroyed section.
Segmentation fault (core dumped)

/Söder
find quote
indy5 Offline
Senior Member
Posts: 154
Joined: Jul 2008
Reputation: 0
Post: #48
Are there any devs out there that may be able to shed some light on this issue. Here are some of the general questions that this thread has brought up:

What exactly happens differently when xbmc is run as root? Why would a graphical glitch not occur with "sudo xbmc"? These types of problems typically point towards video driver misconfiguration, or issues with a particular video driver version. If that's the case, wouldn't one still see the same full screen garbage, regardless of running the application as root or not?

I really appreciate any light that can be shed on this.
Thanks!
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #49
Ive now noticed, that, typing "sudo xbmc" in a terminal works in full screen and "xbmc" does not. Even with "sudo xbmc" I have access to my settings in ~/.xbmc/userdata. I can see what skin that is selected behind all the strange screen.

If I start xbmc with the Icon thats made, its like when I type "xbmc".

BUT, one thing I now noticed, is that when I start with the scripts that is found here, to restartXBMC with a remote, it also doesnt work in fullscreen, but I dont have access to the userdata and the skins in ~/.xbmc/userdata

I know this is the wrong thread, but I thought that might could say something?

/Söder
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #50
As I said, i believe my xbmc is very much more slow not, then on Ubuntu 8.04.

Can it possilbe be so that the precompiled version dont work so good in 8.10?

/Söder
find quote
indy5 Offline
Senior Member
Posts: 154
Joined: Jul 2008
Reputation: 0
Post: #51
Any progress on this? I tried going back to 8.04 and now my damn system locks up randomly (black screen, have to hard reset). I can't even get xbmc installed because it locks up before I can pull down the source code.
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #52
I believe that my xorg isnt that healthy ether.
I runned xbmc, with sudo xbmc. Then I shut it down, and my screen after a while went black.

Then I pressed my key bind to the script for run xbmc, (without sudo), and nothing happend. At least I thought it would turn my monitor on again. Then running "top" with Putty, I see this.


PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
5529 root 20 0 362m 58m 22m R 100 3.3 185:41.07 Xorg

100 % cpu on Xorg?

/Söder
find quote
sexus6 Offline
Junior Member
Posts: 25
Joined: Jul 2008
Reputation: 0
Post: #53
Same problem here, not 100% cpu, only full screen messed up. ATI HD 3200 from ASUS M3A78 Motherboard. ATI drivers installed in ubuntu. Intrepid Ibex and Intrepid ppa xbmc packages.

If I run in windowed mode perfect.

If I change fullscreen, at start or from windowed => fails.

- Changes related in this thread about xorg.conf doesn't work for me.

- sudo xbmc fails

-With my plasma HDTV (HDMI) fails.
-Witch normal CRT monitor (VGA) too.

My question is.... all the problem is xorg and ati drivers from INTREPID? Or Intrepid ppa xbmc? or both?

If the problem is ppa, I remove xbmc package and install the old ones (hardy packages). If the problem is INTREPID, I format system and install HArdy.

Please... anyone confirm this?

(Sorry for my poor english)
find quote
i123 Offline
Junior Member
Posts: 1
Joined: Nov 2008
Reputation: 0
Post: #54
I had the same problem (underscan) with Ubuntu 8.04. I have a Gigabyte GA-MA78GM-S2H 780G motherboard. Using the integrated ATI Radeon HD3200-based graphics connected over the HDMI or DVI connection to a 1080p LCD.

I tried the normal Ubuntu 8.10 Desktop Live CD and the problem went away. I think I will upgrade to 8.10 because of this.

Tried to issue the commands below under 8.04 and they were failing. Turned out it's because I was trying to issue them before X was started. From a user session inside X it worked fine. How do I start this script every time when X starts?

Now I have the problem that if I run mplayer in fullscreen mode it displays the movie in 4:3 aspect ratio (as it should) and when it's finished the screen is back to understanned (zoomed about 5% smaller that it should to fill the whole screen). I have to run the shell script below again in order to get it back to fill the whole screen.

hotzenpl0tz Wrote:#!/bin/sh
aticonfig --set-dispattrib=tmds2i,positionX:0
aticonfig --set-dispattrib=tmds2i,positionY:0
aticonfig --set-dispattrib=tmds2i,sizeX:1920
aticonfig --set-dispattrib=tmds2i,sizeY:1080
(This post was last modified: 2008-11-15 07:58 by i123.)
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #55
i123 Wrote:I had the same problem (underscan) with Ubuntu 8.04. I have a Gigabyte GA-MA78GM-S2H 780G motherboard. Using the integrated ATI Radeon HD3200-based graphics connected over the HDMI or DVI connection to a 1080p LCD.

I tried the normal Ubuntu 8.10 Desktop Live CD and the problem went away. I think I will upgrade to 8.10 because of this.

Tried to issue the commands below under 8.04 and they were failing. Turned out it's because I was trying to issue them before X was started. From a user session inside X it worked fine. How do I start this script every time when X starts?

Now I have the problem that if I run mplayer in fullscreen mode it displays the movie in 4:3 aspect ratio (as it should) and when it's finished the screen is back to understanned (zoomed about 5% smaller that it should to fill the whole screen). I have to run the shell script below again in order to get it back to fill the whole screen.

I had the same underscan with Ubuntu 8.10 to.
The script only works for one session, its better to make a permanent change with "aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0"

It will change the parameters to the same that as the script.

You can read here.
http://forum.xbmc.org/showthread.php?tid=39191&page=8

/Söder
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #56
I now use the 8.543 ATI drivers, (standard Ubuntu 8.10) and updated to final xbmc
Still fucked up screen when running.

sudo xbmc works.

/Söder
find quote
Gurney Offline
Member
Posts: 58
Joined: Jul 2008
Reputation: 0
Location: Thionville, France
Post: #57
Hi guys,

My 2 cents : with the new fglrx package in the intrepid-proposed update repository (check the box in the sources manager), no need to sudo xbmc anymore.
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #58
Gurney Wrote:Hi guys,

My 2 cents : with the new fglrx package in the intrepid-proposed update repository (check the box in the sources manager), no need to sudo xbmc anymore.

Can you tell me what box to check exactly? Im in "software sources" now, and the only I have checked is the one for xbmc.

There also is "Ubuntu Intrepid partner and "Ubuntu Intrepid partner (source code)"

Or am I in the wrong place?

Is this the ATI 8.552 that will be installed? The drivers that wouldnt work with a manual install on Ubuntu 8.10?

EDIT: I think I found what you mean, but I cant see any suggested updates about fglrx. But look in this screen shot. I can see a 8.522, but it say its already installed? And thats not what ATI control center says.

[Image: print.jpg]

I tryed to install 8.552 manualy, but it didnt work, and I went back to Ubuntu 8.10 standard.... How do I install the 8.552?

/Söder
(This post was last modified: 2008-11-18 12:47 by soder.)
find quote
Gurney Offline
Member
Posts: 58
Joined: Jul 2008
Reputation: 0
Location: Thionville, France
Post: #59
Hello Soder,

I'm not a specialist, but it looks like you just have the latest version of fglrx-modaliases, the driver itself still being 8.543 (look at the 2 lines just above the selected one on your screenshot). Try to update these ones (you can select the "versions" tab with the "properties" menuitem of the right-click menu)

The program sources management tool is found in the System menu -> Administration -> update sources (don't know the english, in french it is "Sources de mise à jour").

Then you go to the "Updates" tab, "Ubuntu updates" subsection, and check the "pre-released updates" box.

Hope this helps!
Cheers,
Etienne
find quote
soder Offline
Posting Freak
Posts: 1,330
Joined: Feb 2008
Reputation: 2
Location: Sweden
Post: #60
Gurney Wrote:Hello Soder,

I'm not a specialist, but it looks like you just have the latest version of fglrx-modaliases, the driver itself still being 8.543 (look at the 2 lines just above the selected one on your screenshot). Try to update these ones (you can select the "versions" tab with the "properties" menuitem of the right-click menu)

The program sources management tool is found in the System menu -> Administration -> update sources (don't know the english, in french it is "Sources de mise à jour").

Then you go to the "Updates" tab, "Ubuntu updates" subsection, and check the "pre-released updates" box.

Hope this helps!
Cheers,
Etienne

It looks like you was right....I had the 8.552. But can it really be good to only hade THAT in version 8.552?

Shall I downgrade? Its all very strange, cause I tried to install 8.552 but I couldnt. And it all went wrong, and I had to disable all the ATI -stuff, enter Ubuntu without it, and then download the standard Ubuntu 8.10 drivers again. But apperently I now had the 8.552... very strange...

I will try to downgrade again...

/Söder
find quote
Post Reply