[PATCH] LaunchPlayer - External Video Player Launcher (to launch third-party players)

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
tvont Offline
Senior Member
Posts: 109
Joined: Oct 2008
Reputation: 0
Post: #361
wayland Wrote:anyone know how to setup externalplayer with mpc-hc? i tried last night with build "-Rev16962-jester-externalplayer" but could only get mpc to start in the background

If available in mpc, try using opengl for videooutput
find
ethanmcdonald Offline
Member
Posts: 53
Joined: Aug 2008
Reputation: 0
Post: #362
Does anyone have a win32 link for the LaunchPlayer build, plugin or patch?
I did a search in this discussion but could not find anything but a C++ source.

Thanks for the help... Smile


XBMC 11: EDEN | XBMC | HDDVD+Blu-Ray ISO playback & Blu-ray player
PC - HTPC CASE: APEX DM-318 Black Steel MB: ASUS M3N78-EM/NVIDA8300 | CPU: AMD Athlon 64 X2 5000+ RAM: 2gb DDR2 1066
HD: 70gb(System) DVDROM: LG GGW-H20L Blu-Ray/HDDVD OS: Win7 | NAS: 3-terabytes(RAID 5)
(This post was last modified: 2009-01-10 00:56 by ethanmcdonald.)
find
wayland Offline
Junior Member
Posts: 27
Joined: Dec 2005
Reputation: 0
Post: #363
there doesnt seem to be a obvious option to use opengl, if you have never used it you can see the output optionshere. also these are the switches, i tried the obvious ones like /fullscreen and using a .bat file like someone reccomended a few pages back but nothing seemed to work
find
ethanmcdonald Offline
Member
Posts: 53
Joined: Aug 2008
Reputation: 0
Post: #364
And of course as soon as I post it I find Jester's build.

http://ocs.nl/xbmc/

Tongue


XBMC 11: EDEN | XBMC | HDDVD+Blu-Ray ISO playback & Blu-ray player
PC - HTPC CASE: APEX DM-318 Black Steel MB: ASUS M3N78-EM/NVIDA8300 | CPU: AMD Athlon 64 X2 5000+ RAM: 2gb DDR2 1066
HD: 70gb(System) DVDROM: LG GGW-H20L Blu-Ray/HDDVD OS: Win7 | NAS: 3-terabytes(RAID 5)
find
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #365
wayland Wrote:anyone know how to setup externalplayer with mpc-hc? i tried last night with build "-Rev16962-jester-externalplayer" but could only get mpc to start in the background
Something broke between this build and the previous one. I have the same problem with Zoom Player, that it worked flawlessly before.
My advancedsettings.xml:
Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>C:\Program Files\Zoom Player\zplayer.exe</filename>
  <args>/F /Q /PLAY</args>
  <forceontop>false</forceontop>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>
find
tvont Offline
Senior Member
Posts: 109
Joined: Oct 2008
Reputation: 0
Post: #366
wayland Wrote:there doesnt seem to be a obvious option to use opengl, if you have never used it you can see the output optionshere. also these are the switches, i tried the obvious ones like /fullscreen and using a .bat file like someone reccomended a few pages back but nothing seemed to work

Does it work while XBMC is in windowed mode?
find
Jester Offline
XBMC for iOS* forums Moderator
Posts: 980
Joined: Oct 2008
Reputation: 10
Post: #367
the patch has made it in the main SVN, so all SVN build from 16984 will have the externalplayer with it Smile

Current XBMC Platform: ATV2
Extra XBMC Platform: Raspberry Pi
Read the iOS FAQ
find
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #368
Jester Wrote:the patch has made it in the main SVN, so all SVN build from 16984 will have the externalplayer with it Smile
Hi Jester. I noticed that, and it's great, but basic functionality is broken now Sad Sad

Could it maybe be that someone took my suggestion and forceontop has to be set to true?
find
tvont Offline
Senior Member
Posts: 109
Joined: Oct 2008
Reputation: 0
Post: #369
Compiled on OSX.

1 error in externalplayer.cpp, 209:

g_RemoteControl.Disconnect();

has to be changed in:

#ifdef HAS_LIRC
g_RemoteControl.Disconnect();
#endif

then it builds.
find
topfs2 Offline
Team-XBMC Developer
Posts: 4,004
Joined: Dec 2007
Reputation: 10
Post: #370
fixed in svn, thx tvont

If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
find
WiSo Offline
Team-XBMC Developer
Posts: 2,733
Joined: Oct 2003
Reputation: 0
Location: Germany
Post: #371
Please keep the user support topics in the Windows user forum.
This is for developers talk only.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
Jester Offline
XBMC for iOS* forums Moderator
Posts: 980
Joined: Oct 2008
Reputation: 10
Post: #372
Windows thread:
http://forum.xbmc.org/showthread.php?p=267496

Current XBMC Platform: ATV2
Extra XBMC Platform: Raspberry Pi
Read the iOS FAQ
find
tvont Offline
Senior Member
Posts: 109
Joined: Oct 2008
Reputation: 0
Post: #373
Builds fine now on OSX (used current Xcode project file)

BUT: I have a fast running XBMC window w/o skin now (means open, empty window, but reacts upon "close" etc. No Content)

I built skins, TEX, after all built successfully, I built XBMC.app (which is ~102MB)

Could anyone help with that, please?
(This post was last modified: 2009-01-10 17:29 by tvont.)
find
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #374
WiSo Wrote:Please keep the user support topics in the Windows user forum.
This is for developers talk only.
Not to be a smartass or anything, but I reported the patch being broken before it got committed to SVN, that's why I was commenting here.
find
Jester Offline
XBMC for iOS* forums Moderator
Posts: 980
Joined: Oct 2008
Reputation: 10
Post: #375
some fixes and improvements are done on the windows support thread, i've put the changes in a new trac ticket with the diff and they seem to work fine, could this be put in the main SVN ?

thanks

http://trac.xbmc.org/ticket/5656

Current XBMC Platform: ATV2
Extra XBMC Platform: Raspberry Pi
Read the iOS FAQ
find
Thread Closed