Fanart While Scrolling

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rainmaker002 Offline
Junior Member
Posts: 39
Joined: Sep 2008
Reputation: 0
Post: #1
Quote:Quote:
Originally Posted by fluidman View Post
i have the same "problem" but only in horizonz in aeon it wont jump back to the default background. would be great if there was an option to that "bug" turn off
Not sure what "bug" you're referring to, as this has been covered before. The lack of instantaneous fanart switching is on purpose, to prevent scrolling speed suffering as the program tries to desperately load one fanart file after another.

Now the program only loads fanart when you've paused over an item for a couple of seconds.

Just continuing this discussion here instead of in the main thread...

Previous versions of the skin did not exhibit this behaviour, nor does Aeon (from the last time I ran it). It would be swell if those of us who do not have a scrolling speed problem (because we have fast processors/lots of memory) could have an option to turn this back on. I understand the issue for xbox's and slow pc's, and don't know if it would be a lot of work to re-implement it by choice but hey, that is my request.

Thanks!
find quote
rainmaker002 Offline
Junior Member
Posts: 39
Joined: Sep 2008
Reputation: 0
Post: #2
Quote:well... yeah, the immediate fanart idea didn't go down to well with the masses, and thus, i decided to remove it... sorry... what u need to do if u want it back... is edit the... MyVideoNav.xml and change the control which is pointing to fanart_image and has Control.IsVisible(899) and Control.IsVisible(57) in its visibility tag... remove the Control.IsVisible(899) from that visibility tag and it should show up immediately... sorry, can't sort it out for u, because my files are unavailable on this computer... hope u can get it to work!!!!

Did a little searching and xb2iris seems to have already posted the answer. I tried this fix and it indeed works (just search for Control.IsVisible(899) in the xml file and delete the reference. The only hitch is that it doesn't show random fanart for movies without their own, but its better than before with fanart only loading on hover.
find quote
xb2iris Offline
Skilled Skinner
Posts: 586
Joined: Jun 2008
Reputation: 0
Location: London, UK
Post: #3
thanks for helping out rainmaker002...
find quote
rolandcs Offline
Junior Member
Posts: 3
Joined: Nov 2008
Reputation: 0
Post: #4
rainmaker002 Wrote:Did a little searching and xb2iris seems to have already posted the answer. I tried this fix and it indeed works (just search for Control.IsVisible(899) in the xml file and delete the reference. The only hitch is that it doesn't show random fanart for movies without their own, but its better than before with fanart only loading on hover.

Thanks for sharing your findings rainmaker. I'm still having trouble getting this to work on my own. I've removed the 'Control.IsVisible(899) tag without any change. I am running this on Plex, could that have anything to do with it?
find quote
Ayla Offline
Fan
Posts: 605
Joined: Feb 2008
Reputation: 0
Post: #5
I'm using Plex too and have a fast machine.

Anyone had any luck getting this "fix" to work?
find quote
123ccd Offline
Junior Member
Posts: 40
Joined: Nov 2008
Reputation: 0
Post: #6
I deleted
+ Control.IsVisible(899)
from MyVideoNav.xml, I'm using Plex and it works for me.
Edit: it works in info view type, but not in showcase.
(This post was last modified: 2008-11-30 23:36 by 123ccd.)
find quote
Ayla Offline
Fan
Posts: 605
Joined: Feb 2008
Reputation: 0
Post: #7
123ccd Wrote:I deleted
+ Control.IsVisible(899)
from MyVideoNav.xml, I'm using Plex and it works for me.
Edit: it works in info view type, but not in showcase.

I have a Core 2 Duo 2.8GHz, 4GB RAM, 24" iMac.

When I remove the "Control..... 899)" line, Plex lags really bad when scrolling through movies in Info view.

Is it the same for you?
find quote
xb2iris Offline
Skilled Skinner
Posts: 586
Joined: Jun 2008
Reputation: 0
Location: London, UK
Post: #8
wish i had the time to help out here... pitty im in an internet cafe... but lets just say, instantaneous fanart would make a lot of people complain... and they did when it was like that before... so, ill try and help out later when i give it a think... in a rush
find quote
123ccd Offline
Junior Member
Posts: 40
Joined: Nov 2008
Reputation: 0
Post: #9
I have a Core 2 Duo 2.66GHz, 4GB RAM, 20" iMac and yes, Plex lags badly when you try to scroll fast.

But I like to use instantaneous fanart, because now I have in my home menu Animations, HD-movies, Bond, Classics and Concerts instead of movies. And other than Bond fanart behind Bond movies doesn't feel right (or other movie art behind animations or movie art behind concerts). And because I have these categories, I don't have to scroll so much anymore.

If I could use custom fanart with different smart playlists, my system would be perfect for me.
find quote
Ayla Offline
Fan
Posts: 605
Joined: Feb 2008
Reputation: 0
Post: #10
I tried to change "Control.IsVisible(899)" to "Control.IsVisible(199)", to make the delay before fanart appears shorter (if I completely remove the line, Plex lags badly).

But, with "199" no fanart appears, what are the correct values to input, to make the delay time shorter (and is the (899) number miliseconds or?)?

/Martin
find quote
xb2iris Offline
Skilled Skinner
Posts: 586
Joined: Jun 2008
Reputation: 0
Location: London, UK
Post: #11
Ayla, it lags becuase there isn't a delay anymore... u need to change the animation in that particular Control... those controls are found in Includes.xml... u should search for which ever one ur looking for... for instance... in info it uses Control 899, so search for id="899" and change one of the animations delays, which is currently 3000, so u could search for that as well, if u wanted... change 3000 to 1000 or so...

i know this isn't super dooper helpful and a bit hard to do, but unfortunately, i'm limited to talking to help out... no code to reference... sorry
find quote
123ccd Offline
Junior Member
Posts: 40
Joined: Nov 2008
Reputation: 0
Post: #12
Thanks xb2iris! Works great.

It can be found in here in Includes.xml:

<include name="movieinfo3">
<control type="group" id="899">
...
<effect type="fade" delay=" " (for fanart)
<effect type="slide" delay=" " (for info panel)
find quote
xb2iris Offline
Skilled Skinner
Posts: 586
Joined: Jun 2008
Reputation: 0
Location: London, UK
Post: #13
great to hear it worked man... it was a quick explain... so im glad u caught it...
find quote
Ayla Offline
Fan
Posts: 605
Joined: Feb 2008
Reputation: 0
Post: #14
Thank you xb2iris and 123ccd !

Another question, if I may Smile

When jumping forward or backward in a playing movie, the OSD in the bottom shows where you are in the movie, but it disappears too soon, I think.

Where do I tweak the setting so that it stays on screen a little longer before fading out?
find quote
MrTourettes Offline
Fan
Posts: 330
Joined: Dec 2008
Reputation: 1
Location: Cambridge
Post: #15
123ccd Wrote:Thanks xb2iris! Works great.

It can be found in here in Includes.xml:

<include name="movieinfo3">
<control type="group" id="899">
...
<effect type="fade" delay=" " (for fanart)
<effect type="slide" delay=" " (for info panel)


I used this method to display the fanart quicker in my movies section. Can someone tell me if it is possible to use this same method for tv shows as well?
find quote
Post Reply