[LINUX] Ubuntu PulseAudio Sound Issues

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
sparkie Offline
Junior Member
Posts: 10
Joined: Sep 2008
Reputation: 0
Post: #1
Here is some reading material if you've upgraded to Ubuntu Intrepid 8.10
http://ubuntuforums.org/showthread.php?t=866965
find
althekiller Offline
Retired Team-Kodi Member
Posts: 5,002
Joined: May 2004
Reputation: 12
Post: #2
Nice find, there's also a link in the first post to similar for 8.04. To all those with alsa errors in your logs, check this out.
find
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #3
Pulse audio is no longer an issue after the developer decided to downmix the 5.1 audio to 2 channels by default in video playing.

To set up put the following into the system wide configuration file /etc/asound.conf

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

pcm.pulse {
type pulse
}
ctl.pulse {
type pulse
}


The xbmc client and pulseaudio server in my setup are both running the 8.10 with unmodified pulseaudio package.

I am more than happy to see the changes as now I can streaming the audio to the my centralised pulseaudio server.
find
LAW-Mastermind Offline
Member
Posts: 98
Joined: Sep 2008
Reputation: 0
Location: Germany
Post: #4
WOOT? 5.1 is downmixed to 2 channels? Alway or just if you use Pulseaudio? How can i enable 5.1?
find
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #5
LAW-Mastermind Wrote:WOOT? 5.1 is downmixed to 2 channels? Alway or just if you use Pulseaudio? How can i enable 5.1?

SPDIF passthrough will always give you 5.1 I would guess.
find
vajonam Offline
Donor
Posts: 356
Joined: Sep 2008
Reputation: 0
Location: Toronto, Canada
Post: #6
I've tried all that, the playback still eventually freezes. when i hit x to stop the plyaback XMBC freezes until i kill -9 on pulseaudio

does any one else have this working? on intrepid?
find
LAW-Mastermind Offline
Member
Posts: 98
Joined: Sep 2008
Reputation: 0
Location: Germany
Post: #7
I´m using xbmc together with 8.10 , i made a script to startup
Quote:pulseaudio -k
xbmc
find
kipfel Offline
Junior Member
Posts: 11
Joined: Nov 2008
Reputation: 0
Post: #8
Is XBMC going to support pulseaudio in the near future? Because i can't get my surround sound to work in XBMC.
find
vajonam Offline
Donor
Posts: 356
Joined: Sep 2008
Reputation: 0
Location: Toronto, Canada
Post: #9
I find if do the kill pulseaudio trick, then my menu sounds dont work, but movie audio works okay. do you menu navigation sounds still work?
find
eversmann Offline
Junior Member
Posts: 29
Joined: Jun 2008
Reputation: 0
Location: Malaga, Spain
Post: #10
For the, everything works (even the sound "ticks" in the menu) when i kill pulseaudio. So the script:
pulseaudio -k
sleep 2
xbmc
pulseaudio -D

works great ;-)
find
kipfel Offline
Junior Member
Posts: 11
Joined: Nov 2008
Reputation: 0
Post: #11
I use that script too, but then I can't get the surround sound to work.
find
topfs2 Offline
Team-Kodi Developer
Posts: 4,048
Joined: Dec 2007
Reputation: 10
Post: #12
kipfel Wrote:Is XBMC going to support pulseaudio in the near future? Because i can't get my surround sound to work in XBMC.

maybe Wink

Should be in XBMC Svn when we have decided on how to implement it good (mostly need to take care on desktops that doesnt use it, ie KDE)

Cheers

If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

[Image: badge.gif]

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
find
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #13
The pulseaudio server running with the following command on the centralised sound server:

/usr/bin/pulseaudio --system --daemonize --high-priority --log-target=syslog --disallow-module-loading=1

On the client all I need to do is to define the

default-server = ; set this to ip where your pulse server is running

in /etc/pulse/client.conf

and rest just works. The client and server both running the latest stock Ubuntu 8.10.

On the client, the pulse audio was automatically started as I log in the GDM with the following command line (I think they are default for ubuntu users)

/usr/bin/pulseaudio -D --log-target=syslog
/usr/lib/pulseaudio/pulse/gconf-helper

I did not try running the pulseaudio server on the same machine as the XBMC client. But I would suggest to run the pulseaudio (on the same machine as the XBMC client) as a system service and disable the user's (XBMC) pulseaudio instance to start up automatically.
(This post was last modified: 2008-11-17 21:28 by s7mx1.)
find
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #14
Topfs2 Wrote:maybe Wink

Should be in XBMC Svn when we have decided on how to implement it good (mostly need to take care on desktops that doesnt use it, ie KDE)

Cheers

Hello,

I was having the impression you secretly made some magic code for the pulseaudio support.
find
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #15
Topfs2 Wrote:maybe Wink

Should be in XBMC Svn when we have decided on how to implement it good (mostly need to take care on desktops that doesnt use it, ie KDE)

Cheers

Can it be ported to XBOX branch? Will be thrilled if it's true.
find
Thread Closed