[LINUX] HOW-TO install XBMC for Linux on Debian Lenny

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rogerdugans Offline
Junior Member
Posts: 9
Joined: Dec 2008
Reputation: 0
Thumbs Up  [LINUX] HOW-TO install XBMC for Linux on Debian Lenny
Post: #1
XBMC can be run in Debian Lenny.

This is a quick and basic guide to the general steps not a detailed how-to, although one may follow as I have the time.

Basic Guide:
1) Install Debian Lenny- preferably using XFCE
2) Update the system fully: apt-get update, apt-get upgrade reboot (likely a new kernel version) and then upgrade again to ensure ALL updates are installed.
3) Edit the /etc/apt/sources.list file to add contrib and non-free
4) install 3d drivers for video, preferably the "Debian Way." Ensure that 3d is working properly.
4) Here comes one of the harder parts: find every codec and library related to multimedia that you can- ensure that you include related development code wherever possible (packages ending in "-dev" and beginning with "lib")
5) Test that you can actually playback media using a player already installed
6) Download XBMC from svn- (mkdir xbmc, then cd xbmc in a terminal first. then run svn to download)
svn co http://xbmc.svn.sourceforge.net/svnroot/...linuxport/
7) Open up the readme.LINUX file and install every dependency and associated "-dev" you can using apt. (NOTE that there were a couple that I was NOT able to find as listed.) If there is a "-dev" available for a file that is in the readme that doesn't SAY the -dev is required, I installed it anyway.
8) Start a terminal session in the linuxport/XBMC directory and run "./configure."
If this stops at any point something is missing: find it, install it and run configure again until it completes successfully.
9) After "./configure" run "make" - you should have no errors at this point, but if you do, install or configure whatever causes the error.
10) Change over to the root account- "su root" (Note that I did all steps IN the root account, but this should not be required for configure or make.)
10) Run "make install."
11) Once "make install" has completed successfully, exit the root account.
12) Start XBMC and enjoy!


Again, this is just a rough guide and I hope to improve on it soon.
The total time for my installation yesterday (after failed previous attempts) was about 4 hours to install Lenny, update it and then prepare to compile XBMC. 3 Hours of that was installing codecs, libraries and satisfying dependencies.
Configure ran fairly quickly, make ran while I was sleeping.
Make install ran this morning in just a minute or 3.

XBMC is currently playing a 1080i movie that I have been testing with pretty well. Smile

Notes on this:
I have tested XBMC in Ubuntu (installed JUST for that purpose!) and while the install was easier, playback of this test film was not good on this same exact hardware.
I have tested other solutions as well- Elisa and MythTV for example, and while MythTV does fine, if a tuner card is not being used.... well, it is not optimal.

XBMC on Debian Lenny with a basic install (plus code required for XBMC) runs far better than XBMC and a basic install of Ubuntu.

The hardware I am using is a P4 2.4Ghz chip, 2GB of DDR and an AGP NVidia 6600GT video card.

Thanks to the developers of XBMC-
I am not a console fan, or user, but I am glad you folks are and that you have made your work available for architectures other than the XBox. Smile

More to follow.
find quote
panga Offline
Junior Member
Posts: 1
Joined: Dec 2008
Reputation: 0
Post: #2
Could you post a list of the codecs you used? It would be nice.
find quote
edwinrajadurai Offline
Junior Member
Posts: 1
Joined: Apr 2009
Reputation: 0
Smile  Dependencies - Install
Post: #3
Use http://debian-multimedia.org/ - it saved a lot of time for me!
find quote
jack83 Offline
Junior Member
Posts: 25
Joined: Mar 2008
Reputation: 0
Location: Germany
Post: #4
rogerdugans Wrote:4) Here comes one of the harder parts: find every codec and library related to multimedia that you can- ensure that you include related development code wherever possible (packages ending in "-dev" and beginning with "lib")
5) Test that you can actually playback media using a player already installed

You don't need any codecs at all for xbmc. The rest of your steps are OK, I just tried it myself Big Grin
find quote
halfasleep Offline
Junior Member
Posts: 1
Joined: May 2009
Reputation: 0
Post: #5
For the lazy:

Code:
mkdir XBMC && cd XBMC

svn co http://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/linuxport/XBMC

sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm automake cmake gperf unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libsdl-sound1.2-dev libsdl-stretch-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl4-dev x11proto-xinerama-dev libxinerama-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbis-dev libmysqlclient15-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev

./configure && make && sudo make install
find quote
Igorokk Offline
Junior Member
Posts: 2
Joined: Jun 2009
Reputation: 0
Post: #6
that feature is removed from that T3CH build, it doesnt work for me either. Also I wouldnt use the T3CH builds as they are prototypes and can goof up alot. Mine crashed 4 times already when i just booted up my xbox.
find quote
Shish Offline
Junior Member
Posts: 7
Joined: Jun 2009
Reputation: 0
Post: #7
The above instructions are slightly inaccurate (just tried on a fresh lenny install), a corrected version:

Code:
sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm automake cmake gperf unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libsdl-sound1.2-dev libsdl-stretch-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl4-dev x11proto-xinerama-dev libxinerama-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbis-dev libmysqlclient15-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libenca-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate0-dev

svn co http://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/linuxport/XBMC

cd XBMC

./configure && make && sudo make install

Changes are:
removed libfaac-dev (doesn't exist?)
added libsamplerate0-dev (required)
first install subversion, *then* use it Tongue
svn creates the XBMC directory, no need to create it manually

Aside from those minor tweaks, it all works wonderfully :-)
find quote
dpengu Offline
Junior Member
Posts: 1
Joined: Jul 2009
Reputation: 0
Post: #8
An addition to Shish's post:

apt-get install libmms-dev libxtst-dev zip

(On a fresh install of Lenny, without any window manager, just X. Maybe these libraries will be installed with GNOME, I'm not sure.)

===
real 37m38.645s
user 34m20.625s
sys 2m11.112s
===
with,
model name : AMD Athlon™ 64 Processor 2800+
cpu MHz : 1808.806
find quote
flitter Offline
Junior Member
Posts: 3
Joined: Oct 2010
Reputation: 0
Post: #9
I compiled the SVN package a week ago for lenny and had to install the following additional packages in order to get compilation to work:

libwavpack-dev libmpeg2-4-dev libmodplug-dev libfaad-dev libsmbclient-dev libmicrohttpd-dev yasm

For some reason (I think it was for getting ./bootstrap to work) I had to install gettext and cvs as well.

Finally I changed all occurings of "-DSQUISH_USE_SSE=2 -msse2" in the tree to "-DSQUISH_USE_SSE=1 -msse" in order to get the code to compile. Don't forget to do a "make clean" before!
find quote
gpuk Offline
Junior Member
Posts: 7
Joined: Jun 2010
Reputation: 0
Post: #10
I've posted an updated, more in depth guide for Lenny + Dharma (based on Acer Revo hardware) here: http://forum.xbmc.org/showthread.php?tid=92622
find quote
bigblockmopar Offline
Junior Member
Posts: 1
Joined: Jun 2011
Reputation: 0
Post: #11
Hey All,

My first post.

Lenny, relatively recent (under 2 months) desktop install of Debian Lenny on AMD64.

I downloaded the current source tarball. The extra packages configure squawked about can be downloaded here:

sudo apt-get install libmms-dev libmpeg2-4-dev libmpeg2-dev libwavpack-dev libssl-dev gettext cvs libmodplug-dev libfaad-dev libsmbclient-dev libxtst-dev libmicrohttpd-dev libiso9660-dev

With those additions, configure finished without problems, and my CPU fan is currently running on high as make does her work.

I'm still new to Debian, but I've been using and/or administering Unix/Linux systems for almost 20 years. AFAIK, trying to install an existing package poses no problem... I'll leave that to the Debian experts.

Lawrence
find quote