Control XBMC with firefly remote

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
amirp Offline
Junior Member
Posts: 6
Joined: Dec 2008
Reputation: 0
Post: #1
Hi ,
I just installed XBMC (used to work with MP) and my firefly remote control is not fully working.
How can i fix it , for example i want that the main firefly button will bring me to homepage.
and other things as mytv/myvideo buttons
find quote
tknice1 Offline
Member
Posts: 89
Joined: Jul 2008
Reputation: 0
Post: #2
I have the firefly remote and use EventGhost with it which works great. Just download and install EventGhost and then search these forums for the XBMC plugin for EventGhost. Once you install that, its just a matter of mapping your firefly remote buttons to each XBMC function.

Everything I've needed is right there.

-Tom
find quote
lotis Offline
Junior Member
Posts: 4
Joined: Dec 2008
Reputation: 0
Post: #3
Looking for such a configuration file to EventGhost for XBCM, but I can not find it, can you help?
find quote
josue.camargo Offline
Junior Member
Posts: 1
Joined: Jan 2009
Reputation: 0
Post: #4
I use this profile file:

http://forums.snapstream.com/vb/showthre...661&page=4

With nothing but the firefly software alone.

I think works OK
find quote
rausch101 Offline
Fan
Posts: 582
Joined: Sep 2006
Reputation: 1
Location: Washington D.C.
Post: #5
To Windows 7 users:

The firefly remote is completely plug-and-play with Windows 7 and Eventghost. I didn't install a thing - just plugged in the receiver, added the X10 remote plugin in EventGhost and mapped the buttons.
find quote
rebaker501 Offline
Junior Member
Posts: 18
Joined: Sep 2008
Reputation: 0
Post: #6
I have Windows 7 x86 and EventGhost. Firefly receiver is seen as X10 by Windows 7 and EventGhost is receiving commands. The only problem I have, is that I have to press buttons twice to get a response in EventGhost. Any thoughts?
find quote
rausch101 Offline
Fan
Posts: 582
Joined: Sep 2006
Reputation: 1
Location: Washington D.C.
Post: #7
rebaker501 Wrote:I have Windows 7 x86 and EventGhost. Firefly receiver is seen as X10 by Windows 7 and EventGhost is receiving commands. The only problem I have, is that I have to press buttons twice to get a response in EventGhost. Any thoughts?

I have Windows 7 x64 with 0.3.7.r990 eventghost and a firefly and this doesn't happen to me.

Do you have "X10: SnapStream Firefly" as your plugin? What version eventghost are you using? Does it register anything in the log on the left pane in eventghost when you press a button the first time?

Have a question? First try the XBMC online-manual and FAQ. Also: How to submit a debug log
find quote
rebaker501 Offline
Junior Member
Posts: 18
Joined: Sep 2008
Reputation: 0
Post: #8
I have 0.3.7.r1194 Eventghost. Nothing is registering in EventGhost log when I press button once. I am using the X10: Snapstream Firefly plugin. I am going to try it on my x64 Windows laptop tomorrow.
find quote