Xbmc windows + IRSS + Imon remote. confused

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Mirkwood Offline
Junior Member
Posts: 5
Joined: Jan 2009
Reputation: 0
Post: #1
Ive read and searched so much. but now im just confused and could really use some simple pointers in the right direction, on how to get the final bit to work.

I finally got IRSS(IR Server Suite - Test Build 1.4.2.2391) to respond to my Imon remote fine?. looking at the Input service log

Code:
2009-01-10 06:19:07.796875 - Info:    Starting Input Service ...
2009-01-10 06:19:08.109375 - Warn:    No transmit plugin loaded
2009-01-10 06:19:08.171875 - Info:    Started in Server Mode
2009-01-10 06:19:08.250000 - Info:    Receiver plugin started: "iMon"
2009-01-10 06:19:08.250000 - Info:    Input Service started
2009-01-10 06:19:12.156250 - Debug:    iMon generated a remote event: 1250
2009-01-10 06:19:12.156250 - Debug:    SendToAll(RemoteEvent, Notify)
2009-01-10 06:19:12.171875 - Debug:    iMon generated a remote event: 1246
2009-01-10 06:19:12.171875 - Debug:    SendToAll(RemoteEvent, Notify)
2009-01-10 06:19:12.281250 - Debug:    iMon generated a remote event: 1250
2009-01-10 06:19:12.281250 - Debug:    SendToAll(RemoteEvent, Notify)
2009-01-10 06:19:12.343750 - Debug:    iMon generated a remote event: 1244

Or is there something wrong there. have a feeling there might beRolleyes.

Also then... it is ONLY keymap.xml i need to config? to get it to recive the commands from IRSS?, it dosent need some plugin or dll does it?. id guess keymap.xml will need the event codes from IRSS input log corresponding to my remote buttons etc.. But, how and where exactly to put them in right, im not sure.. ive tried some but no luck.


And... IRSS seems like running ok, but then when launching Xbmc and trying. IRSS will bug?. and it wont "seem" to work again befor i restart it and shut down xbmc.
this is what it starts saying at every button push when xbmc is started:

Code:
2009-01-10 07:07:03.453125 - Debug:    Server message received: RegisterClient, Request
2009-01-10 07:07:03.453125 - Info:    Registered a client
2009-01-10 07:07:03.453125 - Debug:    SendTo(RegisterClient, Response, Success)
2009-01-10 07:07:05.000000 - Debug:    Server message received: DetectedReceivers, Request
2009-01-10 07:07:05.000000 - Info:    Detect Receivers ...
2009-01-10 07:07:06.750000 - Debug:    SendTo(DetectedReceivers, Response)
2009-01-10 07:07:06.750000 - Debug:    Server message received: AvailableReceivers, Request
2009-01-10 07:07:06.765625 - Debug:    SendTo(AvailableReceivers, Response)
2009-01-10 07:07:06.765625 - Debug:    Server message received: ActiveReceivers, Request
2009-01-10 07:07:06.765625 - Debug:    SendTo(ActiveReceivers, Response)
2009-01-10 07:07:16.109375 - Debug:    Server message received: UnregisterClient, Request, ForceNotRespond
2009-01-10 07:07:16.109375 - Info:    Unregistered a client
(This post was last modified: 2009-01-10 17:07 by Mirkwood.)
find quote