XBMC crashes immediately after start-up

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
beforeseven Offline
Junior Member
Posts: 24
Joined: Feb 2009
Reputation: 0
Post: #1
XBMC Atlantis has been working fine on my Apple TV for a couple of weeks now (bar the occasional crash). However, tonight XBMC crashes immediately after starting up. I get the XBMC splash screen, then the home screen for about 2 seconds before the Apple TV spontaneously resets and boots up again. I've tried manually powering down the Apple TV (i.e. pulling out the plug), but no luck.

Any ideas? Help appreciated! I've included my log below.

18:50:05 T:2684407808 M: 29061120 NOTICE: Mapping drive Z to /tmp/xbmc
18:50:05 T:2684407808 M: 29057024 NOTICE: Mapping drive Q to /Applications/XBMC.app/Contents/Resources/XBMC
18:50:05 T:2684407808 M: 29052928 NOTICE: Mapping drive U to /Users/frontrow/Library/Application Support/XBMC
18:50:05 T:2684407808 M: 29052928 NOTICE: Mapping drive T to /Users/frontrow/Library/Application Support/XBMC/userdata
18:50:05 T:2684407808 M: 29052928 WARNING: CopyFile, cant open file </Applications/XBMC.app/Contents/Resources/XBMC/userdata/Lircmap.xml>. trying to use lowercase </applications/xbmc.app/contents/resources/xbmc/userdata/lircmap.xml>
18:50:05 T:2684407808 M: 29052928 ERROR: CopyFile - cant open source file </Applications/XBMC.app/Contents/Resources/XBMC/userdata/Lircmap.xml>
18:50:05 T:2684407808 M: 29052928 NOTICE: -----------------------------------------------------------------------
18:50:05 T:2684407808 M: 29052928 NOTICE: Starting XBMC, Platform: Mac OS X. Built on Dec 18 2008
18:50:05 T:2684407808 M: 29052928 NOTICE: Q is mapped to: /Applications/XBMC.app/Contents/Resources/XBMC
18:50:05 T:2684407808 M: 29052928 NOTICE: The executable running is: /Applications/XBMC.app/Contents/MacOS/XBMC
18:50:05 T:2684407808 M: 29052928 NOTICE: Log File is located: /Users/frontrow/Library/Logs/xbmc.log
18:50:05 T:2684407808 M: 29052928 NOTICE: -----------------------------------------------------------------------
18:50:05 T:2684407808 M: 29052928 NOTICE: Setup SDL
18:50:05 T:2684407808 M: 28409856 NOTICE: load settings...
18:50:05 T:2684407808 M: 28409856 NOTICE: Mapping drive P to /Users/frontrow/Library/Application Support/XBMC/userdata
18:50:05 T:2684407808 M: 28409856 NOTICE: loading /Users/frontrow/Library/Application Support/XBMC/userdata/guisettings.xml
18:50:06 T:2684407808 M: 63512576 NOTICE: Getting hardware information now...
18:50:06 T:2684407808 M: 63512576 NOTICE: Checking resolution 12
18:50:06 T:2684407808 M: 63500288 NOTICE: Loaded advancedsettings.xml from /Users/frontrow/Library/Application Support/XBMC/userdata/advancedsettings.xml
18:50:06 T:2684407808 M: 63500288 NOTICE: Getting hardware information now...
18:50:06 T:2684407808 M: 63500288 NOTICE: Checking resolution 12
18:50:06 T:2684407808 M: 63500288 NOTICE: /Users/frontrow/Library/Application Support/XBMC/userdata/sources.xml
18:50:06 T:2684407808 M: 63500288 ERROR: Missing or invalid <name> and/or <path> in source
18:50:06 T:2684407808 M: 52441088 NOTICE: start dvd mediatype detection
18:50:06 T:2684407808 M: 52408320 NOTICE: initializing playlistplayer
18:50:06 T:2684407808 M: 52404224 NOTICE: DONE initializing playlistplayer
18:50:06 T:2684407808 M: 52404224 NOTICE: load default skin:[MediaStream]
18:50:07 T:2684407808 M: 47464448 ERROR: Window Translator: Can't find window settingscategory
18:50:07 T:2684407808 M: 47480832 ERROR: Error evaluating boolean expression !Window.Previous(0) + !Window.Previous(SettingsCategory) + !Window.Previous(1001) + !Window.Previous(130) + !Window.Previous(34)
18:50:07 T:2684407808 M: 46592000 NOTICE: initialize done
18:50:07 T:2684407808 M: 46587904 NOTICE: Running the application...
18:50:07 T:2684407808 M: 46583808 NOTICE: ES: Starting event server
18:50:07 T:43509760 M: 46579712 NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
18:50:07 T:43509760 M: 46575616 NOTICE: UDP: Listening on port 9777
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #2
pastebin ~/Library/Logs/CrashReporter/XBMC.crash.log

This might be difficult as your description sounds like you might be running multifinder with XBMC set to autoload. You might be forced to run the patchstick again to revert back to the normal boot into frontrow.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
(This post was last modified: 2009-02-03 21:39 by davilla.)
find quote
beforeseven Offline
Junior Member
Posts: 24
Joined: Feb 2009
Reputation: 0
Post: #3
Hi davilla

XBMC does not autoload. I do in fact boot into Front Row then select XBMC from the Launcher menu. I'm not sure what multifinder is supposed to do. The only thing I did to my Apple TV after it came out of the box was to run the patchstick on it.

There is also no file named XBMC.crash.log on the Apple TV, and the binary pastebin is not available.

Are you saying I should run the patchstick again to revert back to the stock Apple TV software, then start all over again? Am I able to back up my library files before doing so?
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #4
beforeseven Wrote:Hi davilla

XBMC does not autoload. I do in fact boot into Front Row then select XBMC from the Launcher menu. I'm not sure what multifinder is supposed to do. The only thing I did to my Apple TV after it came out of the box was to run the patchstick on it.

There is also no file named XBMC.crash.log on the Apple TV, and the binary pastebin is not available.

Are you saying I should run the patchstick again to revert back to the stock Apple TV software, then start all over again? Am I able to back up my library files before doing so?

No scratch that. Your first description was not clear.

look in ~/Library/Logs/CrashReporter for a crash log. If XBMC did crash, there will be a log present.

pastebin refers to http://www.pastebin.com. it's preferred to post log files to pastebin rather than post them here.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
heinzelmann Offline
Junior Member
Posts: 2
Joined: Feb 2009
Reputation: 0
Question  xbmc crashing on apple tv and on mac osx
Post: #5
exactly the same for me xbmc has been working fine for some time (although I'm still learning) but now as from today it is crashing on apple tv as well as on my mac just after it launches?
I guess I will try to reload from scratch!
Any other suggestions?
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #6
heinzelmann Wrote:exactly the same for me xbmc has been working fine for some time (although I'm still learning) but now as from today it is crashing on apple tv as well as on my mac just after it launches?
I guess I will try to reload from scratch!
Any other suggestions?

to understand why it is crashing, need to see the crash log.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
pender Offline
Junior Member
Posts: 38
Joined: Aug 2007
Reputation: 0
Post: #7
I have the exact same issue. It worked fine for months then suddenly on the 2nd of Feb, almost immediately after launching XBMC, it closes and goes back to backrow. Thought it had to do with the Weather Web Service not working so I'll wait it out.

ATV is 2.2.

CrashReporter Log after one crash instance
http://www.mediafire.com/file/xdmznhqv1m...porter.log
(This post was last modified: 2009-02-04 01:30 by pender.)
find quote
falvious Offline
Junior Member
Posts: 1
Joined: Feb 2009
Reputation: 0
Post: #8
Hey guys, same here. just this now reinstalled XBMC from the launcher menu in apple tv.
Everything was workign fine before doing this, except xbmc was running a bit slower and it was taking a while to start up video files. I wanted to try with a clean install, hence the reason i reinstalled it.

Now when i start up xbmc it loads up and goes to the start screen then the apple tv resets itself after a few seconds.

how do i go about getting hold of the crash log from the appletv. Im using windows on my laptop and WHS on the server so dont have access to a mac

cheers
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #9
falvious Wrote:how do i go about getting hold of the crash log from the appletv. Im using windows on my laptop and WHS on the server so dont have access to a mac

You don't need a Mac but you will need ssh/scp client.


/Users/frontrow/Library/Logs/CrashReporter/CrashReporter.log

post it to pastebin.com


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #10
pender Wrote:CrashReporter Log after one crash instance
http://www.mediafire.com/file/xdmznhqv1m...porter.log

Just a question, why mediafile.com when http://www.pastebin.com works and is preferred.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #11
pender Wrote:I have the exact same issue. It worked fine for months then suddenly on the 2nd of Feb, almost immediately after launching XBMC, it closes and goes back to backrow. Thought it had to do with the Weather Web Service not working so I'll wait it out.

Quote:Thread 2 Crashed:
0 com.teamxbmc.xbmc 0x006ce113 CWeather::GetString(TiXmlElement const*, CStdStr<char> const&, char*, CStdStr<char> const&) + 51
1 com.teamxbmc.xbmc 0x006ceb43 CWeather::LoadWeather(CStdStr<char> const&) + 2323
2 com.teamxbmc.xbmc 0x006d02b8 CBackgroundWeatherLoader::GetInformation() + 600
3 com.teamxbmc.xbmc 0x0068d269 CBackgroundLoader::Process() + 25
4 com.teamxbmc.xbmc 0x006b872f CThread::staticThread(void*) + 79
5 com.teamxbmc.xbmc 0x0052e433 InternalThreadFunc(void*) + 131
6 com.teamxbmc.xbmc 0x0085cc2e SDL_RunThread + 57
7 com.teamxbmc.xbmc 0x008a1c72 RunThread + 17
8 libSystem.B.dylib 0x900243e7 _pthread_body + 84

yep, problem with CWeather.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,229
Joined: Oct 2003
Reputation: 177
Post: #12
Which location of weather do you have configured?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
drwickman Offline
Junior Member
Posts: 27
Joined: Dec 2008
Reputation: 0
Post: #13
Same exact issue here, it crashes after a few seconds.

Here is my log.

20:08:43 T:2684407808 M: 95113216 NOTICE: -----------------------------------------------------------------------
20:08:43 T:2684407808 M: 95113216 NOTICE: Starting XBMC, Platform: Mac OS X. Built on Dec 18 2008
20:08:43 T:2684407808 M: 95113216 NOTICE: Q is mapped to: /Applications/XBMC.app/Contents/Resources/XBMC
20:08:43 T:2684407808 M: 95113216 NOTICE: The executable running is: /Applications/XBMC.app/Contents/MacOS/XBMC
20:08:43 T:2684407808 M: 95113216 NOTICE: Log File is located: /Users/frontrow/Library/Logs/xbmc.log
20:08:43 T:2684407808 M: 95113216 NOTICE: -----------------------------------------------------------------------
20:08:43 T:2684407808 M: 95113216 NOTICE: Setup SDL
20:08:43 T:2684407808 M: 94322688 NOTICE: load settings...
20:08:43 T:2684407808 M: 94318592 NOTICE: Mapping drive P to /Users/frontrow/Library/Application Support/XBMC/userdata
20:08:43 T:2684407808 M: 94318592 NOTICE: loading /Users/frontrow/Library/Application Support/XBMC/userdata/guisettings.xml
20:08:43 T:2684407808 M: 94003200 NOTICE: Getting hardware information now...
20:08:43 T:2684407808 M: 94003200 NOTICE: Checking resolution 10
20:08:43 T:2684407808 M: 94003200 NOTICE: Setting autoresolution mode 3
20:08:43 T:2684407808 M: 93962240 NOTICE: Loaded advancedsettings.xml from /Users/frontrow/Library/Application Support/XBMC/userdata/advancedsettings.xml
20:08:43 T:2684407808 M: 93962240 NOTICE: Getting hardware information now...
20:08:43 T:2684407808 M: 93962240 NOTICE: Checking resolution 10
20:08:43 T:2684407808 M: 93962240 NOTICE: Setting autoresolution mode 3
20:08:43 T:2684407808 M: 93962240 NOTICE: /Users/frontrow/Library/Application Support/XBMC/userdata/sources.xml
20:08:43 T:2684407808 M: 93949952 ERROR: Missing or invalid <name> and/or <path> in source
20:08:45 T:2684407808 M: 77160448 NOTICE: start dvd mediatype detection
20:08:45 T:2684407808 M: 77123584 NOTICE: initializing playlistplayer
20:08:45 T:2684407808 M: 77119488 NOTICE: DONE initializing playlistplayer
20:08:45 T:2684407808 M: 77119488 NOTICE: load default skin:[MediaStream]
20:08:46 T:2684407808 M: 69578752 ERROR: Window Translator: Can't find window settingscategory
20:08:46 T:2684407808 M: 69595136 ERROR: Error evaluating boolean expression !Window.Previous(0) + !Window.Previous(SettingsCategory) + !Window.Previous(1001) + !Window.Previous(130) + !Window.Previous(34)
20:08:47 T:2684407808 M: 67813376 NOTICE: initialize done
20:08:47 T:2684407808 M: 67809280 NOTICE: Running the application...
20:08:47 T:2684407808 M: 67801088 NOTICE: Webserver: Starting...
20:08:47 T:43475968 M: 67567616 NOTICE: Webserver: Started
20:08:47 T:2684407808 M: 67530752 NOTICE: ES: Starting event server
20:08:47 T:43465728 M: 67526656 NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
20:08:47 T:43465728 M: 67522560 NOTICE: UDP: Listening on port 9777
find quote
drwickman Offline
Junior Member
Posts: 27
Joined: Dec 2008
Reputation: 0
Post: #14
Shitty,

I couldn't get xbmc to work in any way so i did a factory restore, update to 2.3 and reinstall xbmc.

After that xbmc started and didn't crash. Time was off so i set the region and no problems, i then went to the weather pane and went to set a city (Vancouver, BC) and when it started to get information for the weather it crashed as before.

Logs are fresh so no crash log Sad
find quote
m3mark Offline
Junior Member
Posts: 1
Joined: Feb 2009
Reputation: 0
Location: Vancouver, BC
Post: #15
I don't if it's a coincidence. Just new to ATV and xbmc... Loaded it a couple of hours ago and was finding my way around ok ... until I changed the weather location to Vancouver... kept cycling past the white apple when launcher tried to get XBMC going. Like you drwickman, I opted for a clean slate and reloaded from scratch.

waiting for my DL to finish...Confused
find quote
Post Reply