Error when starting webserver

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sbrandsborg Offline
Junior Member
Posts: 39
Joined: Jun 2005
Reputation: 0
Location: Europe, Denmark, Ã…rhus
Post: #1
Hello everyone,

Im getting a nasty access violation when im trying to enable the embedded webserver in xbmc 8.10, have anyone any experience with this error or any advice?

21:34:44 T:1840 M:1604300800 ERROR: CThread::staticThread : Access violation at 0x007f5c5c: Reading location 0x00000000

Code:
21:33:55 T:4040 M:1557463040  NOTICE: Mapping drive Z to C:\Users\sbrandsborg\AppData\Roaming\XBMC\cache
21:33:55 T:4040 M:1557434368  NOTICE: Mapping drive T to C:\Users\sbrandsborg\AppData\Roaming\XBMC\userdata
21:33:55 T:4040 M:1557434368  NOTICE: Mapping drive Q to C:\Program Files\XBMC
21:33:55 T:4040 M:1557434368  NOTICE: Mapping drive U to C:\Program Files\XBMC
21:33:55 T:4040 M:1557315584  NOTICE: -----------------------------------------------------------------------
21:33:55 T:4040 M:1557311488  NOTICE: Starting XBMC, Platform: Windows Vista, 32-bit Service Pack 1 build 6001.  Built on Nov 13 2008 (compiler 1500)
21:33:55 T:4040 M:1557311488  NOTICE: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
21:33:55 T:4040 M:1557311488  NOTICE: Desktop Resolution: 1920x1080 32Bit at 60Hz
21:33:55 T:4040 M:1557311488  NOTICE: Q is mapped to: C:\Program Files\XBMC
21:33:55 T:4040 M:1557311488  NOTICE: The executable running is: C:\Program Files\XBMC\XBMC.exe
21:33:55 T:4040 M:1557311488  NOTICE: Log File is located: C:\Users\sbrandsborg\AppData\Roaming\XBMC\xbmc.log
21:33:55 T:4040 M:1557311488  NOTICE: -----------------------------------------------------------------------
21:33:55 T:4040 M:1557291008  NOTICE: Setup SDL
21:33:56 T:4040 M:1642954752  NOTICE: load settings...
21:33:56 T:4040 M:1642946560  NOTICE: Mapping drive P to C:\Users\sbrandsborg\AppData\Roaming\XBMC\userdata
21:33:56 T:4040 M:1642938368  NOTICE: loading C:\Users\sbrandsborg\AppData\Roaming\XBMC\userdata\guisettings.xml
21:33:56 T:4040 M:1642471424  NOTICE: Getting hardware information now...
21:33:56 T:4040 M:1642471424  NOTICE: Checking resolution 10
21:33:56 T:4040 M:1642463232  NOTICE: Setting autoresolution mode 12
21:33:56 T:4040 M:1642442752  NOTICE: No advancedsettings.xml to load (C:\Users\sbrandsborg\AppData\Roaming\XBMC\userdata\advancedsettings.xml)
21:33:56 T:4040 M:1642438656  NOTICE: C:\Users\sbrandsborg\AppData\Roaming\XBMC\userdata\sources.xml
21:33:56 T:4040 M:1642409984   ERROR:     Missing or invalid <name> and/or <path> in source
21:33:56 T:4040 M:1642409984   ERROR:     Missing or invalid <name> and/or <path> in source
21:33:56 T:4040 M:1642409984   ERROR:     Missing or invalid <name> and/or <path> in source
21:33:56 T:4040 M:1642401792   ERROR:     Missing or invalid <name> and/or <path> in source
21:33:56 T:4040 M:1614966784  NOTICE: start dvd mediatype detection
21:33:56 T:4040 M:1614958592  NOTICE: initializing playlistplayer
21:33:56 T:4040 M:1614950400  NOTICE: DONE initializing playlistplayer
21:33:56 T:4040 M:1614938112  NOTICE: load default skin:[Project Mayhem III]
21:33:56 T:4040 M:1610407936  NOTICE: Updating video library on startup
21:33:56 T:4040 M:1610035200  NOTICE: initialize done
21:33:56 T:4040 M:1610035200  NOTICE: Running the application...
21:33:56 T:4040 M:1609945088  NOTICE: Webserver: Starting...
21:33:56 T:3852 M:1609805824   ERROR: CThread::staticThread : Access violation at 0x007f5c5c: Reading location 0x00000000
21:33:57 T:740 M:1608486912  NOTICE: My Videos: Scanning for video info using worker thread, operation took 00:00
21:34:01 T:4040 M:1616629760  NOTICE: ES: Starting event server
21:34:01 T:2240 M:1616592896  NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
21:34:01 T:2240 M:1616568320  NOTICE: UDP: Listening on port 9777
21:34:02 T:780 M:1612595200  NOTICE: AudioScrobbler: Handshake successful.
21:34:10 T:4040 M:1605156864 WARNING: CUtil::GetMatchingSource... no matching source found for [Video Plugins]
21:34:44 T:4040 M:1604300800  NOTICE: Webserver: Stopping...
21:34:44 T:4040 M:1604317184  NOTICE: Webserver: Stopped...
21:34:44 T:4040 M:1604317184  NOTICE: Webserver: Starting...
21:34:44 T:1840 M:1604300800   ERROR: CThread::staticThread : Access violation at 0x007f5c5c: Reading location 0x00000000
21:35:52 T:4040 M:1578340352  NOTICE: Enabled debug logging due to GUI setting
21:35:53 T:4040 M:1578274816   DEBUG: CApplication::OnKey: 61477 pressed, action is 1
21:35:54 T:4040 M:1572003840   DEBUG: CApplication::OnKey: 61467 pressed, action is 10
21:35:54 T:4040 M:1571958784   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
21:35:54 T:4040 M:1576964096   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
21:35:54 T:4040 M:1576964096    INFO: Loading skin file: Settings.xml
21:35:54 T:4040 M:1576947712   DEBUG: Load Settings.xml: 10.26ms
21:35:55 T:4040 M:1575854080   DEBUG: Alloc resources: 48.36ms (10.35 ms skin load, 0.65 ms preload)
21:35:55 T:4040 M:1575497728   DEBUG: CApplication::OnKey: 61477 pressed, action is 1
21:35:56 T:4040 M:1575534592   DEBUG: CApplication::OnKey: 61479 pressed, action is 2
21:35:58 T:4040 M:1579765760   DEBUG: CApplication::OnKey: 61477 pressed, action is 1
21:35:58 T:4040 M:1575571456   DEBUG: CApplication::OnKey: 61453 pressed, action is 7
21:35:58 T:4040 M:1575571456   DEBUG: CApplication::OnMessage : Translating ActivateWindow(NetworkSettings)
21:35:58 T:4040 M:1575571456   DEBUG: CApplication::OnMessage : To ActivateWindow(NetworkSettings)
21:35:58 T:4040 M:1575571456   DEBUG: Activating window ID: 10018
21:35:58 T:4040 M:1575571456   DEBUG: Checking if window ID 10018 is locked.
21:35:58 T:4040 M:1574658048    INFO: Loading skin file: SettingsCategory.xml
21:35:58 T:4040 M:1574649856   DEBUG: Load SettingsCategory.xml: 4.72ms
21:35:58 T:4040 M:1574649856   DEBUG: Alloc resources: 12.73ms (4.80 ms skin load, 0.45 ms preload)
21:35:59 T:4040 M:1580105728   DEBUG: CApplication::OnKey: 61480 pressed, action is 4
21:36:05 T:4040 M:1575936000   DEBUG: CApplication::OnKey: 61479 pressed, action is 2
21:36:06 T:4040 M:1576316928   DEBUG: CApplication::OnKey: 61453 pressed, action is 7
21:36:06 T:4040 M:1576316928  NOTICE: Webserver: Stopping...
21:36:06 T:1840 M:1576316928   DEBUG: WebServer:Exiting thread sockReady=0, sockSelect=0.
21:36:06 T:1840 M:1576316928   DEBUG: WebServer:OnExit - Exit web server.
21:36:06 T:1840 M:1576316928   DEBUG: CThread::staticThread, deleting thread graphic context
21:36:06 T:1840 M:1576316928   DEBUG: Thread 1840 terminating
21:36:06 T:4040 M:1576333312   DEBUG: xbmcHttpShim ends
21:36:06 T:4040 M:1576333312   DEBUG: xbmcHttp ends
21:36:06 T:4040 M:1576333312  NOTICE: Webserver: Stopped...
21:36:11 T:4040 M:1576710144   DEBUG: CApplication::OnKey: 61453 pressed, action is 7
21:36:11 T:4040 M:1576710144  NOTICE: Webserver: Starting...
21:36:11 T:4040 M:1576710144   DEBUG: xbmcHttpShim starts
21:36:11 T:1808 M:1576701952   DEBUG: thread start, auto delete: 0
21:36:11 T:1808 M:1576697856    INFO: WebServer: Server starting using C:\Program Files\XBMC\web on 192.168.1.151:8080
21:36:11 T:1808 M:1576697856   DEBUG: DB: Registering database table <users>
21:36:11 T:1808 M:1576697856   DEBUG: DB: Registering database table <groups>
21:36:11 T:1808 M:1576697856   DEBUG: DB: Registering database table <access>
21:36:11 T:1808 M:1576697856   DEBUG: UM: Loading User Configuration from file <umconfig.txt>
21:36:11 T:1808 M:1576697856   DEBUG: DB: About to read data file <C:\Program Files\XBMC\web\umconfig.txt>
21:36:11 T:1808 M:1576693760   ERROR: CThread::staticThread : Access violation at 0x007f5c5c: Reading location 0x00000000
21:36:21 T:4040 M:1568813056   DEBUG: SDLKeyboard found something unknown (unicode <> printable ASCII): scancode: 56, sym: 308, unicode: 0, modifier: 0

My XBMC system:
XBMC PC: 2.2 GHz Dual-core, GeForce 6400 GS, 2 GB Ram
Remote: Phillips Pronto RC9800i
TV: Phillips 42" LCD 1080p 42PFL7962D
Dreambox: Dreambox 500-S
XBMC Tools - Coming soon
XBMC .net API - Coming soon
find quote
petedoc Offline
Junior Member
Posts: 5
Joined: Nov 2007
Reputation: 0
Post: #2
I had the same problem, deleting C:\Program Files\XBMC\web\umconfig.txt and restarting the web server fixed it
find quote
althekiller Offline
Retired Team-Kodi Member
Posts: 5,002
Joined: May 2004
Reputation: 12
Post: #3
Please don't dig up old, dead threads. umconfig.txt is no longer used by the webserver.
find quote
petedoc Offline
Junior Member
Posts: 5
Joined: Nov 2007
Reputation: 0
Post: #4
althekiller Wrote:Please don't dig up old, dead threads. umconfig.txt is no longer used by the webserver.

Is that true? How old is my build, from my debug log:
09:25:31 T:3272 M:856469504 NOTICE: Starting XBMC, Platform: Windows Vista, 32-bit Service Pack 2 build 6002. Built on Jun 2 2009 (SVN:20672, compiler 1500)
11:02:17 T:800 M:1319235584 DEBUG: DB: About to read data file <C:\Program Files\XBMC\web\umconfig.txt>
11:02:17 T:800 M:1319231488 ERROR: CThread::staticThread : Access violation at 0x0083503c: Reading location 0x00000000
find quote
althekiller Offline
Retired Team-Kodi Member
Posts: 5,002
Joined: May 2004
Reputation: 12
Post: #5
Uhh, the build date is right in the log. Do you really need told?
find quote