Media Info Plus - Manage your Movies, Shows, Tunes, NFO and more (Open Source VB.NET)

  Thread Rating:
  • 7 Votes - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Montellese Offline
Team-XBMC Developer
Posts: 3,681
Joined: Jan 2009
Reputation: 34
Location: Switzerland
Post: #1111
iLurk Wrote:HI fekker,

Is there an option to read .nfo's that are named in the same format as the movie.

e.g I've currently got :

name.of.movie.bluray.h264.dts.mkv
name.of.movie.bluray.h264.dts.nfo

but MIP doesn't seem to recognise the nfo & names the creates new files as:

name of movie.nfo
name of movie-fanart.jpg
name of movie.tbn


I noticed in the settings, we only have 2 options to create "movie name.nfo" (which creates the example above) or "movie.nfo". Would it be possible to add an option to name the files created to match the *.mkv filename?

Ta

I had it working like this before I changed to folder level. The problem with your naming is using "." as seperators. There is an option in MIP which says something like "Replace _ and . with spaces". You need to deactivate that option and everything should work the way you want it.
find quote
hikaricore Offline
Posting Freak
Posts: 1,515
Joined: Dec 2008
Reputation: 0
Location: Tuesday
Post: #1112
Tvupdater currently outputs errors to a dialog box requiring user interaction.
I have 3 such errors due to custom naming of series that I don't wish overwritten.

Would it be possible to output these errors to command line or suppress them with a flag?
find quote
logictester Offline
Fan
Posts: 682
Joined: Oct 2008
Reputation: 0
Location: USA
Post: #1113
i have a problem with tv shows that are stored on 2 different disks, it seems that the source that was added as second source, get missed by MIP. for example - if i have lost stored half season on my local hd and half season on my external storage, MIP creates 2 folders with the name Lost but the episodes stored on the external hd showed as missing, and if an entire show is stored on the external hd everything is picked up correctly, am i doing something wrong?
thanks
find quote
JohnWPB Offline
Senior Member
Posts: 215
Joined: Dec 2008
Reputation: 3
Location: West Palm Beach, Florida
Post: #1114
I am sorry I did not report more back to you when you sent me the beta some time ago. I have been in China for 2 months on a business trip, and just got back a few days ago.

Fantastic job on the last release! You have come a LONG ways with this app! Kudos!

On that note, I have a couple of minor things to report from using it since I have been using it:

- When I choose "Add Poster" to add my own image, it is not copied to the movie folder. I also put the image (Folder.jpg) in the movie folder itself to start with, so I could choose it, and it would make the Movie thumbs ect. When I chose it, it deleted the Folder.jpg from the folder completely.

- When displaying the "Media" tab, it does not show the resolutions of the images, and of course clicking on it add's it, and does not show the original size.

- Lastly, when I choose a cover image, it does not show on the top left of the fanart. I have to leave the movie, then come back to it to be sure that it did save it.

Now, as for a feature request Smile I have noticed many movies have the full cover under the media tab, but no front cover to be found. Can you add a routine to pick a media cover, and create the front cover from that? Right now, I am picking a media image, opening a photo editor, and cropping the image manually, and saving it as Folder.jpg. Then I have to also save that image as the [MOVIE NAME].tbn. MyMovies has this feature, and just did a calculation of the image ratio, and cropped off the back cover and spine. I am sure they were using some sort of dll or something to do this, I just do not know the exact details.

------------------------------------------
Atom Dual core 2.8 Ghz / Windows 7 Pro / 4 gigs ram 6.5 Tb storage / Nvidia 9400M Gfx chipset / Output 1920 x 1080p via HDMI to a 52" LED TV / just over 3,400 movies

Have you entered your 5 Movies? - Support themoviedb.org as THE best open source movie information site.
(This post was last modified: 2009-05-06 20:54 by JohnWPB.)
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #1115
Montellese, thanks for helping answer questions here in the thread! you rock!!

Let me start by giving a little update, and then some answers to q's and requests.

I have to move very very soon and need to pack up the family, move and get things in order on that front. This means that there is going to be a delay in updates for a few weeks while things get sorted and i get back online.

We have also started a thread in the dev forums for a unified media manager, we have 3 devs on board right now for that one and discussion has been started. One media manager to rule them all, by getting the folks that make the different ones together. Some will join, others will pass. In the end I think we will have a cross platform unified media manager that's bigger, faster, stronger, better Big Grin .. I'm sure we will need help in the documentation area, i know I would rather code that write about what it does.


now for the questions


Montellese Wrote:Hey fekker

I got a question:

I added lots of movie posters from getvideoartwork.com because they are of better quality. So I just overwrote the "movie.tbn" file in my folders. But somehow MIP doesn't show them anymore alongside the fanart and movie information. I already double-checked the option where you can (de)activate the preview of movie posters and it's activated. Is this the normal behaviour?

Thanks for your help.

If you delete the %moviename%.tbn it will recreate it based off the movie.tbn. Using the gui to add the poster to the movie should replace both files.

If folder.jpg is not being created, you have to enable the option to display the tbn file (under settings)

Missing fanart after it's already added
If fanart is disappearing (so to speak) make sure you have the option enabled to show fanart as background in the settings

Poster is tiny
if your poster size is a tiny box, change the display size in the settings to 325 and save it.. adjust as needed.

Would it be possible to add an option to name the files created to match the *.mkv filename?
yeah, that's doable, although with movie.nfo and movie.tbn it's no longer required that the nfo and image match the filename. (folder level only)


never consider users who use resolution less than 1024*768?
I can not find OK and Cancel buttons on the screen.

honestly, i'm fighting to keep it usable at 1024 much less at lower resolutions.. however, if you can tell me what items are too big, i'll try to work something in to make it usable.


Seems error only comes up when making episode thumb, no error happens when making an episode background, seems odd ?
that's weird for sure, i'll have to run it through some testing when i get back from some time off.

Tvupdater currently outputs errors to a dialog box requiring user interaction.
I have 3 such errors due to custom naming of series that I don't wish overwritten.Would it be possible to output these errors to command line or suppress them with a flag?

i'll see about a supress all flag, should have time to get that in there.

Quote:i have a problem with tv shows that are stored on 2 different disks, it seems that the source that was added as second source, get missed by MIP. for example - if i have lost stored half season on my local hd and half season on my external storage, MIP creates 2 folders with the name Lost but the episodes stored on the external hd showed as missing, and if an entire show is stored on the external hd everything is picked up correctly, am i doing something wrong?
thanks
As long as the full season is in the same location it'll work. If part of the season is in one location, you'll run into what your seeing. It's a flaw in how i handle the shows in mip. I'll add it to the fix list, but it's gonna be abit until i can rework that area. (again, have to move, so down for a few weeks)
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #1116
In other news, mip works fine under Windows 7 RC1 (32bit) if installed as administrator.. haven't tested under other areas, but i'm guessing it works if installed under standard users as well.

Quote:When I choose "Add Poster" to add my own image, it is not copied to the movie folder. I also put the image (Folder.jpg) in the movie folder itself to start with, so I could choose it, and it would make the Movie thumbs ect. When I chose it, it deleted the Folder.jpg from the folder completely.
if your running the latest build (mip update makes that easy, check mip website to install) and these things are still occuring, please pm me the details and pastebin your config.. the display thing sounds like something is not checked to be displayed, i remember having htat issue with file level movies, but i'm pretty sure i fixed it.. maybe i missed it in one of the revs though. If ya still got my email, email works as well.

thanks for the feedback Big Grin
find quote
logictester Offline
Fan
Posts: 682
Joined: Oct 2008
Reputation: 0
Location: USA
Post: #1117
fekker Wrote:As long as the full season is in the same location it'll work. If part of the season is in one location, you'll run into what your seeing. It's a flaw in how i handle the shows in mip. I'll add it to the fix list, but it's gonna be abit until i can rework that area. (again, have to move, so down for a few weeks)

thanks a lot - moving the seasons in the mean time Smile
have an easy move man!
find quote
lestat1977uk Offline
Fan
Posts: 325
Joined: Jan 2009
Reputation: 1
Post: #1118
Good luck with the move mate and try and enjoy the time off Smile
find quote
Montellese Offline
Team-XBMC Developer
Posts: 3,681
Joined: Jan 2009
Reputation: 34
Location: Switzerland
Post: #1119
fekker Wrote:Montellese, thanks for helping answer questions here in the thread! you rock!!

Well no biggy you're the one that rock and keep this awesome tool up to date, handle all the feature requests and eradicate all the bugs in no time.

I just try to support ppl having issues I already encountered myself because that's what a forum and a community is there for isn't it?

fekker Wrote:I have to move very very soon and need to pack up the family, move and get things in order on that front. This means that there is going to be a delay in updates for a few weeks while things get sorted and i get back online.

Well take your time, you've done a really great job here and even the best need some break sometimes Wink

fekker Wrote:We have also started a thread in the dev forums for a unified media manager, we have 3 devs on board right now for that one and discussion has been started. One media manager to rule them all, by getting the folks that make the different ones together. Some will join, others will pass. In the end I think we will have a cross platform unified media manager that's bigger, faster, stronger, better Big Grin .. I'm sure we will need help in the documentation area, i know I would rather code that write about what it does.

Well if you need some help in coding (I don't like writing documentations either sorry Wink) just let me know and I'm in. Before I found out about XBMC I always used a self written tool which scraped infos from OFDb (as I'm a native german speaker), used MediaInfo to get additional information about the files and got my covers from impawards.com.
Well it didn't have nearly that many features as MIP but my point is that I have some knowledge and experience in this stuff as well and if I can help, I'd be greatful to do so.

fekker Wrote:If you delete the %moviename%.tbn it will recreate it based off the movie.tbn. Using the gui to add the poster to the movie should replace both files.

If folder.jpg is not being created, you have to enable the option to display the tbn file (under settings)

Thanks for the suggestion to use the "Add Poster" function. I will try it as soon as possible. I could have come up with this myself Eek
find quote
logictester Offline
Fan
Posts: 682
Joined: Oct 2008
Reputation: 0
Location: USA
Post: #1120
is it possible for MIP to recognize .srt file and put sub in the tag?
thanks a lot
find quote
wannabegt4 Offline
Senior Member
Posts: 208
Joined: Dec 2008
Reputation: 1
Location: Wichita, Kansas
Post: #1121
First thanks, this works great after I figured out the UI.

Secondly, I can not for the life of me get MIP to ignore the jacket_p folders for certain movies backed up in file mode versus iso/img. The folder sits along side the video_ts folder in it's parent directory. Any advice on how to add a filter of some kind so it doesn't try and add it as a movie in my library.
find quote
havoxx Offline
Junior Member
Posts: 1
Joined: May 2009
Reputation: 0
Post: #1122
Hey, I just want to say what a great program you have, I'm having a little bit of an issue though, every time I try to load my "tunes" it says 3584, and then crashes, can it not read more than that?
find quote
reaven Offline
Skilled Skinner
Posts: 1,105
Joined: May 2009
Reputation: 20
Post: #1123
fekker Wrote:Folders will give you the most options, file level also works as well.
I use Folders myself.

I'm giving these details based on MIP 2814, which I am working on right now, some things are different then the current build (autopilot will now prompt you to pick the right movie if there's no .nfo already for it.).

Name the folder the movie name, with MIP, if there's more then one movie, it'll will display a list of movies, with data and a poster (if avail) so you can pick the right one. The year can be added if you want, it's not necessary but won't hurt either. I don't usually know the year, and can't my spelling is almost always off when it comes to movie names, get close, the search makes it alot easier now.

MIP will add backgrounds, posters, media images, media information, all in the most compatible format for all versions of xbmc. Will there be a few duplicate images and fanart images, yes there will be. I would really recommend you leave the duplicates, it makes getting the right image in xbmc (and other apps too) easy. You can always go back and remove duplicates when all the details about what goes where and why in what version makes sense.

Auto-Pilot is a great way to start, Auto-Pilot will prompt for show selection and assign images for you, it doesn't hit all the scrapers, it looks at impawards posters for the posters, when you load the movie by clicking on the movie name, it'll pull images from many different sites.

If you picked the wrong movie, or have a bad .nfo, don't worry.. you can change it. Click on the "Wrong Movie" button to search imdb again for the movie.

Once in xbmc, it's easy.
Add source.. browse to the main folder that has all the movie folders in it.
Click on set content, choose the type as Movie with tmdb as the site (default).
Check the option - run automated scan
Check the option - scan recursive
Check the option - use folder name for lookups
click ok (or add, whichever isn't the cancel button)
It'll load up your movies.

When you add movies, scan them with MIP, set your images and details.. then in xbmc right click and choose update library. and your up to date.


I follow this instructions since i am having the same difficulties with my library, i dont know how to reflect what i choose and add in MIP to XBMC

my library is in another computer where MIP is installed i scan select fanart, poster all the deal... i go to the other computer where xbmc is running delete my library and follow what you wrote on the post. it detect the movies in time but it pulls the fanart from the site tmdb not the one i choose and the one is in the same folder with the movie poster and nfo...its like all those files are not there, is like it would be the same if I delete the nfo...

1. Why is not reading the nfo?

2. the files you choose to add means something or have anything to do with it ?like( <moviename>.tbn or poster.tbn, movie.nfo or <moviename>.nfo,fanart.jpg or <moviename>.jpg)

3. can I have a combination like (<moviename>-fanart.jpg and poster.tbn)or I have to choose the same <moviename> or movie ?

4. why isn't in the .nfo the path to the fanart and poster that is in the movie folder and is something like
Code:
<thumb preview="image/backdrops/20756/Day_The_Earth_Stood_Still_03_thumb.jpg">image/backdrops/20756/Day_The_Earth_Stood_Still_03.jpg</thumb>
I would like to erase all the images that is not in use in the program folders is that possible ?

5. I really love XBMC and your program seems to be the best for its purpose and I want to make it work.


Thanks and keep up the good work...
(This post was last modified: 2009-05-08 13:51 by reaven.)
find quote
Beatzeps08 Offline
Member
Posts: 75
Joined: Oct 2008
Reputation: 0
Post: #1124
Hey fekker, could you add an Auto-Pilot-Function to update the infos from OFdb for all movies?
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #1125
wannabegt4 Wrote:First thanks, this works great after I figured out the UI.

Secondly, I can not for the life of me get MIP to ignore the jacket_p folders for certain movies backed up in file mode versus iso/img. The folder sits along side the video_ts folder in it's parent directory. Any advice on how to add a filter of some kind so it doesn't try and add it as a movie in my library.

I've added it to the next patch list, which will be out in a few weeks (2)..

Quote:why isn't in the .nfo the path to the fanart and poster that is in the movie folder and is something like
xbmc will load it from the folder.. the items in the .nfo are just so that you could select a different one in xbmc.

if your running xbmc 9.04 then use movie.nfo, movie.tbn, fanart.jpg and folder.jpg.. for older versions, or if your not sure, use them all and xbmc will pick what it needs from those that are in there.. different builds of xbmc use different items.

i'll have to ask for someone to help ya with the library, i'm swamped and about to go offline (have to pack the computer)

Quote:s it possible for MIP to recognize .srt file and put sub in the tag?
thanks a lot
if it contains the lang in the file, or in the filename, i could detect it..


signing out for now, cya's in a few weeks!!
find quote
Post Reply