Allmusic scraper doesn't work fetching album info

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Nazgulled Offline
Fan
Posts: 530
Joined: Feb 2009
Reputation: 0
Post: #1
This is a follow up to a previous thread where I was having problems with the music library. I knew there was something wrong but I created a new topic instead because the problem is different, but related.

I'm using the "allmusic" scaper and the problem is that the scraper stops working if I have the option "fetch album information when adding to library".

Let's say my database is completely cleaned (no Database folder in userdata) and I have the above option enabled. I start XBMC, go to Music and select the source I want to scan, open context menu and select "scan item to library". It shows "Loading media info from files..." and the current directory it's scanning.

It starts scanning and as soon as the scraper neesd to download information from the internet for the first album, it just doesn't work... For a while, it keeps on the screen:
Quote:Downloading album information
30 seconds from Mars
(first album on my library)

After a while the message becomes "Loading media info from files..." and nothing else. Normally it shows the current directory it's scanning but not this time (remember, it showed the first time when I started the scanning). And it just stays there, saying "loading media info from files...", but it's not doing anything.

If I open the context menu and select "stop scanning" it doesn't work, it still keeps saying "loading media info from files...".

If I disable the "fetch album information when adding to library" option and start the scanning again, it will work because it only needs to get data from the local files. But if I enable that option, it doesn't work...

Maybe it was some update done to allmusic scraper because this was working a few days ago...

I'm using revision 19340 by the way.

EDIT:
Just realized that none of the scrapers are able to download any album information from the internet... It's not a "allmusic" scraper problem (someone with access please change the thread topic).
(This post was last modified: 2009-04-09 17:36 by Nazgulled.)
find quote
Nazgulled Offline
Fan
Posts: 530
Joined: Feb 2009
Reputation: 0
Post: #2
I didn't want to bump the thread but... Sorry!
find quote
PantsOnFire Offline
Fan
Posts: 621
Joined: Aug 2008
Reputation: 2
Post: #3
Nazgulled Wrote:EDIT:
Just realized that none of the scrapers are able to download any album information from the internet... It's not a "allmusic" scraper problem (someone with access please change the thread topic).

You did? They're not? What happened?


I read this thread as I have similar problems like this. I've found that if I switch to a less mem-intensive skin like xTV and do the scan to library, it works fine.

But I do also have a problem, where most of the albums I hit info on, show 'no review available' when I know for a fact they are veyr popular albums that do indeeed have reviews on allmusic.com

I miss this feature working..
find quote
tslayer Offline
Team-XBMC Developer
Posts: 3,557
Joined: Oct 2003
Reputation: 12
Post: #4
This is the same issue as we discussed. Due to 19329. We are aware of it.

42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote