[LIVE] HOW-TO build a XBMC Live USB without burning a CD on Windows

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
RedSpawn Offline
Junior Member
Posts: 7
Joined: Aug 2009
Reputation: 0
Post: #16
tried everything but nothing worked....

1) install from live: getting "end_request: I/O error" upon installing GRUB
2) install via VirtualBox: same as 1)
3) install with unetbootin: seems to work but won't boot. since Babylon release changed to GRUB isn't this working anymore?

since this release is not really new i guess i'm making some stupid mistakes but maybe someone can give me some directions?

btw. tried 2different USB-sticks and a USB-HDD
find quote
iainmacleod Offline
Senior Member
Posts: 199
Joined: Feb 2006
Reputation: 0
Location: Pittsburgh area (Scotland previously)
Post: #17
RedSpawn Wrote:tried everything but nothing worked....

1) install from live: getting "end_request: I/O error" upon installing GRUB
2) install via VirtualBox: same as 1)
3) install with unetbootin: seems to work but won't boot. since Babylon release changed to GRUB isn't this working anymore?

since this release is not really new i guess i'm making some stupid mistakes but maybe someone can give me some directions?

btw. tried 2different USB-sticks and a USB-HDD

Exactly the same problem.

*update* this may be the solution http://www.xbmc.org/forum/showthread.php?t=51142

trying now...

This worked for me!

XBMC on RPi, and Zotac box (Openelec flavor)
NAS4Free with 8TB of storage.
(This post was last modified: 2009-08-20 16:55 by iainmacleod.)
find quote
mouphi Offline
Junior Member
Posts: 1
Joined: Aug 2009
Reputation: 0
Post: #18
Apologies in advance, I'm a Linux noob.

Created the USB stick fine.
Booted into Safe Mode.

The mount command...
Code:
sudo mount -t vfat /dev/sda1 /mnt

Generates this error:

Code:
[ 1045.654258] FAT:bogus number of reerved sectors
mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage, or helper program, or other error

So typed in 'dmesg | tail', and got this back:

Code:
[ 1045.654258] FAT:bogus number of reerved sectors
VFS: Can't fin a valid FAT filesystem on dev sda1

No doubt I'm missing something blindingly obvious, but I'm a spoilt Windows man-child.
find quote
vikjon0 Offline
---
Posts: 2,497
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #19
Quote:Can a static IP address be built into the USB drive? When I try to change my Ip address it is greyed out, only a DHCP address is available.

I am sure it can, but it is not easier to assign a static ip in the router instead?
(This post was last modified: 2009-09-11 18:49 by vikjon0.)
find quote
PantsOnFire Offline
Fan
Posts: 575
Joined: Aug 2008
Reputation: 2
Post: #20
I've just created a USB stick with Live written on it. I got the ISO from here:
http://sourceforge.net/projects/xbmc/fil...p/download

I take it this is the latest release?

Anyway, I followed the instructions in the first post to make the stick 'writeable'. Didn't work for me, something went wrong, for a start I didn't know you had to 'log in' to anything, might have been cool to add those details in the post. But when I did, I couldn't get those commands to work.

So anyway I booted XBMC, and changed a few settings. Rebooted the machine, and the settings remain as I set them. XBMC surely is writing settings to the stick successfully?

Bloodyhell, and then I go and delete the AEON skin directories... and from that point on, no XBMC settings save! How weird!

My band - www.myspace.com/seabasskid
My system - ASRock 330, 1.6GHz DualCore Atom, GeForce9400 ION, 2GB ram
XboxLive Gamertag - SkillipEvolver
(This post was last modified: 2009-09-13 18:39 by PantsOnFire.)
find quote
jochenz Offline
Senior Member
Posts: 202
Joined: May 2006
Reputation: 0
Location: Netherlands
Post: #21
thanks man!
unetbootin worked like a charm for me!

XBMC on HTPC with Ubuntu 12.04 connected to Amahi Home Server 750GB+1TB storage.
XBMC is probably the best thing that ever happened to me...!!! You people Rock!!!

HTPC: MB: Asus P5N7A-VM DDR: 2 x 1 GB Kingston CPU: Intel Core2DUO E8400 @ 3,0 GHz Coller: Scythe Shuriken
find quote
jochenz Offline
Senior Member
Posts: 202
Joined: May 2006
Reputation: 0
Location: Netherlands
Post: #22
l.capriotti Wrote:my fault, the mount command was incorrect for an usb disk.
Pls try the new one

what is this "new one" you are referring to?

could you please update the code for creating the permanent storage?

XBMC on HTPC with Ubuntu 12.04 connected to Amahi Home Server 750GB+1TB storage.
XBMC is probably the best thing that ever happened to me...!!! You people Rock!!!

HTPC: MB: Asus P5N7A-VM DDR: 2 x 1 GB Kingston CPU: Intel Core2DUO E8400 @ 3,0 GHz Coller: Scythe Shuriken
find quote
jochenz Offline
Senior Member
Posts: 202
Joined: May 2006
Reputation: 0
Location: Netherlands
Post: #23
jochenz Wrote:what is this "new one" you are referring to?

could you please update the code for creating the permanent storage?

for me this worked:

Code:
sudo mount -t vfat /dev/sdb1 /mnt
dd if=/dev/zero of=/mnt/ext3fs.img bs=1M count=600
mkfs.ext3 -F /mnt/ext3fs.img

the only thing I changed was sda1 to dsb1

XBMC on HTPC with Ubuntu 12.04 connected to Amahi Home Server 750GB+1TB storage.
XBMC is probably the best thing that ever happened to me...!!! You people Rock!!!

HTPC: MB: Asus P5N7A-VM DDR: 2 x 1 GB Kingston CPU: Intel Core2DUO E8400 @ 3,0 GHz Coller: Scythe Shuriken
find quote
prupert Offline
Senior Member
Posts: 178
Joined: Feb 2007
Reputation: 1
Post: #24
Hi

I just tried to follow this guide, using Unetbootin on Windows and the XBMClive 9.11 Alpha1 iso.

But when it comes to his section of the guide:

open the file syslinux.cfg on the flash disk and replace all occurrences of "boot=cd" with "boot=usb"

I can't do anything since there is no mention of boot=cd in syslinux.cfg...

When I try to boot via the USB drive, I get a kernel panic saying it can't find any mountable filesystems.

Any idea what I need to change?
find quote
lcapriotti Offline
a.k.a Luigi, Team-XBMC XBMCbuntu Dev
Posts: 811
Joined: Jan 2008
Reputation: 12
Location: Italy
Post: #25
these instructions were related to previous releases, there would be no need to modify anything now. I will try it myself and update the post accordingly.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
ahreno Offline
Junior Member
Posts: 34
Joined: Dec 2008
Reputation: 0
Post: #26
Im trying to get this going and all i get is a blank white screen.

I've done this with 9.04 and it was fine, but i want my 5.1 surround!

I downloaded 9.11 and loaded it with unet and installed to usb drive.

I then copy and pasted your suggested .cfg file into the one that was created on the usb drive.

Put the usb drive into the revo and used the boot menu to select it. it shows a line of text then goes to the white screen with a circle gradient.

any ideas?
find quote
paulyche Offline
Junior Member
Posts: 9
Joined: Jul 2009
Reputation: 0
Post: #27
l.capriotti Wrote:UPDATE: unetbootin has not yet support for grub2, used in XBMCLive 9.11. This means that the proper syslinux entries will not be created properly. So, once unetbootin has finished, replace the file syslinux.cfg with something like

How do I add an entry to allow me to install to disk from an xbmclive 9.11 (grub2) usb stick.

I have tried copying the entry from the NVIDIA menu item (I have an Acer Revo) and adding xbmc=install i.e. as follows:

Code:
label install
menu label Install
kernel /ubnkern
append initrd=/ubninit  boot=live splash module=nvidia quiet persistent quickreboot quickusbmodules skipconfig union=aufs

xbmc=install,nodiskmount,setvolume,wakeOnUSBRemote loglevel=0

but that doesn't seem to work. it just boots to a screen asking me for the XBMCLive login. I can enter xbmc/xbmc and then I just arrive at a command prompt
(This post was last modified: 2009-11-22 13:47 by paulyche.)
find quote
Eldandoerino Offline
Junior Member
Posts: 19
Joined: Nov 2009
Reputation: 0
Post: #28
paulyche Wrote:How do I add an entry to allow me to install to disk from an xbmclive 9.11 (grub2) usb stick.

I have tried copying the entry from the NVIDIA menu item (I have an Acer Revo) and adding xbmc=install i.e. as follows:

Code:
label install
menu label Install
kernel /ubnkern
append initrd=/ubninit  boot=live splash module=nvidia quiet persistent quickreboot quickusbmodules skipconfig union=aufs

xbmc=install,nodiskmount,setvolume,wakeOnUSBRemote loglevel=0

but that doesn't seem to work. it just boots to a screen asking me for the XBMCLive login. I can enter xbmc/xbmc and then I just arrive at a command prompt


Having the same problem here.
find quote
arielgr Offline
Member
Posts: 50
Joined: Dec 2006
Reputation: 0
Post: #29
I had the same problem.. I believe the 9.11 alpha 2 is broken, perhaps try another version..

In any case (and I haven't tried it myself as I switched to a full ubuntu installation + xbmc) apparently you can complete the installation by running installXBMC (or something similar) after you login using xbmc / xbmc .
find quote
Mnuu Offline
Member
Posts: 53
Joined: Nov 2009
Reputation: 0
Post: #30
The new installer with alpha1 seems to not like installing from usb and demands a CD. I don't have a CDROM drive Sad
find quote