[LINUX] Sony PlayStation 3 Blu-ray Disc Remote (PS3 BD) + LIRC + XBMC = SUCCESS

  Thread Rating:
  • 6 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kitlaan Offline
Member
Posts: 74
Joined: Nov 2009
Reputation: 5
Location: Massachusetts
Post: #646
Wow, a lot of activity since I was last around. Great to see everyone helping out!

The PPA has been updated for oneiric, no need to hold the package any more; sorry about that. In my experimental PPA, there's a newer version that does some magic with the sixaxis controller. I haven't vetted it, but the additional code came from Fedora, so it should be fine.


Re: Print Screen. I think the definition to use is KEY_SYSRQ (but I could be wrong, haven't tried). I don't know why they used that instead, but I imagine it's because the original PC-XT spec doesn't have a print screen key -- only later did people reuse the key for print screen usage.
find quote
kitlaan Offline
Member
Posts: 74
Joined: Nov 2009
Reputation: 5
Location: Massachusetts
Post: #647
Re: Eject. Wow, it looks like they deprecated the old keymap for eject...
You now need to custom-define a keymap in XBMC, then set your mapping...
See: http://forum.xbmc.org/showpost.php?p=708...stcount=12

The post may be incorrect, as I think Dharma/Eden changed the xml file?
find quote
Stilllife Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #648
Right. so Remote is all working. I just can't find out how to get it to wake up the device (and which mode do you put it in 'standby / hybernate / off?)

If anyone can point me in the right direction i'll be truly greatful.

Thank you
(This post was last modified: 2012-01-21 16:28 by Stilllife.)
find quote
kitlaan Offline
Member
Posts: 74
Joined: Nov 2009
Reputation: 5
Location: Massachusetts
Post: #649
Stilllife Wrote:Right. so Remote is all working. I just can't find out how to get it to wake up the device (and which mode do you put it in 'standby / hybernate / off?)

I don't believe that you can do a wake-up using the bluetooth remote, based on how the PC sleep cycle works. I hope someone proves me wrong, though.
find quote
Stilllife Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #650
Ah right. so my only option is to leave it running 24/7.. grr not really what i'd want. Can anyone (in the UK) recommend me a good 'out of the box' remote then to use with this set up?

thank you
find quote
vaughan Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #651
1. First of all, a question for kitlaan - you say: "The PPA has been updated for oneiric, no need to hold the package any more; sorry about that".
I'm not sure what you mean by that? Do you mean that there are unncessary steps in my posting from "2011-12-30, 16:08", or what?

2. I've been looking at the remote control power consumption. With mine, on standby the remote control draws 0.12 mA.
Then if you press a button on the remote control it establishes the bluetooth connection and the consumption goes up to about 14 mA.
However the timeout doesn't seem to work.
The power consumption goes back to standby when you unplug the Bluetooth dongle, power down the mythbox or issue 'sudo service bluetooth stop'.
But if you press a button and just leave it, the consumption stays at 14 mA.
I set:
IdleTimeout=30
(and restarted the bluetooth service) but it doesn't time out after 30 seconds - in fact 40 minutes on it's still drawing 14 mA.
I tried running it in debug mode by issuing the following:
sudo service bluetooth stop
sudo bluetoothd -nd

The debug messages show when a key is pressed and released, but there are no timeout messages, etc.

Does anyone have any suggestions about this?

Thanks very much - Vaughan
find quote
vaughan Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #652
In fact I've found the answer to my question #2 above: when I looked nearer the start of the debug output I found that it contained the following line:

bluetoothd[2351]: input/manager.c:input_manager_init() input.conf: Key file contains key 'IdleTimeout' in group 'General' which has value that cannot be interpreted.

After experimenting it appears that you need to ensure that there aren't any blank characters at the end of the 'IdleTimeout' line in /etc/bluetooth/input.conf.

Having corrected that, I found that the timeout did indeed occur after the specified number of seconds - and then the power consumption dropped back to 0.12 mA. Smile
find quote
Stilllife Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #653
Evening

After much faffing about I now have this remote working, but for the life of me can't it to WOL (wake on lan). can anyone tell me if this is possible and if so what I am missing with this remote or I should be looking for something else to let me do this?

Thank you
find quote
chipsteroo Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #654
vaughan Wrote:In fact I've found the answer to my question #2 above: when I looked nearer the start of the debug output I found that it contained the following line:

bluetoothd[2351]: input/manager.c:input_manager_init() input.conf: Key file contains key 'IdleTimeout' in group 'General' which has value that cannot be interpreted.

After experimenting it appears that you need to ensure that there aren't any blank characters at the end of the 'IdleTimeout' line in /etc/bluetooth/input.conf.
)

It seems the example input.conf in the wiki http://wiki.xbmc.org/index.php?title=HOW..._BD_Remote has several spaces after the numeric value in the IdleTimeout line. This could be a problem for anyone who cut/pastes that file.

It also says that IdleTimeout is measure in minutes. I thought it was seconds. I have IdleTimeout=30 and it definately disconnects after 30 seconds, according to the bluez list-devices script.
find quote
Stilllife Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #655
Is there any reason why the Revo will not be saving my edited files after I have made sure the USB00-03 are listed for Wake on Lan?. It wokes if i remote on to the machine but if I fully power down it will not WOL. Seems the unit doesn't keep the USB settings to accept wake on lan.

any ideas?
find quote
TREX6662k5 Offline
Donor
Posts: 214
Joined: Oct 2006
Reputation: 0
Location: London, United Kingdom
Post: #656
kitlaan Wrote:I don't believe that you can do a wake-up using the bluetooth remote, based on how the PC sleep cycle works. I hope someone proves me wrong, though.

Someone had posted instructions on how to wake up a suspended machine via Bluetooth.

http://forum.xbmc.org/showpost.php?p=614...tcount=516

I haven't used it myself yet but the person who posted it says it works.

WYSIWYG
find quote
tweaker Offline
Junior Member
Posts: 28
Joined: May 2011
Reputation: 0
Post: #657
Is it possible to map two keys to one button in input.conf?

I want to map ALT-F4 and ESC to the eject button.
find quote
MartinHJ Offline
Junior Member
Posts: 28
Joined: Jan 2011
Reputation: 0
Post: #658
tweaker Wrote:Is it possible to map two keys to one button in input.conf?

I want to map ALT-F4 and ESC to the eject button.

You can always use irexec to map an executable script to a button

Martin
find quote
tweaker Offline
Junior Member
Posts: 28
Joined: May 2011
Reputation: 0
Post: #659
MartinHJ Wrote:You can always use irexec to map an executable script to a button

Martin

Thanks.

I have another question. Tongue

How do I pair a PS3 Sixaxis/Dualshock controller?

I'm using kitlaans patched drivers for my BD Remote. Works perfectly but now I need a controller for emulators.
find quote
DaMizZa Offline
Senior Member
Posts: 108
Joined: Dec 2010
Reputation: 2
Location: Saskatchewan, Canada
Post: #660
heldchen Wrote:anyone who had problems waking up through the ps3 remote from a suspended state:

Code:
sudo cat /sys/bus/usb/devices/x-y.z/power/wakeup
echo enabled | sudo tee > /sys/bus/usb/devices/x-y.z/power/wakeup

replace x-y.z with the node the bluetooth dongle is located. also make sure the usb host's power wakeup setting is enabled:

Code:
sudo cat /proc/acpi/wakeup
echo USBx | sudo tee > /proc/acpi/wakeup

replace USBx with your actual usb port name as outputted by /proc/acpi/wakeup

once that works, put the echo commands into your /etc/rc.local to have it enabled on boot.

works like a charm now for me (using a cheap usb dongle).

I've been trying to get this working, but ran into a few issues I'm hoping you can help me out with:

- lsusb output shows my bluetooth dongle connect on Bus 007 device 002, but looking at my /sys/bus/usb/devices/ folder, the closest thing I've found to this is 7-1:1.2, but there are so many other options (usb1 through usb8 among several others like 7-1, 7-1:1.0, 7-1:1.1 etc...) is there any way to tell exactly which one I want?

- sudo cat /sys/bus/usb/devices/7-1:1.2/power/wakeup returns a no such file or directory error

- echo enabled | sudo tee > /sys/bus/usb/devices/7-1:1.2/power/wakeup returns a permission denied error

I'm guessing it's more of a user error than anything, I really have no idea what these commands are doing, or if I'm even on the right track with the USB node the bluetooth dongle is connected to. Any help would be greatly appreciated!

XBMCbuntu {Frodo} - Ubuntu 12.04 (Main):
Intel Q6600 [2.4GHz Quad Core], 4GB DDR3, nVidia GT-210, Antec Fusion Case (iMon LCD), PS3 BD Remote

XBMC Live {Frodo} - Ubuntu 10.04 (Bedroom): Intel Atom D510 [1.66GHz Dual Core], ION Graphics, 2GB DDR2, PS3 BD Remote
find quote
Post Reply