Video playback problems!

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
CuFk Offline
Member
Posts: 52
Joined: Jan 2009
Reputation: 0
Post: #1
Hi!

I've been reading a few threads here but I can't seem to find any sollution to the problem.

When I watch any video using XBMC it seem like the picture is not horizontaly synced. I've been trying to change settings, turn vertical sync on and off and so on, but nothing seems to work.

I use the latest release of XBMC, and UltraMon to launch it on my TV in 1920x1080 resolution. Graphics card is a Nvidia 8600GT and a 3,0GHz AMD processor.

I'm greatful for any help I can get...
find quote
SlaveUnit Offline
Posting Freak
Posts: 1,736
Joined: Oct 2008
Reputation: 14
Location: San Diego
Post: #2
Just for the heck of it make sure its on in the Nvidia control panel as well. Also maybe turn on triple buffering also. With those on you can also try to set the XBMC to Let Driver Decide.
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #3
Triple buffering should be off!
Try setting your tv as primary monitor.
find quote
SlaveUnit Offline
Posting Freak
Posts: 1,736
Joined: Oct 2008
Reputation: 14
Location: San Diego
Post: #4
Oh...listen to bobo he knows way more than I do on the subject.

Bobo, Im just wondering why you wouldnt want to use triple buffering. Just asking so I can learn as well.

Would it be because the transfer of the buffer frame to the front fame slows it down?
(This post was last modified: 2009-06-17 21:45 by SlaveUnit.)
find quote
CuFk Offline
Member
Posts: 52
Joined: Jan 2009
Reputation: 0
Post: #5
Well. I can't set the TV as primary monitor since I need my computer as the primary. They don't run in the same resolution, and they're not in the same room. What should I turn on in the controll panel?

Thanks for helping me out!
find quote
SlaveUnit Offline
Posting Freak
Posts: 1,736
Joined: Oct 2008
Reputation: 14
Location: San Diego
Post: #6
CuFk Wrote:Well. I can't set the TV as primary monitor since I need my computer as the primary. They don't run in the same resolution, and they're not in the same room. What should I turn on in the controll panel?

Thanks for helping me out!

I was suggesting to make sure vsync is turned on on the Nvidia control panel.
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #7
SlaveUnit Wrote:Oh...listen to bobo he knows way more than I do on the subject.

Bobo, Im just wondering why you wouldnt want to use triple buffering. Just asking so I can learn as well.

Would it be because the transfer of the buffer frame to the front fame slows it down?

The nvidia drivers disable vsync when triple buffering is on and the running app doesn't to buffer swaps fast enough.
XBMC never does that when playing video because it has to render at a certain fps.
Games on the other hand always try to render as fast as possible.
find quote
CuFk Offline
Member
Posts: 52
Joined: Jan 2009
Reputation: 0
Post: #8
I've been trying the stuff you told me to try, but there's no change. It's so weird that XBMC isn't working but Windows Media Center plays all video files without any problems at all.

In Windows Media Player I use CoreAVX, CCCP and AC3 Filter. It seems to me that CoreAVC is one of the best codecs for decoding H.264 video on the market right now...
find quote
Ninjamawwe Offline
Member
Posts: 90
Joined: Mar 2007
Reputation: 0
Location: Gothenburg, Sweden
Post: #9
bobo, is the same true for ATI, i.e. it is best to disable triple buffering?
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #10
I have no idea about ati.
find quote
AzzX Offline
Senior Member
Posts: 153
Joined: Jul 2008
Reputation: 0
Location: Oz
Post: #11
Ninjamawwe Wrote:bobo, is the same true for ATI, i.e. it is best to disable triple buffering?
Doesn't appear to be an issue.
find quote
CuFk Offline
Member
Posts: 52
Joined: Jan 2009
Reputation: 0
Post: #12
It seems to be fixed now, I just installed Nvidias newest drivers. Smile
find quote