[MOD] Dan's Latest Movies & TV Hack

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dt1000 Offline
Member
Posts: 73
Joined: May 2009
Reputation: 4
Post: #1
Hi, All.
I've just finished a hack that adds a little overlay to Mediastream so you can quickly watch your latest files...

[Image: 2cedd16f461c7610ef642b8fb931774e5g.jpg]

You can download it here.

Just unzip the file to your XBMC directory and it will add Latest Movies & Latest TV panels to mediastream.

N.B. You will have to activate the panels from the skin settings (in Movies & TV) to see anything!

Enjoy! Cool
(This post was last modified: 2009-06-29 00:09 by dt1000.)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,450
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #2
Suweet. Grabbing it now!

EDIT:
Thanks for making it so easy to copy and paste into my already custom home.xml file Wink
Is there a way to make the script run when the home.xml window loades so when I first turn on XBMC I don't have to go run the script manually? I guess I could always do the auto load script thing.....but I'd rather have it so the script runs each time I return to the home menu form elsewhere in XBMC.

EDIT2:
Okay I found that your first change was:
Code:
<defaultcontrol always="true">308</defaultcontrol>
Which has the effect of running the script when the screen loads, but the side effect is that the text on the main menu does not animate with the panel.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2009-06-30 04:52 by kricker.)
find quote
dt1000 Offline
Member
Posts: 73
Joined: May 2009
Reputation: 4
Post: #3
Did you make sure the end of the file looks like this...
Code:
<!-- Code to handle running the script -->
               <control type="button" id="308">
                <description>Run Recently added</description>
                <posx>240</posx>
                <posy>240</posy>
                <width>10</width>
                <height>10</height>
                <onfocus>XBMC.RunScript(special://xbmc/scripts/recentadded.py)</onfocus>
                <onfocus>Control.SetFocus(305,0)</onfocus>
                <onfocus>Control.SetFocus(304,0)</onfocus>
                <onfocus>SetFocus(300)</onfocus>
                <visible>Skin.HasSetting(ShowLatestMovies) | Skin.HasSetting(ShowLatestTV)</visible>
            </control>
            
            <control type="button" id="308">
                <description>Run Recently added</description>
                <posx>240</posx>
                <posy>240</posy>
                <width>10</width>
                <height>10</height>
                <onfocus>SetFocus(300)</onfocus>
                <visible>!Skin.HasSetting(ShowLatestMovies) + !Skin.HasSetting(ShowLatestTV)</visible>
            </control>

  </controls>
</window>
?

The menu animates fine on my computer. Smile
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,450
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #4
dt1000 Wrote:Did you make sure the end of the file looks like this...
The menu animates fine on my computer. Smile
Yup just like that. I am planning on trying your home.xml in a few minutes to see if there is something wrong with mine. I love this mod.

EDIT:
Trying your home.xml results in the same thing. The home menu animates off properly, but not on. For example, when I go into movies and then return to the home menu, the text for the menu pops on, and then the panel slides in under it.

Video of it.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2009-06-30 20:05 by kricker.)
find quote
DrSlump Offline
Junior Member
Posts: 13
Joined: Nov 2008
Reputation: 0
Post: #5
Hi, sorry but in the video menù the lastmovie isn't viewed, only in menù "the movie" and "TV Shows".

Bye
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,450
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #6
DrSlump Wrote:Hi, sorry but in the video menù the lastmovie isn't viewed, only in menù "the movie" and "TV Shows".

Bye
I'm pretty sure that's how it works. You shouldn't see a panel for "videos".

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
Amplificator Offline
Junior Member
Posts: 9
Joined: Jul 2009
Reputation: 0
Post: #7
Is it possible to get it so show the latest 10 movies and tv episodes instead of just 4?

Other than that, it's a pretty nice mod along with the media flag mod Smile
find quote
BadMuts Offline
Junior Member
Posts: 26
Joined: Dec 2008
Reputation: 0
Post: #8
Very nice mod!! I like it a lot.

One question though: if I use the custom home.xml the system stall while scrolling to the movies & tv show buttons. This does not happen when I manually load the script.

Any suggestions? I'm using the latest svn build.

Thanks
find quote
pnobrega Offline
Junior Member
Posts: 13
Joined: Aug 2009
Reputation: 0
Post: #9
DrSlump Wrote:Hi, sorry but in the video menù the lastmovie isn't viewed, only in menù "the movie" and "TV Shows".

Bye

yep.. this happens to me to.. no image on the video..

also the image on the tv series is to large... i think it's getting the full image..

is this fixable??
find quote
gislihaukur Offline
Junior Member
Posts: 7
Joined: Mar 2009
Reputation: 0
Post: #10
dt1000 Wrote:Hi, All.
I've just finished a hack that adds a little overlay to Mediastream so you can quickly watch your latest files...

[Image: 2cedd16f461c7610ef642b8fb931774e5g.jpg]

You can download it here.

Just unzip the file to your XBMC directory and it will add Latest Movies & Latest TV panels to mediastream.

N.B. You will have to activate the panels from the skin settings (in Movies & TV) to see anything!

Enjoy! Cool

I have just installed the Mediastream theme and also your MOD and i have activated the two items and restarted xbmc and run the Update library but still no overlay screen in TV shows or Movies ?

any ideas ? i´m running this on a atv with the latest stable.
find quote
dt1000 Offline
Member
Posts: 73
Joined: May 2009
Reputation: 4
Post: #11
You have to activate the functionality in the settings menu! Smile
find quote
NeoDuck Offline
Member
Posts: 70
Joined: May 2010
Reputation: 0
Post: #12
kricker Wrote:Yup just like that. I am planning on trying your home.xml in a few minutes to see if there is something wrong with mine. I love this mod.

EDIT:
Trying your home.xml results in the same thing. The home menu animates off properly, but not on. For example, when I go into movies and then return to the home menu, the text for the menu pops on, and then the panel slides in under it.

Video of it.

Kricker, how did you get all the movie info from Aeon Flux to show up? I'm still new to XBMC, and have already set the content type for the movie folder and it's finished downloading all the "info" supposedly, but when I go into that screen, all it shows is a self-generated thumbnail from the file, no movie poster art, synopsis or any of that other good stuff?

I used these instructions: http://wiki.xbmc.org/?title=Video_Library
(This post was last modified: 2010-05-02 17:29 by NeoDuck.)
find quote