back to having r21xxxM on my *nix builds

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
althekiller Offline
Team-XBMC Developer
Posts: 4,926
Joined: May 2004
Reputation: 12
Post: #16
No real reason that file should be getting touched. It happens on both *nix builds?
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #17
no on Linux it is

root@Moya:~# cd /devel/XBMC
root@Moya:/devel/XBMC# svn st -q
M configure
root@Moya:/devel/XBMC#

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
find quote
althekiller Offline
Team-XBMC Developer
Posts: 4,926
Joined: May 2004
Reputation: 12
Post: #18
If you aren't running autoconf (autoheader in the MPCDec dir on OSX) and you aren't manually (or through a script) mucking with the file there's no way it's going to change. Presumably that's my ancient hack ass build.sh script? I really wouldn't use that anymore, it was deleted for a reason. Copy the install target out of the makefile and modify it to fit your needs instead.
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #19
althekiller Wrote:If you aren't running autoconf (autoheader in the MPCDec dir on OSX) and you aren't manually (or through a script) mucking with the file there's no way it's going to change. Presumably that's my ancient hack ass build.sh script? I really wouldn't use that anymore, it was deleted for a reason. Copy the install target out of the makefile and modify it to fit your needs instead.

I hacked out most everything from that build.sh. I only use it to create the dist package. I do not muck with any file, I'm not running the autoconf [now] and I do not use a script to modify any file on either OSX or Linux but both are having this issue, though both having different files modified Sad

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #20
Also i started using autoconf and svn revert because out of nowhere before I started getting these modified issues and i was told to use them Sad

this is what I am using to svn/build/package OS X

svn up && echo "Y" > temp_input_file && make reallyclean < temp_input_file && ./configure && export XBMC_HOME=`pwd` && make xcode_depends && xcodebuild -sdk macosx10.4 -project XBMC.xcodeproj -target XBMC.app -configuration Debug build && cd tools/PackageMaker && ./dmgmaker.pl ../../build/Debug/XBMC.app && cd /users/craig/XBMC/tools/PackageMaker/dist && tar -czf ./XBMC_OSX_21734.tgz XBMC.dmg && md5 -q XBMC_OSX_21734.tgz > /users/craig/xbmc/md5.txt && mv *.tgz /users/craig/xbmc

there is nothing in there that can modify that file so I have NO idea how or why it is. Sad

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
(This post was last modified: 2009-07-17 06:03 by TheQuestor.)
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #21
ok the problem is gone on OSX lol, no idea why, but this last build, using the above cmd did not produce a modified build .

I did a svn revert -R * on both branches and it did fix the OSX issue [even though I have been using that in my build cmd on both branches all along until this started happening again]

I just tried building Linux and now IT is borking lol.

I ran from the readme.ubuntu

apt-get install subversion make g++ gcc gawk pmount libtool nasm automake cmake gperf unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libsdl-sound1.2-dev libsdl-stretch-dev libfribidi-dev liblzo-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl4-dev x11proto-xinerama-dev libxinerama-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbis-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev

and it wasn't pretty,

issue 1
Note, selecting libsdl1.2-dev instead of libsdl-dev
libsdl1.2-dev is already the newest version.

Issue 2
Note, selecting libasound2-dev instead of libasound-dev
libasound2-dev is already the newest version.

Issue 3
Note, selecting libglew1.5-dev instead of libglew-dev
libglew1.5-dev is already the newest version.

Issue 4
Note, selecting libcurl4-gnutls-dev instead of libcurl4-dev
libcurl4-gnutls-dev is already the newest version.

Issue 5
Package libmysqlclient-dev is a virtual package provided by:
libmysqlclient15-dev 5.1.30really5.0.75-0ubuntu10.2
You should explicitly select one to install.
E: Package libmysqlclient-dev has no installation candidate

Issue 6
checking for main in -lmms... no
configure: error: Could not find a required library. Please see the README for your platform.


Some nights it just doesn't pay to do this. I am getting way too many gray hairs over this Sad


Edit -

apt-get install libmms-dev fixed the build issue.

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
(This post was last modified: 2009-07-17 06:20 by TheQuestor.)
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #22
both *nix builds are building clean now, no more rxxxxxM showing. I don't really know why it started or why it stopped but at least it did stop and all is well.

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
find quote
marshalleq Offline
Junior Member
Posts: 47
Joined: Oct 2008
Reputation: 0
Post: #23
Still happening here. You must have done something?!
find quote
TheQuestor Offline
Fan
Posts: 415
Joined: Jun 2005
Reputation: 0
Location: South TX US
Post: #24
marshalleq Wrote:Still happening here. You must have done something?!

I changed my build cmds back to my old way of doing them. I posted the actual command in http://www.xbmc.org/forum/showthread.php?t=54671&page=3 at the bottom of the page. They have worked for the last couple of days as is, might want to give it a try.

Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore E5200@3.0Ghz - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
find quote
Post Reply