[AppleTV] Broadcom Crystal HD Hardware Decoder Mini-PCIe Card support for Apple TV?

  Thread Rating:
  • 9 Votes - 4.89 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
thE_29 Offline
Junior Member
Posts: 17
Joined: Feb 2009
Reputation: 0
Post: #1336
davilla Wrote:1) Lots of users are using xbmc w/crystalhd on the AppleTV right now. You can search the forum for info and then decide for yourself if it would work for you.

2) If mplayer's devs include crystalhd support, and nito builds a version with it, then yes. Otherwise, support does not happen by magic and someone from the mplayer dev camp needs to step up and put the effort in.

I know you posted that a long time ago, but mplayer supports crystalhd now!

http://intr.overt.org/blog/?p=117
https://github.com/philipl/mplayer-crystalhd

Now we need a new nitoTV version or?
find quote
dimnet2000 Offline
Junior Member
Posts: 39
Joined: Jul 2010
Reputation: 0
Post: #1337
Is it working BCM970012 for Apple TV 2th generation?
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #1338
dimnet2000 Wrote:Is it working BCM970012 for Apple TV 2th generation?

Does the Apple TV 2th generation have a mini pcie slot ?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Brainfrz Offline
Junior Member
Posts: 40
Joined: Feb 2011
Reputation: 0
Location: Netherlands
Post: #1339
dimnet2000 Wrote:Is it working BCM970012 for Apple TV 2th generation?
The 2nd gen appletv doesn't have a mini-pci slot. the wifi board is soldered on.

But the appletv2 seems to be powerfull enough to decode 1080p, so why would you want it anyway?
find quote
h2sammo Offline
Junior Member
Posts: 43
Joined: May 2010
Reputation: 0
Post: #1340
i experience difficulties when starting 1080p movies on old appletv with gentoo and xbmc 10.0 and latest osx crystalhd version (http://bugs.gentoo.org/show_bug.cgi?id=344877) . For example if i am successful rendering the first 1080p mkv upon cold start of machine i can play any number of additional 1080p videos if i start the next one as the current one is still playing. once i wait for current to stop i cannot succesfully engage the next 1080p movie. dmesg will show crystalhd error similar to this: Insufficient Memory For RX.

is there a particular version of crystalhd driver that works best and i should try or the problem lies elsewhere?

thank you
find quote
bmel Offline
Junior Member
Posts: 11
Joined: Apr 2009
Reputation: 0
Post: #1341
I started a thread on this elsewhere but this seems a better thread for it. I apologize if that's a forum violation.

I have installed :
Launcher 3.2.5
XBMC 10.1 Git e9e9099 Mar 9, 2011
CrystalHD driver r174
Broadcom Crystal HD BCM70015
on my ATV1

Playback of 720p files is very nice. 1080p files in m2ts, ts or mkv containers (H264 Profile High@4.1 1920:10880p Frame rate:23.976) play poorly with much stuttering and frequent dropped frames. I seem to get 18fps with 95-98%cpu.
The crystal HD is enabled. I have tried changing most every setting I can find.

The same 1080p files play well if I run the ATV as a linux environment. Very smooth, good video and audio. Files also run well on my iMac.

I would rather run in the osx environment to preserve the apple tv functions.

XBMC also hangs when I exit after attempting to play a 1080p. Exit after 720p file playback is normal.

xbmc log at:
http://pastebin.com/bHYyC8nf

Any suggestions?

Thanks for your efforts
Brian
find quote
Galactus Offline
Member
Posts: 50
Joined: Mar 2004
Reputation: 0
Post: #1342
From my understanding its a resources issue. If you want to keep the ATV functions you are going to sacrifice smooth playback of 1080p files even with the Broadcom card installed. To resolve that issue you will need to do a full install.... but you will lose ATV menu options that you want to keep.
find quote
Observer Offline
Junior Member
Posts: 35
Joined: Mar 2011
Reputation: 0
Post: #1343
All

Having seem the liht that running on and OSX/ATV is not going to give me 1080p I'm now running XBMC on and AppleTV running Ubuntu Hardy (the atv-cloner image) with some limited success but still a lot of picture jumping and freezing. This is with Bluray rips via MakeMKV, containing h264 streams. I still have no video for VC-1 streams.

(also I'm pulling content from my NAS over UnPN - bit don't believe its a bandwidth issue, but am welcome to being corrected)

I all actuality beyond now having 1080p, my issues are exactly the same.

Logs are showing:

Code:
16:43:40 T:2640305040 M: 11788288 WARNING: CALSADirectSound::GetSpace - get space failed. err: -32 (Broken pipe)
16:43:40 T:2640305040 M: 11288576   ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe
and
Code:
19:12:34 T:2705820560 M: 15847424   DEBUG: CPullupCorrection: detected pattern of length 24: 42000.00 41000.00 42000.00 42000.00 41000.00 42000.00 42000.00 42000.00 41000.00 42000.00 42000.00 41000.00 42000.00 42000.00 42000.00 41000.00 42000.00 42000.00 41000.00 42000.00 42000.00 41000.00 42000.00 42000.00
19:13:25 T:2705820560 M: 19120128   DEBUG: CPullupCorrection: pattern lost
19:13:33 T:2705820560 M: 20447232 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available


I've seen a few threads talking about different NVidia and Alsa Driver versions....but have not found the definitive current "know to work" configuration (for any specific hardware/Linux disto combination).

There is the perception out there that folks have things running as sweet at a baby...and at the same time many of us struggling.

Am I having driver version issues ?

Is it worth having a thread/wiki page that shows the status of various configurations playing specific content perhaps linking to a thread where we can see existing discussion or post specific version issues or know to update to a newer version ?
find quote
bmel Offline
Junior Member
Posts: 11
Joined: Apr 2009
Reputation: 0
Post: #1344
Galactus Wrote:From my understanding its a resources issue. If you want to keep the ATV functions you are going to sacrifice smooth playback of 1080p files even with the Broadcom card installed. To resolve that issue you will need to do a full install.... but you will lose ATV menu options that you want to keep.

Ok. So now that I realize that I can't get the apple tv to do want I want (view 1080p with xbmc under the apple os), what should I do with the crystal HD card. Any reason to leave the Broadcom crystal hd installed in the apple tv? Will it improve performance with 720p files? Should I resell it on ebay?

Brian
find quote
Starstream Offline
Donor
Posts: 643
Joined: Apr 2009
Reputation: 16
Post: #1345
The CrystalHD will handle 720p video better than the ATV without it so I'd hang onto it.
find quote
Sam.Nazarko Offline
Posting Freak
Posts: 852
Joined: Dec 2009
Reputation: 16
Location: London
Post: #1346
bmel Wrote:Ok. So now that I realize that I can't get the apple tv to do want I want (view 1080p with xbmc under the apple os), what should I do with the crystal HD card. Any reason to leave the Broadcom crystal hd installed in the apple tv? Will it improve performance with 720p files? Should I resell it on ebay?

Brian

Use a Linux distro (see sig)
find quote
Post Reply