DLNA in new Sony Bravia KLD-40Z5500

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Zornac Offline
Junior Member
Posts: 4
Joined: Aug 2009
Reputation: 0
Post: #1
Hi,

I'm trying to put together XBMC and Sony's KDL-40Z5500 via DLNA. Many have noticed that Z4500's DLNA supports only pic's and music, but Sony has informed that nyt Z5500 should support also video:

http://www.sony.co.uk/comparison/kdl40z5...dl40z4500u

My problem is this. I've activated UPnP client, renderer and server in XBMC and also created music, video and video shares where are some mp3s, jpgs and avis. Openig these using XBMC works fine on my Mac. Sony's TV do not show XBMC media center in Photo, Music or Video -sections when browsing "home" menu. It only shows Windows Media Player's media sharing service from the other computer in my network.

When going to "network settings" in TV and choosing "server diagnostic" the XBMC is found from network, but TV says that it cannot be connected successfully. When opening found media server TV will give XBMC's information like IP, UDN, MAC and TCP port. It also gives this error message "Compatible files could not be found". :confused2:

Am I doing something wrong setting up XBMC? Does XBMC support Sony's Z5500 series DLNA? Will it support it at some time in future - when?
(This post was last modified: 2009-08-18 16:54 by Zornac.)
find quote
CrashX Offline
Posting Freak
Posts: 1,164
Joined: Jan 2009
Reputation: 2
Post: #2
What is OS are you running xbmc server on ?
Can you please post full debug log ?

Have you tried accessing xbmc UPnP server via other UPnP clients ?

The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
find quote
Zornac Offline
Junior Member
Posts: 4
Joined: Aug 2009
Reputation: 0
Post: #3
Hi,

I’m running OS X 10.5.8, Intel. I’m sending the log to you using private message (your tagline was helpfull). Smile

I’m running Vista on my other computer and I tried to access XBMC library from there, but it did not work either - I guess this means that my library is not functioning properly either. Attempt is located in the log with timestamp 18:01:45.
find quote
CrashX Offline
Posting Freak
Posts: 1,164
Joined: Jan 2009
Reputation: 2
Post: #4
Please post logs on the forum so that others ( ie developers ) can look as well ..

What client software are you using on vista to view xbmc library ?

The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
find quote
Zornac Offline
Junior Member
Posts: 4
Joined: Aug 2009
Reputation: 0
Post: #5
CrashX Wrote:What client software are you using on vista to view xbmc library ?

Media Player v.11.0.6002.18065 found the server from network so I just tried that one. I don't really know what is a good program for Windows to use as a client for media sharing servers - and I'm not sure would I be as it is Windows. Smile
(This post was last modified: 2009-08-19 20:37 by Zornac.)
find quote
MDPauley Offline
Senior Member
Posts: 263
Joined: Mar 2004
Reputation: 0
Location: Centreville, Va
Post: #6
http://wiki.xbmc.org/index.php?title=HOW...Bug_Report

"Note! Please never cut and paste logs into a post on the XBMC Community Forum, instead use one of the many pasting websites such as pastebin.com or pastebin.ca to upload your entire log and then only post the link to that web page. Thank you in advance for not cluttering the XBMC Community Forum"
find quote
Zornac Offline
Junior Member
Posts: 4
Joined: Aug 2009
Reputation: 0
Post: #7
Ok, I was thinking something simillar, plain pasting cannot be a good idea. Smile
Here it is. http://pastebin.com/m38d4207c
(This post was last modified: 2009-08-19 20:27 by Zornac.)
find quote
Joe76000 Offline
Junior Member
Posts: 10
Joined: Sep 2009
Reputation: 0
Post: #8
Hello Guys,

I am new from today on this forum.
I know I am on the MAC part of this forum but I think the solution could be the same...

I am owning a Sony Bravia KDL-46W5710 (W5500 series) which is very similar to the Z5500 series and have both the same DLNA client (accordingly to Sony's specifications).
I have exactly the same issues than Zornac with the XBMC setups and the same information on my Bravia.

I have installed lastest XBMC version (precision: version 9.04.1-jaunty1) on one of my PC (the weakest one) under Linux Ubuntu 9.04 (with dual boot Linux / Windows XP SP3).

Under Linux, XBMC is working fine for both local and LAN media files (WD MyBookWorld NAS with Twonky Media Server). XBMC is really a great S/W.

My LAN setup (compact) is as follows:
PC / LINUX / UBUNTU 9.04 / XBMC / FREEBOX (French ISP tripleplay box) with 100 MB router / LAN CAT 5E CABLE / BRAVIA DLNA Client.

When testing my network from my TV, the DLNA client is saying (as for Zornac) "Compatible files could not be found" even if all TV network parameters are okay.

So I am stuck... And even Googling the web, reading XBMC forum, XBMC Wiki, etc... I cannot find the WHY of my issue and thus the solution!

FYI: I have tested under my Linux PC and with the same configuration an other DLNA server; i.e. the latest beta version of PS3 Media Server (even if I am not owning a PS3 but an XBOX 1st G), and this server (only) was working. It was immediatly recognized by my Bravia for all A/V files (music, photo and video). My Bravia can directly stream from PS3MS (without any transcoding) MPEG-2, AVCHD (lite and full) and HDV, and with transcoding (renderer) to MPEG-2 a lot of other video formats.
There are still a lot of issues with this S/W, but at least I got something working.

Now, I would like really to have both in a given S/W; i.e. a DLNA Client awa a DLNA Server and XBMC is supposed to achieve both.

So, HELP and suggestion would be greatly appreciated for trying to fix the problem I am / we are currently facing to with XBMC.

Many thanks in advance to the helpers.
Cheers.
(This post was last modified: 2009-09-07 10:06 by Joe76000.)
find quote
Joe76000 Offline
Junior Member
Posts: 10
Joined: Sep 2009
Reputation: 0
Post: #9
Link to my thread in the Linux section where I have updated and summarized the add tests I have made:
http://www.xbmc.org/forum/showthread.php...post398591

This could also help MAC users, as it seems the issue is with the DLNA client of the Sony Bravia series (Z, W and so on).

Cheers.
find quote
CrashX Offline
Posting Freak
Posts: 1,164
Joined: Jan 2009
Reputation: 2
Post: #10
Windows Media Player 11 has a DLNA server built in. Click Library -> Media Sharing. Does that work on the Sony TV ?

The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
find quote
elupus Offline
Team-XBMC Developer
Posts: 3,799
Joined: Mar 2004
Reputation: 3
Post: #11
that was a really old log.. could you post an updated Debug Log from a recent build?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote