[MOD] xTV SAF (Spouse Acceptance Factor)

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #616
[Image: 4a477b166394730.jpg]
blank video menu
http://pastebin.com/ERcwnNzf

[Image: 537e9f138616114.jpg]
location play using.. dialong window not centered

it seem player osd dissapered, i also try on vie as window still not showing
http://pastebin.com/DXJc63ca

something missing, if i chose music video info & artist name it doesnt show anything
[Image: 69ae05166154556.jpg]
http://pastebin.com/4VGVbUpz

different colored time bar in playlist view music
[Image: 8878f1166153722.jpg]

what function "power menu avtion" & "search on home menu "served ? is this eden only option ?
[Image: 9360c8166155473.jpg]
(This post was last modified: 2011-12-26 08:02 by lipo.)
find quote
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #617
[Image: aauiyERQ.jpg]
little fix for position player osd text on viwe as window (video playlist)
find quote
Javalsu Offline
Junior Member
Posts: 11
Joined: Nov 2011
Reputation: 0
Post: #618
Great job, I (and my wife) love this skin.

One question though. I have XBMC installed on my laptop as well as my apple tv. When I set the fan art as the background on my laptop, the fan art's opacity is lower, and and the background color comes through. Which makes the menu much more readable.

However, when I set it on the atv, the fan art is at 100% opacity and it may wash out the text in the menus.

Am I missing a setting?
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #619
Javalsu Wrote:Great job, I (and my wife) love this skin.

One question though. I have XBMC installed on my laptop as well as my apple tv. When I set the fan art as the background on my laptop, the fan art's opacity is lower, and and the background color comes through. Which makes the menu much more readable.

However, when I set it on the atv, the fan art is at 100% opacity and it may wash out the text in the menus.

Am I missing a setting?
Javalsu,

I believe this is an issue with the AppleTV (gen2) build of XBMC. Try using a latter build of XBMC should probably help this. Go check the FAQ's for AppleTV in this forum should confirm if this is your issue.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #620
lipo Wrote:[Image: aauiyERQ.jpg]
little fix for position player osd text on viwe as window (video playlist)
Lipo, just got back from the family camping holiday. Will check thru your posts and see what I can fix.

Could you please e-mail me a copy of the english strings.xml file from your build of XBMC (not the strings file from my skin) as some of the problems are due to changes between Eden and XBox build of XBMC. Power menu action should be working on XBox build (it allows to to either quit from the home menu quit button or go to the shutdown menu from this button). Yes Search from home menu is Eden only, will fix. Will work my way thru your list and get back to you on some of the other issues latter.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #621
wyrm Wrote:Lipo, just got back from the family camping holiday. Will check thru your posts and see what I can fix.

Could you please e-mail me a copy of the english strings.xml file from your build of XBMC (not the strings file from my skin) as some of the problems are due to changes between Eden and XBox build of XBMC. Power menu action should be working on XBox build (it allows to to either quit from the home menu quit button or go to the shutdown menu from this button). Yes Search from home menu is Eden only, will fix. Will work my way thru your list and get back to you on some of the other issues latter.

Wyrm (xTV-SAF)

great to have you back wyrm

will send xml file after downloaded latest xbmc4xbox svn just in case there's more changes
find quote
Javalsu Offline
Junior Member
Posts: 11
Joined: Nov 2011
Reputation: 0
Post: #622
wyrm Wrote:Javalsu,

I believe this is an issue with the AppleTV (gen2) build of XBMC. Try using a latter build of XBMC should probably help this. Go check the FAQ's for AppleTV in this forum should confirm if this is your issue.

Wyrm (xTV-SAF)

Thanks for the help. I'm running Eden Beta 1, perhaps it's just a bug in Eden.
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #623
lipo Wrote:[Image: b83860166111421.jpg]
[Image: d95f9d166111429.jpg]
weird thing about list view, the screenshot size change after few seconds ?
it should behave like that ??
Lipo, short answer , YES. Long answer you should also see plot info like in List2 view appear when the Icon shrinks (it has to get out of the way so I can show more info). This and a number of the other problems are caused by the XBox build not evaluating <visible> conditions like Eden build does.

Can you please grab the latest SVN version of the skin (426 at last count) and see what problem remain. Then restarting XBMC, can you then show only the problems and post a debug log so that I can see which conditions are failing (they show up in the log file, so don't really need screen shots to see this problem).

Hopefully you should see a major improvement with the last couple of updates to the skin.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #624
wyrm Wrote:Lipo, short answer , YES. Long answer you should also see plot info like in List2 view appear when the Icon shrinks (it has to get out of the way so I can show more info). This and a number of the other problems are caused by the XBox build not evaluating <visible> conditions like Eden build does.

Can you please grab the latest SVN version of the skin (426 at last count) and see what problem remain. Then restarting XBMC, can you then show only the problems and post a debug log so that I can see which conditions are failing (they show up in the log file, so don't really need screen shots to see this problem).

Hopefully you should see a major improvement with the last couple of updates to the skin.

Wyrm (xTV-SAF)

now i get itSmile
great solution because the lack of space to display media infoLaugh
if this works i will disable list2 view & gain more memory

just downloaded svn 426, still no media info
http://pastebin.com/TsxFwVJM
find quote
vibber419 Offline
Junior Member
Posts: 1
Joined: Jan 2012
Reputation: 0
Post: #625
Hi, I am pretty new to XBMC, and have run into an issue that I would like some help with. I have XBMC running on my Apple TV 2. I have tried out different skins and installed xTV-SAF 1.0.2 because I was looking for something similar to the Apple TV appearance. I was able to install it ok, but now if I click on settings, nothing happens. Is there something I have done incorrectly? Can somebody let me know how to fix this or at the very least change the skin or uninstall? Any help would be appreciated. Thanks.
find quote
eddiem Offline
Senior Member
Posts: 115
Joined: Oct 2010
Reputation: 0
Location: Edinburgh, Scotland
Post: #626
I tried this skin tonight and it looks and works great.
One point is that there is no location showing on weather windows.
MyWeather.xml Line 45:
$INFO[Weather.Location]
I copied from Transparency:
$INFO[Window(Weather).Property(Location)]
and location is displayed.
Regards,
Eddie.
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #627
vibber419 Wrote:Hi, I am pretty new to XBMC, and have run into an issue that I would like some help with. I have XBMC running on my Apple TV 2. I have tried out different skins and installed xTV-SAF 1.0.2 because I was looking for something similar to the Apple TV appearance. I was able to install it ok, but now if I click on settings, nothing happens. Is there something I have done incorrectly? Can somebody let me know how to fix this or at the very least change the skin or uninstall? Any help would be appreciated. Thanks.
vibber419,

Look at the first post of this thread, there you will see details on downloading the skin. For the AppleTV you will need at least version 1.1.1 (Eden) as the AppleTv has only ever run a version of Eden XBMC. If you are able to figure out how to run the skin from the Passion repo (instructions are in first post also) I would recommend that you use v1.2.0 as there has been a lot of changes since the beginning of the Eden cycle of XBMC. v1.1.1 will work (mostly), but v1.2.0 from the Passion repo is pretty well up to date and so is a much better option.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #628
eddiem Wrote:I tried this skin tonight and it looks and works great.
One point is that there is no location showing on weather windows.
MyWeather.xml Line 45:
$INFO[Weather.Location]
I copied from Transparency:
$INFO[Window(Weather).Property(Location)]
and location is displayed.
Regards,
Eddie.
eddiem,

Thank you for pointing that out. This is because of the recent change to how weather is handled by XBMC. I will be going thru the Eden build of the skin to fix issues like this after I have sorted out the major problem in the XBox build (kind of owe Lipo for ALL of the good bug reports that he makes for me).

Please feel free to point out any other issues like this, as I tend to miss things here and there and this list is a handy reminder.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Online
Skilled Skinner
Posts: 944
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #629
lipo Wrote:now i get itSmile
great solution because the lack of space to display media infoLaugh
if this works i will disable list2 view & gain more memory

just downloaded svn 426, still no media info
http://pastebin.com/TsxFwVJM
Lipo,

Yep thanks tiger, got the offending <visible> condition, will see what I can do. Watch the SVN and let me know if there is still a problem. Is there still an issue with the fanart background (another <visible> condition) or have I got that one? As you have noticed there has been a number of changes and it is sometimes a bit difficult keeping track of changes and if they have fixed things (sorry flying blind on the XBox at the moment).

Keep up the good work sport.
Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #630
wyrm Wrote:Lipo,

Yep thanks tiger, got the offending <visible> condition, will see what I can do. Watch the SVN and let me know if there is still a problem. Is there still an issue with the fanart background (another <visible> condition) or have I got that one? As you have noticed there has been a number of changes and it is sometimes a bit difficult keeping track of changes and if they have fixed things (sorry flying blind on the XBox at the moment).

Keep up the good work sport.
Wyrm (xTV-SAF)

yup fanart still dont appear
full screen visualization also dont appear

on the postive note clearart works
waiting for next svnLaugh
find quote
Post Reply