[RELEASE] Gmail Checker (Script)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
logictester Offline
Fan
Posts: 682
Joined: Oct 2008
Reputation: 0
Location: USA
Post: #16
sorry not posting before, here is the debug log

http://pastebin.com/m381581f0


edit: i left it running and it managed to connect after a while and now working just fine Smile any plans on notifications to the XBMC GUI?

edit2: it still fails to connect on first attempt and have to be left running...
(This post was last modified: 2009-11-25 21:55 by logictester.)
find quote
mymymy Offline
Junior Member
Posts: 24
Joined: Dec 2009
Reputation: 0
Post: #17
I'm also having trouble getting it to run on Win 7 x64

Log is http://pastebin.com/m1b3ce1bb
find quote
gatv_user Offline
Junior Member
Posts: 5
Joined: Jan 2010
Reputation: 0
Question  Looks great- but error on ATV
Post: #18
Get an Error: CBMC/Boxee exited with status:10

From debug log:


21:55:44 T:2684407808 M: 31940608 DEBUG: ------ Window Init (/Users/frontrow/Library/Application Support/XBMC/scri$
21:55:44 T:2684407808 M: 31940608 INFO: Loading skin file: /Users/frontrow/Library/Application Support/XBMC/scrip$
21:55:44 T:2684407808 M: 31936512 DEBUG: unable to load /Users/frontrow/Library/Application Support/XBMC/scripts/G$
21:55:44 T:2684407808 M: 31875072 DEBUG: Load /Users/frontrow/Library/Application Support/XBMC/scripts/GmailChecke$
21:55:44 T:2684407808 M: 31825920 DEBUG: Alloc resources: 59.88ms (14.25 ms skin load)
21:55:44 T:2684407808 M: 31825920 DEBUG: CGUIMediaWindow::GetDirectory (?)
21:55:44 T:2684407808 M: 31825920 DEBUG: ParentPath = []
21:55:44 T:2684407808 M: 31821824 ERROR: GetDirectory - Error getting ?
21:55:44 T:2684407808 M: 31821824 ERROR: CGUIMediaWindow::GetDirectory(?) failed
21:55:44 T:2684407808 M: 31821824 ERROR: Control 101 in window 13000 has been asked to focus, but it can't

Willing to troubleshoot as needed - would be great to have this.
find quote
d3us Offline
Junior Member
Posts: 17
Joined: Dec 2009
Reputation: 0
Post: #19
anything new?
i cant get it work... win 7...

zeljko brate... angazuj se malo Tongue
find quote
amet Offline
Posting Freak
Posts: 4,113
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #20
d3us Wrote:anything new?
i cant get it work... win 7...

zeljko brate... angazuj se malo Tongue

works fine on my side Smile, post a debug log

"sta mu je??, sad mu nije nista... ubio si ga ko zeca" Smile


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find quote
juniorz Offline
Junior Member
Posts: 1
Joined: Sep 2010
Reputation: 0
Post: #21
There can be several issues :

first of all the URL in the 'script.gmail.checker\resources\lib\gui.py' line 16 '_URL = "https://mail.google.com/gmail/feed/atom"' might be not accessable from several countries. One example is Germany.

Try this URL instead
'https://mail.google.com/a/googlemail.com/feed/atom'

The next thing could be that you are using a proxy setting which is valid system wide. If so, disable the proxy in your browser and try again.

cheers
J
find quote
AddictedToMetal Offline
Member
Posts: 77
Joined: Dec 2009
Reputation: 0
Post: #22
So is this supposed to show a pop-up when new mail arrives?

If not, that would be a big plus IMO. Nice little pop-up using the normal XBMC notifications.

Aside from that, this is really nice. Thanx. Smile
find quote
michal Offline
Senior Member
Posts: 160
Joined: Oct 2005
Reputation: 0
Location: Brisbane, Australia
Post: #23
As far as I can tell Google broke this plugin.

http://www.google.tt/support/forum/p/gma...86ba&hl=en
find quote
amet Offline
Posting Freak
Posts: 4,113
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #24
it works just fine for me, not sure what to tell you


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find quote
Laureus1 Offline
Junior Member
Posts: 8
Joined: Jan 2011
Reputation: 0
Post: #25
I'm sorry, I made a mistake. It seems that the plug-in doesn't work when you're already logged into gmail. When I signed off manually it was able to fetch my email.

Perhaps this could be improved in coming versions?
Great addon though!

Quote:Hi,

I'm a bit of a newbie concerning xbmc, but I tried to install the gmail checker. However I get an error stating 'error connecting to gmail'. When I put the URL from the gui-file into the browser myself, I do get feed about my new emails.

How do I find out what causes this error, how do I know if I'm connecting through a proxy?

Thanx
(This post was last modified: 2011-01-14 17:29 by Laureus1.)
find quote
drewzh Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #26
OP,
Are you still actively developing this? I'm really interested in getting this plugin going with a bit more functionality. If not then I'd like to add background updates and possibly a way of reading each message. Unfortunately without this, the plugin isn't very useful.

Cheers,
Drew
find quote
amet Offline
Posting Freak
Posts: 4,113
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #27
drewzh Wrote:OP,
Are you still actively developing this? I'm really interested in getting this plugin going with a bit more functionality. If not then I'd like to add background updates and possibly a way of reading each message. Unfortunately without this, the plugin isn't very useful.

Cheers,
Drew

sure, show me what you have and we'll talk about it


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find quote
john.doe Offline
Banned
Posts: 514
Joined: Aug 2010
Post: #28
juniorz Wrote:There can be several issues :

first of all the URL in the 'script.gmail.checker\resources\lib\gui.py' line 16 '_URL = "https://mail.google.com/gmail/feed/atom"' might be not accessable from several countries. One example is Germany.

Try this URL instead
'https://mail.google.com/a/googlemail.com/feed/atom'

The next thing could be that you are using a proxy setting which is valid system wide. If so, disable the proxy in your browser and try again.

cheers
J

I have exact this problem.

Where is the file that i can change it?

Greets


I found the file and it works now fine!
(This post was last modified: 2011-01-15 23:39 by john.doe.)
find quote
ryan03rr Offline
Junior Member
Posts: 49
Joined: Feb 2009
Reputation: 0
Location: the home of moto
Post: #29
Laureus1 Wrote:I'm sorry, I made a mistake. It seems that the plug-in doesn't work when you're already logged into gmail. When I signed off manually it was able to fetch my email.

Perhaps this could be improved in coming versions?
Great addon though!
im having a issue similar... can the gmail plugin run on 2 boxes simultaneously......... seems that it will not read the feed if another gmail plugin on another box has been used in the last 12 -24 hours...
tried everything. password username copying the plugin from one box to another....
anyway plugin works great unless there are 2 boxes using the same wan ip accesing the same gmail account..

i would also like to know if the plugin can support respecting the back button normally mapped to a xb ir kit. no big deal to hit menu to exit... just would love not to have to explain that to the woman. (back key doesnt work)..
i

RYAN03
[Image: signature.jpg]
find quote
KidVulcan Offline
Senior Member
Posts: 100
Joined: May 2010
Reputation: 0
Post: #30
Hi, I see no one has been in here for a while and I don't mean to revive dead threads so if this is one pleas excuse me. I just got this up and running in xbmc eden-beta but how do you view individual messages?

[Image: widget]
[Image: widget]
find quote