[LINUX] xbmc interface very slow

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
PipBoy2000 Offline
Junior Member
Posts: 3
Joined: Nov 2009
Reputation: 0
Sad  [LINUX] xbmc interface very slow
Post: #1
xbmc interface is very very slow. I have ~0.1 FPS and 100% CPU usage (~99% is xbmc). It is completly unusable. :-(

Build
Camelot Alpha2 from PPA

My system
Ubuntu Karmic Koala
CPU: Intel® Pentium® 4 Mobile CPU 1.60GHz
GPU: ATI Technologies Inc Radeon Mobility M6 LY
(using OSS drivers radeon)
RAM: 256 MiB

glxinfo
direct rendering: Yes
...
OpenGL renderer string: Mesa DRI R100 (RV100 4C59) 20090101 AGP 1x x86/MMX/SSE2 NO-TCL
OpenGL version string: 1.3 Mesa 7.6


I have tried to change Vsync settings (on, off, video) with no success. Also I have tried changing resolution and full screen/windowed mode with same result.

Any suggestion?
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,221
Joined: Oct 2003
Reputation: 178
Post: #2
Try the binary drivers for the ATI card.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
boludo Offline
Junior Member
Posts: 2
Joined: Nov 2009
Reputation: 0
Post: #3
jmarshall Wrote:Try the binary drivers for the ATI card.

Same problem here, ubuntu 9.10 with ati 9200 board

I don't think that installing the binary drivers will be of any help, it seems that they don't support cards earlier than 9500

Any help would be appreciated !
find quote
PipBoy2000 Offline
Junior Member
Posts: 3
Joined: Nov 2009
Reputation: 0
Post: #4
boludo Wrote:Same problem here, ubuntu 9.10 with ati 9200 board

I don't think that installing the binary drivers will be of any help, it seems that they don't support cards earlier than 9500

Any help would be appreciated !

Yes there are no drivers from AMD.

At first change skin from PM3.HD to Project Mayhem III. Performance will go up like hell Big Grin

This will be good suggestion to devs: Change default Skin is too slow for older HW.
find quote
boludo Offline
Junior Member
Posts: 2
Joined: Nov 2009
Reputation: 0
Post: #5
PipBoy2000 Wrote:At first change skin from PM3.HD to Project Mayhem III. Performance will go up like hell Big Grin

Thx PipBoy. I managed to change the skin but it didn't change anything...

When I say the interface is very slow, it's VERY slow, something like a frame every 4 seconds...
I think there's a problem with hardware acceleration it's like the CPU is doing all the job (info: direct rendering is enabled and glxgears runs smoothly with a result of about 1400fps)

There must be something obvious...
find quote
PipBoy2000 Offline
Junior Member
Posts: 3
Joined: Nov 2009
Reputation: 0
Post: #6
boludo Wrote:Thx PipBoy. I managed to change the skin but it didn't change anything...

When I say the interface is very slow, it's VERY slow, something like a frame every 4 seconds...
I think there's a problem with hardware acceleration it's like the CPU is doing all the job (info: direct rendering is enabled and glxgears runs smoothly with a result of about 1400fps)

There must be something obvious...

well I am sorry to hear(see) this, because 0.1 FPS WAS exactly my problem, have you tried to play with vsync settings? (maybe...)
find quote
FaberfoX Offline
Junior Member
Posts: 6
Joined: Feb 2009
Reputation: 0
Post: #7
I have the same issue on a thinkpad T40 (ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]) running karmic.
The only solution I found so far is to downgrade these 2 packages with the Jaunty versions:
libgl1-mesa-dri (http://packages.ubuntu.com/jaunty/i386/l...i/download)
libgl1-mesa-glx (http://packages.ubuntu.com/jaunty/i386/l...x/download)

There are still glitches if run in a window but fullscreen works ok.
find quote
knefas Offline
Junior Member
Posts: 4
Joined: Nov 2010
Reputation: 0
Post: #8
I know this is nearly one year old, but I seem to be having the same issue with very similar hardware. Did you find any solutions to this in the end?
find quote
llyzs Offline
Junior Member
Posts: 8
Joined: Dec 2010
Reputation: 10
Post: #9
recently I switched to use the open-source radeon driver from fglrx and I encounter the same issue. XBMC GUI renders slow like hell. But I have figured out the solution.

I know this is extremely old thread but I just want to post my solution here to help other googlers. My solution is just run xbmc, go to system settings, and disable video output vsync. XBMC immediately come back to normal.
find quote
sitealpha Offline
Junior Member
Posts: 5
Joined: Dec 2013
Reputation: 0
Post: #10
I had the same issue. Here is how I resolved it. I thought it may be because I had an HP laptop (and it still maybe the issue) with no Windows 8 video drivers that was slowing my video down and made it look like slow motion so I restored my computer with Windows 7 OS. I ran the same video that I had just ran earlier and it ran at normal speed. While watching the video I adjusted my system/system/audio output from 2.0 speaker configuration to 4.1 and the video immediately went into slow motion. I adjusted it back to 2.0 and it ran at normal speed. I then restored my OS back to windows 8 and adjusted my system/system/audio output to 2.0 on the speaker configuration and it ran at normal speed again. I hope this helps others because I spent many hours figuring this out.
find quote