[bugs]

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
GrinRoth Offline
Member
Posts: 69
Joined: May 2009
Reputation: 0
Location: Netherlands
Post: #31
noox Wrote:I have a couple of bugs to report. Hopefully it's not user error.
My setup is:
Linux Ubuntu 9.10
1080p resolution
xbmc svn rev 25266
Alaska is at head as of this posting

5) browsing with studio flag enabled crashes xbmc. I do have the studios dir in the extras folder. Sometimes xbmc crashes right away when i browse movies in poster view and sometimes it takes a bit but it seems to always crash with that option. Anyone running linux seeing this?

[EDIT HITCHER] Can't reproduce.

Hitcher this is a great skin. Thank you for the effort.

I do have the exact same problem, using ubuntu 9.04 mini install.
xbmc is latest beta from ppa.

Last log is like this:
Code:
21:15:42 T:3029343120 M:1352663040   DEBUG: Thread 3029343120 terminating
21:15:43 T:3040642960 M:1352671232   DEBUG: LIRC: Update - NEW at 15441:000000037ff07bde 00 Right mceusb (Right)
21:15:43 T:3040642960 M:1352671232   DEBUG: OnKey: 168 pressed, action is 2
21:15:43 T:3040642960 M:1352671232    INFO:   msg: PICTURE::LoadImage: Unable to open image: special://skin/extras/studios/Bazmark Films / 720p / 0 / V_MPEG4/ISO/AVC / DTS / 6ch / eng / subeng / subdum.png Error: (2)
21:15:43 T:3040642960 M:1352671232   ERROR: Texture manager unable to load file: special://skin/extras/studios/Bazmark Films / 720p / 0 / V_MPEG4/ISO/AVC / DTS / 6ch / eng / subeng / subdum.png
21:15:43 T:3040642960 M:1346527232   DEBUG: LIRC: Update - NEW at 15974:000000037ff07bde 00 Right mceusb (Right)
21:15:43 T:3040642960 M:1346527232   DEBUG: OnKey: 168 pressed, action is 2
21:15:43 T:3040642960 M:1345712128    INFO:   msg: PICTURE::LoadImage: Unable to open image: special://skin/extras/studios/Silver Screen Partners IV / sddvd / ac-3 / 6ch / subs.png Error: (2)
21:15:43 T:3040642960 M:1345712128   ERROR: Texture manager unable to load file: special://skin/extras/studios/Silver Screen Partners IV / sddvd / ac-3 / 6ch / subs.png
21:15:44 T:3040642960 M:1345839104   DEBUG: LIRC: Update - NEW at 16478:000000037ff07bde 00 Right mceusb (Right)
21:15:44 T:3040642960 M:1345839104   DEBUG: OnKey: 168 pressed, action is 2
21:15:44 T:3040642960 M:1345839104 WARNING: CreateFile, successfuly opened </home/xbmc/.xbmc/skin/Alaska/extras/Studios> instead of </home/xbmc/.xbmc/skin/Alaska/extras/studios/>
Maybe it has something to do with linux being case-sensitive?
When disabling studioflags then no more crashes anymore.

XBMC Main HTPC:
Asrock ION 330 running Openelec 3

XBMC 2:
XBMC Frodo running on OSX 10.8 (Core i7, Hackintosh)

XBMC 3:
XBMC Frodo running on OSX 10.8 (2011 iMac)

Server and TVHeadend backend: Ubuntu 12.04
find quote
noox Offline
Junior Member
Posts: 9
Joined: Dec 2009
Reputation: 0
Post: #32
GrinRoth Wrote:Maybe it has something to do with linux being case-sensitive?
When disabling studioflags then no more crashes anymore.

That looks to be the case. I rename extras/Studio to extras/studio and no more crashes.
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,748
Joined: Aug 2007
Reputation: 98
Location: Eastleigh, UK
Post: #33
noox Wrote:Looks like another case sensitive issue. I checked with Aeon and default folder is "DefaultFolder.png" and default artist is "DefaultArtist.png. Alaska has it as all lowercase. I symlinked a couple others to their correct cases and it makes the icons appear.

GrinRoth Wrote:I do have the exact same problem, using ubuntu 9.04 mini install.
xbmc is latest beta from ppa.

Last log is like this:
Code:
21:15:42 T:3029343120 M:1352663040   DEBUG: Thread 3029343120 terminating
21:15:43 T:3040642960 M:1352671232   DEBUG: LIRC: Update - NEW at 15441:000000037ff07bde 00 Right mceusb (Right)
21:15:43 T:3040642960 M:1352671232   DEBUG: OnKey: 168 pressed, action is 2
21:15:43 T:3040642960 M:1352671232    INFO:   msg: PICTURE::LoadImage: Unable to open image: special://skin/extras/studios/Bazmark Films / 720p / 0 / V_MPEG4/ISO/AVC / DTS / 6ch / eng / subeng / subdum.png Error: (2)
21:15:43 T:3040642960 M:1352671232   ERROR: Texture manager unable to load file: special://skin/extras/studios/Bazmark Films / 720p / 0 / V_MPEG4/ISO/AVC / DTS / 6ch / eng / subeng / subdum.png
21:15:43 T:3040642960 M:1346527232   DEBUG: LIRC: Update - NEW at 15974:000000037ff07bde 00 Right mceusb (Right)
21:15:43 T:3040642960 M:1346527232   DEBUG: OnKey: 168 pressed, action is 2
21:15:43 T:3040642960 M:1345712128    INFO:   msg: PICTURE::LoadImage: Unable to open image: special://skin/extras/studios/Silver Screen Partners IV / sddvd / ac-3 / 6ch / subs.png Error: (2)
21:15:43 T:3040642960 M:1345712128   ERROR: Texture manager unable to load file: special://skin/extras/studios/Silver Screen Partners IV / sddvd / ac-3 / 6ch / subs.png
21:15:44 T:3040642960 M:1345839104   DEBUG: LIRC: Update - NEW at 16478:000000037ff07bde 00 Right mceusb (Right)
21:15:44 T:3040642960 M:1345839104   DEBUG: OnKey: 168 pressed, action is 2
21:15:44 T:3040642960 M:1345839104 WARNING: CreateFile, successfuly opened </home/xbmc/.xbmc/skin/Alaska/extras/Studios> instead of </home/xbmc/.xbmc/skin/Alaska/extras/studios/>
Maybe it has something to do with linux being case-sensitive?
When disabling studioflags then no more crashes anymore.
XBMC now sorts out case issues it comes across.
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,748
Joined: Aug 2007
Reputation: 98
Location: Eastleigh, UK
Post: #34
noox Wrote:That looks to be the case. I rename extras/Studio to extras/studio and no more crashes.
I changed that a week or so ago so you've missed an update or something.
find quote
hikaricore Offline
Posting Freak
Posts: 1,515
Joined: Dec 2008
Reputation: 0
Location: Tuesday
Post: #35
Someone should also mention that you need to redo your nfo files to get away from that outdated hacky flagging.

Quote:21:15:43 T:3040642960 M:1345712128 INFO: msg: PICTURE::LoadImage: Unable to open image: special://skin/extras/studios/Silver Screen Partners IV / sddvd / ac-3 / 6ch / subs.png Error: (2)

These items are now handled properly and no longer need the old workaround.

**edit* And before anyone complains that this too much effort you can go right to hell.
I have 1,400 movies and 247 tv series which I've been slowly redoing since last thursday, if I can do it, anyone can. Tongue
(This post was last modified: 2009-12-05 00:55 by hikaricore.)
find quote
Groove996 Offline
Junior Member
Posts: 18
Joined: Sep 2009
Reputation: 0
Location: The Great White North
Post: #36
noox Wrote:That looks to be the case. I rename extras/Studio to extras/studio and no more crashes.

Apparently my crash that i posted on the last page had the same cause

I saw your post, renamed 'Studio' to 'studio' and no more crashy

thx!!!!
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,748
Joined: Aug 2007
Reputation: 98
Location: Eastleigh, UK
Post: #37
You'll also see that XBMC has no trouble finding the studio folder even though the case is different -
Code:
CreateFile, successfuly opened </home/xbmc/.xbmc/skin/Alaska/extras/Studios> instead of </home/xbmc/.xbmc/skin/Alaska/extras/studios/>
find quote
Groove996 Offline
Junior Member
Posts: 18
Joined: Sep 2009
Reputation: 0
Location: The Great White North
Post: #38
Hitcher Wrote:You'll also see that XBMC has no trouble finding the studio folder even though the case is different -
Code:
CreateFile, successfuly opened </home/xbmc/.xbmc/skin/Alaska/extras/Studios> instead of </home/xbmc/.xbmc/skin/Alaska/extras/studios/>

Yeah i noticed that in the log too, still crashes though

regardless of what the cause is, renaming it was easy enough a fix Smile

p.s. about to try the new universal flags - that youtube vid looks great, Hitcher.
find quote
jbor613 Offline
Junior Member
Posts: 35
Joined: Jul 2009
Reputation: 0
Post: #39
Hitcher, quick question, not sure if it's a bug or not -
with the new Set feature for movies, is there anyway to turn off the loop in poster/fanart/square view? When you've got a list of 3 movies, there's really no reason to see 7...
find quote
hikaricore Offline
Posting Freak
Posts: 1,515
Joined: Dec 2008
Reputation: 0
Location: Tuesday
Post: #40
You could just get more movies. ^_^
find quote
jbor613 Offline
Junior Member
Posts: 35
Joined: Jul 2009
Reputation: 0
Post: #41
hikaricore Wrote:You could just get more movies. ^_^

More movies isn't the problem - I have 372 and counting.
But seeing as how each set, for me at least, consists of 3 movies and up, the sections just look overly crowded.
find quote
JDizzy Offline
Fan
Posts: 376
Joined: Apr 2009
Reputation: 1
Location: Californication
Post: #42
dogotcat Wrote:When in home screen mode 1, When you select music in the main menu it takes you to album view when in library mode. Instead of he normal list of artists, albums, genres ect.

I also would like to see it go straight to the Artist Page... I looked for where to make the change but could not find it. I just don't think the normal list of artists, albums, genres, etc, is very attractive with the generic folder pictures.

Is it possible to replace the generic pictures of folders with pictures of your choice on the normal list screen? Kinda like the ability to change the movie genre icons with many different ones?
(This post was last modified: 2009-12-06 18:24 by JDizzy.)
find quote
sinarquia Offline
Member
Posts: 67
Joined: Sep 2008
Reputation: 0
Location: Spain
Post: #43
When I try to access any password-locked section (videos, movies...) there's is no "pop-up" to enter the code.

I'm on XBMC 9.11 Beta1, Linux, can supply log if you need it.

Thanks for a great skin.

Ubuntu 9.10 - XBMC 9.11 Beta
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,748
Joined: Aug 2007
Reputation: 98
Location: Eastleigh, UK
Post: #44
sinarquia Wrote:When I try to access any password-locked section (videos, movies...) there's is no "pop-up" to enter the code.

I'm on XBMC 9.11 Beta1, Linux, can supply log if you need it.

Thanks for a great skin.
How do you password items in XBMC?

EDIT: Found it thanks to Rocky5.
(This post was last modified: 2009-12-07 00:46 by Hitcher.)
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,748
Joined: Aug 2007
Reputation: 98
Location: Eastleigh, UK
Post: #45
JDizzy Wrote:I also would like to see it go straight to the Artist Page... I looked for where to make the change but could not find it. I just don't think the normal list of artists, albums, genres, etc, is very attractive with the generic folder pictures.

Is it possible to replace the generic pictures of folders with pictures of your choice on the normal list screen? Kinda like the ability to change the movie genre icons with many different ones?
I've changed the way Music works now so you can change from Library to Files mode and set anything you want as Default.
find quote
Post Reply