How do you watch 720p/24Hz?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
AmirG Offline
Junior Member
Posts: 41
Joined: Apr 2009
Reputation: 0
Post: #1
Most of the content I have in HD is at 720p/24Hz (Babylon can't handle 1080p on my setup, hopefully Camelot will). However, my Philips LCD don't have a 720p/24Hz mode, only 720p/50Hz and 720p/60Hz, and as a result, every HD video I watch has this annoying tearing (or jitter or whatever it's called).

As far as I can tell, most TVs don't have a 720p/24Hz mode, so how do YOU watch such content? Do you upscale it to 1080p/24Hz? Do you use some pull-down to convert it to 720p/50Hz or 60Hz? Is there some other solution?

And whichever solution you employ, is it done by XBMC, the underlying OS, your AV receiver or perhaps your TV?
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #2
I've currently limited my xorg modelines to 1920x1080/60hz and 1920x1080/24hz since my TV supports those. I'm then letting XBMC do the upscaling (via the nvidia card). This gives me 24hz playback even on DVD rips at 1080p/24.

My TV, like yours, only supports 24hz at the 1080p resolution so I have to let the player do the upscaling.

If you're getting tearing that shouldn't be from a refresh mismatch. That's probably a VSync issue. Refresh mismatch should only give you a 3:2 pulldown (frames repeated 3 times, then 2 times, then 3, etc.). Which gives slightly less smooth playback (however... that's how TV broadcasts shot in film work so you're used to it and probably won't notice it anyway).
find quote
AmirG Offline
Junior Member
Posts: 41
Joined: Apr 2009
Reputation: 0
Post: #3
It only happen when the camera panes or when there's a cut, then I get a horizontal tear.
XBMC debug option reports that it's doing about 24 FPS while xorg log file reports that the TV is in 720p/60Hz. So the framerate doesn't match. Wouldn't that cause tearing or does XBMC (and I'm still using the Babylon stable release) or the TV do a pull down automatically?

I have vsync set as on everywhere, I have twinview disabled, I've added every suggested setting to my xorg.conf, theonly thing left I can think of is that refresh rate missmatch.

Comes Camelot with its supposed performance improvements with VPDAU and I'll be able to test that theory.
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #4
That shouldn't cause tearing and pull down should be automatically applied. Is VSync turned on in XBMC as well? Also is Compiz disabled in X?
find quote
AmirG Offline
Junior Member
Posts: 41
Joined: Apr 2009
Reputation: 0
Post: #5
Vsync is turn on in XBMC as well. When it wasn't, its framerate while on the menus was 60FPS, now it's 30FPS and the CPU usage is much lower. I've tried both "on" and "let driver decide". Compiz? That's the `Option "Composite" "Disable"`, right? If so, it's disabled.

If pull down is applied, would the framerate reported by XBMC still be around 24FPS?

To make a short story much longer, here's my xorg.conf file:
http://pastebin.com/f90faa0e

My current Xorg.0.log file:
http://pastebin.com/fd339227
(The entire XBMC session was in 720p/60Hz, the 1080P/50Hz was before XBMC was started and after is was terminated.)

I'm using Ububtu Jaunty x64 desktop default install updated as of today with Nvidia proprietary driver v. 180.44. Is there anything else I should add to help you help me?
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #6
If you're getting 30fps that should mean the video is 30fps. 3:2 pulldown converts 24fps to 60hz. 12 * 2 + 12 * 3.

You can use mediainfo to see what framerate the video file itself is in.

You can also try upgrading to the 190 nvidia drivers by following this http://www.ubuntugeek.com/install-nvidia...hardy.html

Not sure what else you can try. If you're using VDPAU you might search these forums for some more info... I've seen numerous people having similar problems with VDPAU stuff.

Compiz is in the appearance settings I believe. You shouldn't see compiz running if you do 'ps ax' but you should see metacity.
find quote
AmirG Offline
Junior Member
Posts: 41
Joined: Apr 2009
Reputation: 0
Post: #7
Oh, sorry, I wasn't clear: the Menus are rendered at 30FPS, which fits as the TV is working at 60Hz. When a video is played, it's at about 24FPS while the TV is still at 60Hz, as is evident from the X log file.

The framerate the videos are supposed to be played in is 24, verified with Media Player Classic under Windows.

Thanks for the help, I'll try to update the driver and see how it goes.
find quote
nunu Offline
Member
Posts: 92
Joined: Feb 2009
Reputation: 0
Post: #8
same things for me. The XBMC settings was 1920*1080/60Hz and my TV is 50Hz only.

On slow scrolling it was not smooth and i have set xbmc to 1920*1080/50Hz and it's very better but not perfect.

A friend had the same problem, and solves with starting ubunutu with XBMC session mode. He had desable the twinview etc....
find quote
valexi Offline
Junior Member
Posts: 16
Joined: Dec 2009
Reputation: 0
Post: #9
Hi!

I have those latest NVIDIA drivers, and I am able to set my ubuntu to 1080p/24hz resolution, but it seems that XBMC oversets that resolution. I can't change this refresh rate to 1080p/24hz, from XBMC because it lovers the resolution, when going under 50hz.

Any clues? This is very weird, because my Popcorn hour player is able to do 24p standard, and it is linux based too...
find quote
neil.j1983 Offline
Donor
Posts: 589
Joined: Jun 2009
Reputation: 28
Post: #10
i have a optoma hd65 (seems like a popular budget projector) and it allows custom modelines for 23.976Hz and 48Hz at 1280*720. its very good.
find quote
zigomatic Offline
Junior Member
Posts: 7
Joined: Dec 2009
Reputation: 0
Location: Belgium
Post: #11
I'm was in the same case...

My tv support the 24p but not the PS3 (sony seems to block the switch...)

As i understand xbmc is also a dlna server, so the idea is may be to use the PS3 media server http://ps3mediaserver.org/forum/viewtopi...f=2&t=3217where you put in the config this line to avoid this problem of 24p : framerate == 23.976 :: -speed 1.042709376 -ofps 25
find quote