.MKV Subtitles not displaying on XBMC

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
hogfan Offline
Fan
Posts: 384
Joined: Nov 2009
Reputation: 0
Post: #1
.MKV created with Handbrake, selected the English subtitle track & chose "Forced Only", and set this as the default subtitle track.

Playing this file back in VLC Player & MPlayer OSX Extended on Mac work great. The Forced subs are appropriately displayed during the foreign language scenes. However, on XBMC I get no subtitles displayed. Is there an option I need to enable in XBMC? thanks for any help
find quote
gabbott Offline
Team-Kodi Member
Posts: 1,545
Joined: Jul 2007
Reputation: 27
Post: #2
If you go into audio settings while the file is playing, are subtitles enabled?
find quote
hogfan Offline
Fan
Posts: 384
Joined: Nov 2009
Reputation: 0
Post: #3
Are you referring to "Audio Settings" in "System"? I was not aware there were subtitle settings in the audio section.
find quote
bossanova808 Offline
Donor
Posts: 2,239
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #4
No they mean if you bring up the OSD while the file is playing (the thing with the progress bar and the circular icons for bookmarks, audio and video settings) - and choose audio in there, does it have 'enable subtitles' set?

Although i am not sure how this corresponds to forced subbies - which I am not sure about being supported at this stage...

My XBMC stuff:
find quote
hogfan Offline
Fan
Posts: 384
Joined: Nov 2009
Reputation: 0
Post: #5
Brought up the OSD and subtitles are enabled. Subtitle track says the English subtitle track is being used, which is the default. Subtitles just are not displaying. All checking forced subs does in handbrake is creates a subtitle track with only the subtitles marked as "Forced". Basically the rest of the subtitle stream is just blank. These are working on MPlayer for OSX & VLC. I don't understand if XBMC has the track enabled and subtitles enabled why it is not displaying them. Forced subs are a PITA. I like it when they just come burned into the video....but then again, I only care about watching these movies in English (Region 1).
find quote
hogfan Offline
Fan
Posts: 384
Joined: Nov 2009
Reputation: 0
Post: #6
Has anybody else seen this issue before?
find quote
elzafir Offline
Junior Member
Posts: 14
Joined: Jan 2010
Reputation: 0
Post: #7
yes, i do.
I got an MKV with internal subs.
It doesn't show.

a normal .avi with a same name .srt along side it works superbly!

most of my matroska files are asian movies, without the subs i'm just watching people talking gibberish.
find quote
hogfan Offline
Fan
Posts: 384
Joined: Nov 2009
Reputation: 0
Post: #8
If you don't plan to watch in multiple languages, you can do what I do now and just tell handbrake to burn the subs into the video. 1 less thing that can break, if the forced subs are part of the video stream they have no choice but to display Smile
find quote
paularms Offline
Member
Posts: 76
Joined: Oct 2008
Reputation: 0
Post: #9
MKVs with softsubs work just fine for me.

Running Ubuntu 9.10 with XBMC 9.11.
find quote
officeboy Offline
Member
Posts: 75
Joined: Nov 2009
Reputation: 0
Post: #10
It's not much help, but I encode with handbrake and my subs work fine too.
But I don't use the forced only setting. I wonder if this is working properly in Handbrake? (ie it's not detecting the forced subs so your subtitle stream is empty)
You should demux the mkv and see what the subtitle stream has in it.
(This post was last modified: 2010-01-07 23:19 by officeboy.)
find quote
chridmiller Offline
Junior Member
Posts: 3
Joined: Apr 2010
Reputation: 0
Sad  Me Too
Post: #11
I too have had this problem with forced subtitles. I have checked the files with VLC, Media player and Quicktime and they all work with no problems but XBMC still wont play the subtitles. When checking the subtitle options when the file is playing it does not display any available subtitles.

Running on Windows 7 and XBMC 9.11
(This post was last modified: 2010-04-05 21:49 by chridmiller.)
find quote
voip-ninja Offline
Donor
Posts: 1,112
Joined: Jan 2010
Reputation: 23
Post: #12
I posted a thread on this too, and it looks like it's a "known" issue as a developer asked someone previously to open up a bug report since XBMC seems to ignore the forced/priority field for streams in MKV files.

See this bug;

http://trac.xbmc.org/ticket/8622

Unfortunately it was opened 3 months ago and no status update of any kind.

Would be nice to see this fixed. I just spent hours and hours re-encoding movies trying to figure out why XBMC kept ignoring the forced field on subtitles as well as not properly interpreting the order/priority of the subtitle data and the default track fields.

All of this needs to be fixed as more and more people are moving to use of MKV for their playback needs.
find quote
elupus Online
Team-XBMC Developer
Posts: 3,799
Joined: Mar 2004
Reputation: 3
Post: #13
A sample with forced subs that totaly refuse to display would help.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
voip-ninja Offline
Donor
Posts: 1,112
Joined: Jan 2010
Reputation: 23
Post: #14
elupus Wrote:A sample with forced subs that totaly refuse to display would help.

Shouldn't be a problem. I will turn logging on and collect the output. Should I attach it to the existing bug report or file a new one?

Also, remember that the forced track WILL play if you check the "enable" subtitle field in audio properties. This is not the correct behavior for a forced subtitle though. The forced subtitle should play even if the subtitle field is set to "no" (that's kind of the purpose of "force").

In the current implementation, XBMC will only select the 1st subtitle track (forced or otherwise) and will only display it when the subtitle enable checkbox is selected.

The better (and correct) implementation would be for XBMC to determine which subtitle track to play based on the default field in the subtitle track. In the event a subtitle is marked with the "forced" flag it should display regardless of whether the subs are enabled or not.

There could always be a property or option in XBMC to control this behavior if for some reason there are people out there who do not wish to see the "forced" subs in movies (although why they wouldn't want them is beyond me).
(This post was last modified: 2010-04-14 03:37 by voip-ninja.)
find quote
voip-ninja Offline
Donor
Posts: 1,112
Joined: Jan 2010
Reputation: 23
Post: #15
The plot thickens so to speak. Mediainfo does not provide information on the forced flag, default flag, etc.

This is what mediainfo shows for the track;

Quote:Text
ID/String : 4
Format : VobSub
CodecID : S_VOBSUB
CodecID/Info : The same subtitle format used on DVDs
Title : Forced Subtitles
Language/String : English

And this is what shows up in the log of XBMC;

Quote:19:59:21 T:97768 M:2511187968 INFO: ffmpeg[17DE8]: Metadata:
19:59:21 T:97768 M:2511187968 INFO: ffmpeg[17DE8]: description : Main Title
19:59:21 T:97768 M:2511187968 INFO: ffmpeg[17DE8]: Stream #0.3(eng): Subtitle: dvdsub
19:59:21 T:97768 M:2511187968 INFO: ffmpeg[17DE8]: Metadata:
19:59:21 T:97768 M:2511187968 INFO: ffmpeg[17DE8]: description : Forced Subtitles

20:04:50 T:92500 M:2507956224 INFO: CDVDFactorySubtitle::GetSubtitles, searching subtitles
20:04:50 T:92500 M:2507956224 DEBUG: CUtil::CacheSubtitles: START
20:04:50 T:92500 M:2507952128 DEBUG: CUtil::CacheSubtitles: Checking for common subirs...
20:04:50 T:92500 M:2509176832 DEBUG: CUtil::CacheSubtitles: Done (time: 25 ms)
20:04:50 T:92500 M:2509123584 DEBUG: CUtil::CacheSubtitles: Searching for subtitles...
20:04:50 T:92500 M:2508984320 DEBUG: CUtil::CacheSubtitles: Done (time: 2 ms)
20:04:50 T:92500 M:2508984320 DEBUG: CUtil::CacheSubtitles: END (total time: 28 ms)
20:04:50 T:92500 M:2508984320 INFO: CDVDFactorySubtitle::GetSubtitles, searching subtitles done
20:04:50 T:92500 M:2508984320 NOTICE: Creating Demuxer

20:04:50 T:92500 M:2498908160 NOTICE: Opening Subtitle stream: 3 source: 256
20:04:50 T:92500 M:2498895872 DEBUG: FactoryCodec - Overlay: FFmpeg Subtitle Decoder - Opening
20:04:50 T:99084 M:2498895872 DEBUG: thread start, auto delete: 0
20:04:50 T:99084 M:2498883584 NOTICE: running thread: CDVDPlayerAudio::Process()
20:04:50 T:92500 M:2498883584 DEBUG: FactoryCodec - Overlay: FFmpeg Subtitle Decoder - Opened
20:04:50 T:92500 M:2498883584 DEBUG: CEdl::ReadEditDecisionLists - checking for any edit decision lists (EDL) on local drive or remote share for: smb://GIZMO/Videos/Movies/Iron Man/Iron Man.mkv
20:04:50 T:99060 M:2498842624 NOTICE: running thread: video_thread

Here's the real kicker. In other media players, the forced sub track is displayed, without "enable" subtitles, but in XBMC it is not.

Does anyone know of a way to pull info out that shows if the sub track has the forced flag set?
find quote
Post Reply