"adjust display refresh rate to match video"

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #181
as always, no xbmc.log, no soup Smile


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Hersan Offline
Junior Member
Posts: 35
Joined: Jan 2012
Reputation: 0
Post: #182
@ davilla

http://pastebin.com/cNaG96gy

What I did: start, options, switch auto refresh rate to ON, videos, start movie with 24 fps, let it play for 20 sec, close xbmc.

You will see a few warnings and quite a few errors as well, good luck Smile

As I sad before, xbmc DO switch to 24 hz (my TV shows a change in refresh rate), but the video stutters like crazy and there is no sound at all with this option set to ON.

Thanks
(This post was last modified: 2012-01-28 20:49 by Hersan.)
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #183
Hersan Wrote:@ davilla

http://pastebin.com/cNaG96gy

What I did: start, options, switch auto refresh rate to ON, videos, start movie with 24 fps, let it play for 20 sec, close xbmc.

You will see a few warnings and quite a few errors as well, good luck Smile

As I sad before, xbmc DO switch to 24 hz (my TV shows a change in refresh rate), but the video stutters like crazy and there is no sound at all with this option set to ON.

Thanks

Set the audio device to 'hdmi', not default audio device. enable player pause when switching.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Hersan Offline
Junior Member
Posts: 35
Joined: Jan 2012
Reputation: 0
Post: #184
That did the trick, thanks for the tip. What was wrong in my setup?

Also, whats the meaning of:
"ERROR: Unable to load libcrystalhd.dylib, reason: dlopen(libcrystalhd.dylib, 1): image not found" and
"ERROR: AddPackets - failed to add leftover bytes to render" that I still get?

Anyway, a BIG thanks for resolving it so quickly!
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #185
Hersan Wrote:That did the trick, thanks for the tip. What was wrong in my setup?

nothing, it's a quirk of how it's done right now.

Hersan Wrote:Also, whats the meaning of:
"ERROR: Unable to load libcrystalhd.dylib, reason: dlopen(libcrystalhd.dylib, 1): image not found" and

you don't have a crystal hd hardware decoder card, don't worry about it.

Hersan Wrote:"ERROR: AddPackets - failed to add leftover bytes to render" that I still get?

Anyway, a BIG thanks for resolving it so quickly!

depends, you might get that when the player is sync'ing or stopping.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
superyo Offline
Senior Member
Posts: 120
Joined: Mar 2011
Reputation: 0
Question   
Post: #186
Hi all,

I can not understand.
When I select a film change refresh works very well. But on most films (or iso DVD or .m2ts or. mkv) I have very big delays following the change of refresh.
I paused. I remove the break and everything returns to normal!

I do not have this problem when I disable the automatic refresh.

Strange is not it?
find quote
J├Ânke Offline
Fan
Posts: 592
Joined: Oct 2009
Reputation: 2
Post: #187
Ok so whats the status right now ? Does it work 100% on the latest mac mini with 50/60/23.976 hz automatic adjust display refresh rate to match video ?
find quote
prophetizer Offline
Senior Member
Posts: 283
Joined: Sep 2008
Reputation: 2
Post: #188
it does 50/60/24 with no issues at all for me, if u want 23.976 you need to use SwitchResX but after you set that up, yes it works without issue

--
[Image: watched-clearlogo.jpg]
find quote
Post Reply