Windows - HOW-TO play Blu-ray Disc with External Player and auto adjust refresh rate

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #31
thanks i will do laterBig Grin
find quote
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #32
here is my debug logShocked

http://pastebin.ca/1740769
find quote
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #33
Ok, what i have found is that xbmc sees D drive and lables the blu ray ie D (the dark knight) but when i click play nothing happens. click again it says something like cannot find file. however if i left click i can explore the disk to the stream folder right click and it gives me dvdplayer(default) and tmtmc. click the latter. and it plays with arcsoft.

seems that is the problem but where do i go from hereConfused

thanks for your time
(This post was last modified: 2010-01-08 23:24 by jonnyboom.)
find quote
mindweaver Offline
Posting Freak
Posts: 998
Joined: Jan 2004
Reputation: 1
Location: Sweden
Post: #34
Here is the playercorefactory.xml for external player with PowerDVD 9

Code:
<playercorefactory>
  <players>
    <player name="PDVDCinemaPlayer" type="ExternalPlayer" audio="false" video="true">
      <filename>C:\Program Files\CyberLink\PowerDVD9\PowerDVD Cinema\PowerDVDCinema.exe</filename>
      <hidexbmc>true</hidexbmc>
      <hideconsole>true</hideconsole>
      <warpcursor>none</warpcursor>
    </player>
  </players>
  <rules action="prepend">
    <rule name="Blu-Ray" protocols="bd" player="PDVDCinemaPlayer"/>
  </rules>
</playercorefactory>
find quote
bollerfant Offline
Junior Member
Posts: 7
Joined: Jan 2010
Reputation: 0
Post: #35
@mindweaver:
Hi,
when i pasted your Code into my playercorefactory.xml and now it lookes like that:
Code:
<playercorefactory>

  <players>
    <player name="PDVDCinemaPlayer" type="ExternalPlayer" audio="false" video="true">
      <filename>C:\Program Files\CyberLink\PowerDVD9\PowerDVD Cinema\PowerDVDCinema.exe</filename>
      <hidexbmc>true</hidexbmc>
      <hideconsole>true</hideconsole>
      <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="Blu-Ray" protocols="bd" player="PDVDCinemaPlayer"/>
    <rule filetypes="mkv|ts|mts|m2ts" player="DSPlayer"/>
  </rules>

</playercorefactory>

That part <rule filetypes="mkv|ts|mts|m2ts" player="DSPlayer"/> is working, but i cannot play a BD from inside my XBMC. I can open the BD and i can browse in the folders, but i cannot start it with PDVD. The path for the exe file is correct (i checked it with windows-run) and when i start is manually then the BD works fine.
Maybe the XML is wrong?
find quote
mindweaver Offline
Posting Freak
Posts: 998
Joined: Jan 2004
Reputation: 1
Location: Sweden
Post: #36
bollerfant Wrote:@mindweaver:
Hi,
when i pasted your Code into my playercorefactory.xml and now it lookes like that:
Code:
<playercorefactory>

  <players>
    <player name="PDVDCinemaPlayer" type="ExternalPlayer" audio="false" video="true">
      <filename>C:\Program Files\CyberLink\PowerDVD9\PowerDVD Cinema\PowerDVDCinema.exe</filename>
      <hidexbmc>true</hidexbmc>
      <hideconsole>true</hideconsole>
      <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="Blu-Ray" protocols="bd" player="PDVDCinemaPlayer"/>
    <rule filetypes="mkv|ts|mts|m2ts" player="DSPlayer"/>
  </rules>

</playercorefactory>

That part <rule filetypes="mkv|ts|mts|m2ts" player="DSPlayer"/> is working, but i cannot play a BD from inside my XBMC. I can open the BD and i can browse in the folders, but i cannot start it with PDVD. The path for the exe file is correct (i checked it with windows-run) and when i start is manually then the BD works fine.
Maybe the XML is wrong?

How are you trying to access it? You shouldn't browse it. There are two ways to play it

1. in videos - file mode you press PLAY when you have highlighted/marked/standing on top of the blu-ray drive in the list.

2. in main menu if you are using Aeon (maybe available in other skins too) press on "PLAY DISC".
find quote
bollerfant Offline
Junior Member
Posts: 7
Joined: Jan 2010
Reputation: 0
Post: #37
mindweaver Wrote:How are you trying to access it? You shouldn't browse it. There are two ways to play it

1. in videos - file mode you press PLAY when you have highlighted/marked/standing on top of the blu-ray drive in the list.

2. in main menu if you are using Aeon (maybe available in other skins too) press on "PLAY DISC".

I tried both. Nothing happens when i press "PLAY".
find quote
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #38
@BOLLERFANT

SAME WITH MINESad
find quote
ethanmcdonald Offline
Member
Posts: 53
Joined: Aug 2008
Reputation: 0
Post: #39
I noticed there is a "protocals" attibute in the RULE tag.
How is this attibute determined?
Is there a list of all the protocals?
Can specifi your own?

Code:
<rules action="prepend">
    <rule name="Blu-Ray" protocols="bd" player="PDVDCinemaPlayer"/>
  </rules>


XBMC 11: EDEN | XBMC | HDDVD+Blu-Ray ISO playback & Blu-ray player
PC - HTPC CASE: APEX DM-318 Black Steel MB: ASUS M3N78-EM/NVIDA8300 | CPU: AMD Athlon 64 X2 5000+ RAM: 2gb DDR2 1066
HD: 70gb(System) DVDROM: LG GGW-H20L Blu-Ray/HDDVD OS: Win7 | NAS: 3-terabytes(RAID 5)
(This post was last modified: 2010-01-12 15:38 by ethanmcdonald.)
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #40
what's a protocal? Wink

no you cannot. that is determined by the code and is the means by which the bd's are identified.
find quote
catdroid Offline
Junior Member
Posts: 6
Joined: Jan 2010
Reputation: 0
Post: #41
The only thing I changed in the xml file was from D: to E:

Everything else should be correct on my system. (I verified the path to TMT3)

When I put in The Hangover Blu-Ray disc, XBMC sees it, then if I "play disc", the counter in the bottom left starts and the disc starts reading.

TMT3 does not open and XBMC does not close.

I installed XBMC in portable mode and placed the xml file in the c:\program files\XBMC\userdata folder.

Any clues? Anything jump out that says I'm doing this wrong?
find quote
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #42
Changed from latest xbmc release to the one at the start of the tutorial 25821.
now it works
find quote
catdroid Offline
Junior Member
Posts: 6
Joined: Jan 2010
Reputation: 0
Post: #43
jonnyboom Wrote:Changed from latest xbmc release to the one at the start of the tutorial 25821.
now it works

Good tip. I switched to the latest build (26787) and it worked.

But I noticed the movie didn't automatically play in TMT3. Anybody know the argument for this?
find quote
mindweaver Offline
Posting Freak
Posts: 998
Joined: Jan 2004
Reputation: 1
Location: Sweden
Post: #44
catdroid Wrote:Good tip. I switched to the latest build (26787) and it worked.

But I noticed the movie didn't automatically play in TMT3. Anybody know the argument for this?

I have also noticed that it does not play automaticly when launched from XBMC. if you launch it stand alone it auto plays. I have tried to search for it but can't find anything.

I can live with pressing play on the remote, but please tell us if you find a solution.
find quote
jonnyboom Offline
Junior Member
Posts: 14
Joined: Sep 2009
Reputation: 0
Post: #45
strange how yours works with 62787 and mine wont, i tried both versions and mine will only work with 25821
find quote
Post Reply