[MAC] Broadcom Crystal HD Mini-PCIe Card in a Intel (GMA) Mac Mini?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
BARXO Offline
Junior Member
Posts: 3
Joined: Jan 2010
Reputation: 0
Location: Italy
Post: #31
Kyle Reese Wrote:I too can confirm that the broadcom card works in a mac mini (1.83 ghz core2duo). The video plays perfectly,

Hi, my first post...
First of all, many many compliments to all xbmc devs, amazing work!!!
And special thanks to davilla, for his work for crystalhd...

Installed broadcom card in my 1,83 CD2 mac mini today, with drivers too...
I confirm that all of my BD rips or 1080p mkv works perfectly, but only within first minutes of playback....
After a few, A/V sync appears to lost...
To resync i need to step back a bit with R (rewind) or with left arrows...
The same problem appear immediately if i press I to show playback time info...

Another problem is that my mini doesn't sleep anymore....
Could it be broadcom card?

Hoping to help a bit, thanks for your work...
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #32
Something going wrong under OSX/AppleTVOS right now, not sure what. It's being looked into.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
gianpy69 Offline
Junior Member
Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #33
BARXO Wrote:Another problem is that my mini doesn't sleep anymore....
Could it be broadcom card?

What's mean doesn't sleep anymore. It doesn't go to sleep at all or it goes to sleep and then wake up after few times unexplectedly?

My mac mini goes to sleep normally. I have a problem with wake up because my ups send a signal periodically on usb port and mac mini wake up but this is another issue.

Bye
find quote
gianpy69 Offline
Junior Member
Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #34
davilla Wrote:Something going wrong under OSX/AppleTVOS right now, not sure what. It's being looked into.
So is the Linux/Windows versions work right without stuttering problem?
find quote
BARXO Offline
Junior Member
Posts: 3
Joined: Jan 2010
Reputation: 0
Location: Italy
Post: #35
gianpy69 Wrote:What's mean doesn't sleep anymore. It doesn't go to sleep at all or it goes to sleep and then wake up after few times unexplectedly?

Hi...
It doesn't go to sleep at all...When i try to sleep it with the remote or with the finder, video goes to sleep normally, but mini don't...
hard disk, cd , continue to go....
At the moment for me this is the biggest problem with this card...
How can i solve this problem?

Last night i've tested all of my videos...
In XBMC settings, i've selected

[Image: xbmcsettings.jpg]

(Render method in the picture is on software beacuse i'm posting with another mac Smile In my mini is on crystalhd)
After that new set up, i have perfect video playback without desync...
I don't tested it for the entire movie, but more of 30 minutes of playback goes perfectly...
Tonight i'll try for an entire movie...

Another info:
Pressing I during playback cause stuttering and A/V desync every time...
Could it be that crystalhd rendered images (the movie) crashes with other images (like menus) rendered directly in software mode?
find quote
DaSal Offline
Junior Member
Posts: 30
Joined: Sep 2008
Reputation: 0
Post: #36
BARXO Wrote:Hi...
It doesn't go to sleep at all...When i try to sleep it with the remote or with the finder, video goes to sleep normally, but mini don't...
hard disk, cd , continue to go....
At the moment for me this is the biggest problem with this card...
How can i solve this problem?

For the record, I have this problem too. I thought maybe I messed something up while installing the card. How would one check if it's actually the card causing it or just us having messed something up?
find quote
gianpy69 Offline
Junior Member
Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #37
DaSal Wrote:For the record, I have this problem too. I thought maybe I messed something up while installing the card. How would one check if it's actually the card causing it or just us having messed something up?

Today i will do some test. Have you snow leopard or leopard?
I ask you that because in snow leopard there is an option that can wake up through wlan and may be it could interfere but it's only a thought.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #38
BARXO Wrote:Hi...
It doesn't go to sleep at all...When i try to sleep it with the remote or with the finder, video goes to sleep normally, but mini don't...
hard disk, cd , continue to go....
At the moment for me this is the biggest problem with this card...
How can i solve this problem?

You can solve this problem by adding power/sleep handling to the OSX kext source code. I intend to add this later but you can help by starting on the patches now and I will merge them into crystalhd-for-osx svn tree. Right now, the kext marks the hardware as incapable of sleeping and this will prevent OSX from sleeping.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
gianpy69 Offline
Junior Member
Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #39
BARXO Wrote:Hi, my first post...
Another problem is that my mini doesn't sleep anymore....
Could it be broadcom card?
Ok. My mac mini doesn't go sleep anymore too. I was wrong because my TV switch off. Now i have notice that mac mini's fan and led are always on.
However i think that most important is that Davilla concentrate his efforts to resolve sporadic playback problem.
find quote
BARXO Offline
Junior Member
Posts: 3
Joined: Jan 2010
Reputation: 0
Location: Italy
Post: #40
davilla Wrote:You can solve this problem by adding power/sleep handling to the OSX kext source code.Right now, the kext marks the hardware as incapable of sleeping and this will prevent OSX from sleeping.

Ok, now i know...thanks.

davilla Wrote:you can help by starting on the patches now and I will merge them into crystalhd-for-osx svn tree.

Sorry (for my english too) but i don't understood very well.
What do you mean with "starting on the patches"?
I must post some logs?
I must select some things within XBMC?

gianpy69 Wrote:However i think that most important is that Davilla concentrate his efforts to resolve sporadic playback problem.

I agree...
About that, yesterday night i've seen an entire 2 hr movie without stuttering...But i confirm that other images (like menus or info) causes desync and stuttering...
find quote
Tijntje Offline
Junior Member
Posts: 49
Joined: Jan 2010
Reputation: 0
Question  [MAC] Broadcom Crystal HD video playback performance issue on a Intel (GMA) Mac Mini?
Post: #41
Hello,

i'm testing version r26973 in combination with a mac mini 1.83 C2D and a crystal HD card. Everything is playing very well, I only see some frame drops every 5 to 10 minutes which is quite annoying.

Does anybody know the reason for these drops? The movies are played from USB harddisks connected to the mac mini. There are frame drops with 720p and 1080p movies.


Thx
find quote
Flyinace2000 Offline
Junior Member
Posts: 4
Joined: Jan 2010
Reputation: 0
Post: #42
I think it is a problem with the nightly build. Mine does the same thing every 7 to 10 minutes. I am hoping a new nightly build fixes it.

I am using it on a screenless black MacBook. When it work it works VERY well. 1080p rips use less than 50% CPU compared to 200% w/o the card.
(This post was last modified: 2010-01-19 20:50 by Flyinace2000.)
find quote
anothergene Offline
Junior Member
Posts: 30
Joined: Jul 2009
Reputation: 0
Post: #43
ijhammo Wrote:Only the Mini's pre 2009 (without the NVidia graphics) can take the card.

I realize I have to remove the WiFi card, which isn't a problem for me as I have Gbit Ethernet run out to my Mini. But is this above true that my 2GHz Mini with the Nvidia graphics will not support the Crystal HD Card?
find quote
DaSal Offline
Junior Member
Posts: 30
Joined: Sep 2008
Reputation: 0
Post: #44
So, the Crystal HD support seems to be improving, however there's still some problems. There's a particular 1080p file that has a lot of problems for me, it keeps juddering, and the A/V sync goes crazy. I thought I'd post a sample, to see if other people have the same problem, and I thought it might help with debugging. Smile

Here's the sample: download.
find quote
elconcho Offline
Junior Member
Posts: 25
Joined: Sep 2006
Reputation: 0
Post: #45
evldhs Wrote:Excellent, I installed my Crystal HD today and got this problem as well on a Mini 1.83 GHz. Keeping my fingers and toes crossed that it is a software issue and not a problem with the hardware.


I wrote down what I downloaded and how to install everything in a small web page in case someone is interested: http://ae.dhs.nu/crystalhd/

Thanks for the easy setup guide. I'm up and running. Very easy to follow.

I should add that I'm getting jittering and blocking on all 1080p content using the CrystalHD card for some reason with build r26973. Bit of a let down after staring at my mailbox for 3 weeks waiting for the card to arrive. However, I understand that this is bleeding edge and a work in progress. I'll keep my fingers crossed.
(This post was last modified: 2010-01-20 04:37 by elconcho.)
find quote
Post Reply