[AppleTV] Compiling crystalhd-for-osx Lib/Kext

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #16
gangsta75 Wrote:i don't know if what i did is right..
i compiled everything on my macbookpro and copied all the stuff on appletv.
kext is loaded:
kextload: extension BroadcomCrystalHD.kext appears to be valid
kextload: loading extension BroadcomCrystalHD.kext
kextload: BroadcomCrystalHD.kext loaded successfully
kextload: loading personalities named:
kextload: FirstPersonality
kextload: sending 1 personality to the kernel
kextload: matching started for BroadcomCrystalHD.kext

i'm running the latest build of xbmc and the card is installed properly (i've already tested ubuntu live and it's working good)

this is it?
I've tried 720p but it's not working.
Am i missing something?

thanks
G75

Not nearly enough info to begin debugging why Smile


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
gangsta75 Offline
Donor
Posts: 59
Joined: Aug 2005
Reputation: 0
Location: Italy
Post: #17
davilla Wrote:Not nearly enough info to begin debugging why Smile

You are right Davilla but i tought i was not in the right direction so i have not added other infos on my post Tongue
I'm running build R26208 (one of the latest) and i don't see any references about Broadcom on xbmc log.

Seeing A Milton post, i suppose build i'm running is not patched. (tought was patched since #26172)
(This post was last modified: 2010-01-06 01:06 by gangsta75.)
find quote
Clumsy Offline
Team-XBMC Forum Moderator
Posts: 641
Joined: Feb 2004
Reputation: 0
Post: #18
Bet you forgot to compile xbmc with the --enable-crystalhd flag, after having installed the lib/headers.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
A Milton Offline
Donor
Posts: 101
Joined: Jun 2007
Reputation: 0
Location: Sweden
Post: #19
I found a compiled r26336 here. That _should_ work, right?

Edit: I'm not sure that build has crystalhd enabled. I'll keep on compiling...
(This post was last modified: 2010-01-06 01:20 by A Milton.)
find quote
A Milton Offline
Donor
Posts: 101
Joined: Jun 2007
Reputation: 0
Location: Sweden
Post: #20
Quote:** BUILD FAILED **


The following build commands failed:
XBMC:
CompileC build/XBMC.build/Release/XBMC.build/Objects-normal/i386/CrystalHD.o /Users/staed/dev/trunk/xbmc/cores/dvdplayer/DVDCodecs/Video/CrystalHD.cpp normal i386 c++ com.apple.compilers.gcc.4_0
(1 failure)

Sad

I guess I'll try again tomorrow if someone doesn't have something precompiled by then. It's 1 AM here, so I guess it's time for bed.

Quote:$ time { ./bootstrap && ./configure --disable-debug --enable-crystalhd && make clean && make xcode_depends && xcodebuild -sdk macosx10.4 -project XBMC.xcodeproj -target XBMC.app -configuration Release build; }

[...]

real 45m7.372s
user 36m58.379s
sys 7m22.544s

XBMC is a freaking beast! Big Grin
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #21
Humm, you too. Something must be busted in svn, checking.

EDIT: command-line xcodebuild is broke for some reason, open the project and build it in xcode.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
(This post was last modified: 2010-01-06 02:42 by davilla.)
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #22
post the output of

ls -l /usr/include/libcrystalhd


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
A Milton Offline
Donor
Posts: 101
Joined: Jun 2007
Reputation: 0
Location: Sweden
Post: #23
Code:
-rw-r--r--  1 root  wheel  15915  5 Jan 23:06 bc_dts_defs.h
-rw-r--r--  1 root  wheel   2442  5 Jan 23:06 bc_dts_types.h
-rw-r--r--  1 root  wheel  32785  5 Jan 23:06 libcrystalhd_if.h
find quote
DV3B Offline
Member
Posts: 72
Joined: Dec 2009
Reputation: 0
Post: #24
I'm having trouble with the XBMC compile also.

Installed the crystalhd libs as per instructions on site, no errors.

I just downloaded XBMC svn_revision 26422M and and ran;

Code:
make clean     
./bootstrap     
./configure --enable-crystalhd    
make clean
make xcode_depends


Opened up xcode ran build and got 255 errors ,1 warning. (I know I should post a log but where do I find it?)

/usr/include/libcrystalhd reads the same as A_Milton

Code:
total 112
-rw-r--r--  1 root  wheel  15915  6 Jan 10:29 bc_dts_defs.h
-rw-r--r--  1 root  wheel   2442  6 Jan 10:29 bc_dts_types.h
-rw-r--r--  1 root  wheel  32785  6 Jan 10:29 libcrystalhd_if.h

Also I just recompiled XBMC without the --enable-crystalhd flag and build was successful.

If I can provide any more info I'm happy to help.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #25
svn up and try again. made so tweeks. seems to build from me, not sure what is wrong.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #26
Grrrr, not sure what is going on here. The other post clearly points to a problem finding the crystalhd headers as the include fails. Yet the headers are present.

someone do "echo $PATH" on the command-line and post the results.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
DV3B Offline
Member
Posts: 72
Joined: Dec 2009
Reputation: 0
Post: #27
Is this what your after?

Code:
echo $PATH
/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/X11/bin
find quote
WeakATV Offline
Junior Member
Posts: 33
Joined: Jan 2010
Reputation: 0
Post: #28
There must be an obvious answer to this because I have not seen it yet, so my apologies in advance....

If everyone is using the same platform (Apple TV), why is _everyone_ compiling it? Couldn't one compile it, and host the kext somewhere? Blush
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #29
fixed in crystalhd-for-osx svn r15.

Xcode sandboxes "/usr/includes" and uses "/Developer/SDKs/MacOSX10.4u.sdk/usr/include" instead.

So svn up (from crystalhd-for-osx svn) re-install the crystalhd library and all should be good.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
pin87a Offline
Senior Member
Posts: 179
Joined: Mar 2004
Reputation: 5
Post: #30
Yay! It works!
After a serious crash course in building XBMC for the Mac I was able to get everything up and running on my ATV.

XBMC.log

So far so good. Big thanks to Davilla and everyone else involved in making this happen.
find quote
Post Reply