XBMC and Mac Firewall Popup

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
Scoobydoofus Offline
Junior Member
Posts: 2
Joined: Jan 2010
Reputation: 0
Sad  XBMC and Mac Firewall Popup
Post: #1
Hi, I've been using XBMC under Leopard on a Mini for a while, switched to Plex last year but decided to give Camelot a go and I love it.

Only problem is every time I start XBMC now, I get a pop up that says:

Do you want the application "XBMC.app" to accept incoming network connections?

With buttons for Allow / Deny underneath.

It doesn't matter what I click, the next time I start XBMC I get the pop up again.

My firewall is set to "Set access for specific services". I've gone into the firewall settings, removed the entry and added it manually, repaired permissions, nothing works.

The only way I can get it to stop coming up is to choose either "Allow all incoming connections" or "Allow only essential services", neither of which are ideal.

Any ideas?
find
Smenus Offline
Member
Posts: 72
Joined: Nov 2009
Reputation: 0
Location: Bath, UK
Post: #2
Looks like this is a code signing issue, I think it's been mentioned before on the forums.

From looking at this ticket, it doesn't look like it's going to be sorted.
find
Scoobydoofus Offline
Junior Member
Posts: 2
Joined: Jan 2010
Reputation: 0
Post: #3
Not going to pursue this, Digital signed code and FLOSS just does not mix and the benefits are not worth the effort. Users can easily add XBMC to the 10.5/10.6 firewall exceptions should they need it.

I do have it added to the firewall exceptions and I'm still having the problem. If not everybody is getting the issue, it looks like it's something on my computer...

Hmm. Sucks.
find
egoldy Offline
Junior Member
Posts: 6
Joined: Apr 2007
Reputation: 0
Post: #4
Did anyone fix this problem?

I am having the same problem.

I also have had similar problems with a few other programs.

I was told for people that are having the problem with iTunes that you can disable Bonjour to fix this.

Curious if anyone had any luck fixing this.
find
sirrond Offline
Junior Member
Posts: 1
Joined: May 2011
Reputation: 0
Post: #5
I just started using XBMC and I have this same issue. Everytime I start XBMC, I get the popup "Do you want the application "XBMC.app" to accept incoming network connections?"

I also have XBMC added to my firewall settings "Allow incoming connections"

Has anyone found a solution?

Thanks
find
Chris! Offline
Donor
Posts: 1,012
Joined: Apr 2010
Reputation: 16
Location: England
Post: #6
I think it may be an apple bug as when I have it on, it doesn't remember any applications - not even apple apps like itunes.

I got frustrated and turned it off.


Flirc now has a forum: forum.flirc.tv
find
Novamac Offline
Junior Member
Posts: 13
Joined: Nov 2011
Reputation: 0
Post: #7
Same issue here!

__________________

iMac , OS X 10.7.5, Time Capsule 2TB
AppleTV1, iPhone 4S, iPad mini
XBMC Remote App
XBMC ATV
XBMC OSX
find
codisgod Offline
Junior Member
Posts: 8
Joined: Jan 2012
Reputation: 0
Post: #8
egoldy Wrote:Did anyone fix this problem?.

Ran into this problem after installing a couple of add-ons. The problem is that the signature of the file was somehow corrupted. Rather than reinstall you can create a self-signed certificate and resign the xbmc.app:

1. Verify the signature of xbmc.app:

[INDENT]From TERMINAL type the following:
[/INDENT]
[INDENT]'codesign -vvv /Path/To/xbmc.app'
[/INDENT]
[INDENT]if the result includes the message 'a sealed resource is missing or invalid' then move on to step 2.
[/INDENT]
2. Create a Self Signed Certificate

[INDENT] - Open Applications > Utilities > Keychain Access.
[/INDENT]
[INDENT]- From the Keychain Access menu, choose Certificate Assistant > Create a Certificate.[/INDENT]
[INDENT]- Fill in a name for the certificate. This name appears in the Keychain Access utility as the name of the certificate. This is also the name you will use when referencing this certificate.
[/INDENT]
[INDENT]- Choose Self Signed Root from the Type popup menu.[/INDENT]
[INDENT]- Check the Let me override defaults checkbox.
[/INDENT]
[INDENT]- Choose Code Signing from the Certificate Type menu.
Click Continue.[/INDENT]
[INDENT]Specify a serial number for the certificate. Any number will do as long as you have no other certificate with the same name and serial number.[/INDENT]
[INDENT]- Fill in the information for the certificate.
[/INDENT]
[INDENT]- Accept the defaults for the rest of the dialogs.[/INDENT]

3. Re-sign xbmc.app:

[INDENT]From TERMINAL type the following:[/INDENT]

[INDENT]'codesign -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app'
[/INDENT]

4. Verify the signature of xbmc.app:

[INDENT]From TERMINAL type the following:
[/INDENT]
[INDENT]'codesign -vvv /Path/To/xbmc.app'
[/INDENT]
[INDENT]if the result includes the message 'satisfies its Designated Requirement' you are good - move on to step 5.[/INDENT]

5. Delete and re-add xbmc.app to firewall exceptions (System Preferences)

[INDENT]You should no longer be prompted to allow incoming connections!Big Grin[/INDENT]

By the way, this same procedure will work for all your other apps including iTunes etc. Clearly not an XBMX issue.
If it works for you please add to my rep!!
(This post was last modified: 2012-01-09 22:31 by codisgod.)
find
sparcxl Offline
Junior Member
Posts: 6
Joined: Dec 2010
Reputation: 0
Location: Dallas, TX
Post: #9
To add since XBMC is already signed you may need to add a -f to replace the existing code signature in step 3

Code:
codesign -f -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app

Thanks for the post codisgod, saved me a lot of time.
find
codisgod Offline
Junior Member
Posts: 8
Joined: Jan 2012
Reputation: 0
Post: #10
sparcxl Wrote:Thanks for the post codisgod, saved me a lot of time.

Glad it helped!! I've spent hours sorting out these minor issues and hoped it would be useful to someone else.
find
bbos Offline
Junior Member
Posts: 5
Joined: Feb 2011
Reputation: 0
Post: #11
I have recently turned off the MacOSX 10.7 Application Filtering firewall (The simple one found under System Preferences > Security) and have activated Packet Filtering (PF) firewall. I did so as I needed more control over the firewall so I could, for example, work directly with ports.

Anyways turning off the Application Filtering Firewall seems to have stopped the 'Accept Incoming Network Connections' issue with XBMC.

BTW configuring PF by hand / through config files is not something I wanted to do. I found http://www.openbsd.org/faq/pf/example1.html which would have helped but instead I found IceFloor app for MacOSX 10.7 that is a gui front end and simplified the task significantly.

Cheers,

Brooke Nod
find
wlgspotter Offline
Junior Member
Posts: 4
Joined: Mar 2012
Reputation: 0
Post: #12
(2012-01-20 07:48)sparcxl Wrote:  To add since XBMC is already signed you may need to add a -f to replace the existing code signature in step 3

Code:
codesign -f -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app

Thanks for the post codisgod, saved me a lot of time.

Hi:

I too am encountering the same issue. However, when I tried your solution, I rceived an error as follow:

object file format unrecognized, invalid, or unsuitable

Is there something that I have to have installed prior to performing your steps?

Thanks.
(This post was last modified: 2012-10-06 01:01 by wlgspotter.)
find
Hees Offline
Junior Member
Posts: 3
Joined: Nov 2012
Reputation: 0
Post: #13
This thread helped me an awful lot but only by reading that you have to install (I did) XCode form the App Store and within XCode turn on the Command Line Tools. You will find them in the Preferences of XCode.

After that this line:

Code:
codesign -f -s "MySelfMadeCertificate" -f /Volumes/HardDisk/Applications/XBMC.app

went smooth and came back with the (after checking with this line):

Code:
codesign -vvv /Volumes/HardDisk/Applications/xbmc.app

that "it satisfied its Designated Requirement". I then removed and re-added XBMC to the firewall. Problem solved.

Thanks to all in the thread that putted me on the right track.
(This post was last modified: 2012-11-11 01:25 by Hees.)
find
Clumsy Offline
Team-XBMC Forum Moderator
Posts: 641
Joined: Feb 2004
Reputation: 0
Post: #14
wlgspotter: had the same problem under mointain lion. What worked:
Before the codesign -fs ... step, enter the following commands.

Code:
bash
export CODESIGN_ALLOCATE="/Applications/Xcode.app/Contents/Developer/usr/bin/codesign_allocate"

Then do the codesign step. Don't ask me why exactly this works, got this from a post on stackoverflow.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
ihjones Offline
Junior Member
Posts: 19
Joined: Jun 2009
Reputation: 0
Post: #15
Opps
(This post was last modified: 2013-01-14 03:47 by ihjones.)
find
Thread Closed