[RELEASE] MediaStream v1.60 (2010-01-26)

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #16
Waffa Wrote:Pictures custom backgrounds is not working for home screen.
Check SVN now as I've added a line that was missing from the code.

Waffa Wrote:Edit : Yeah it is id 25 sort by rating works fine now, thanks.
Nice one, thanks Big Grin
find quote
Waffa Offline
Posting Freak
Posts: 1,163
Joined: May 2008
Reputation: 7
Location: Netherlands
Post: #17
And custom backgrounds pictures is fixed to, thanks
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #18
Excellent, thanks for finding those issues! Wink
find quote
benobi Offline
Junior Member
Posts: 21
Joined: Aug 2009
Reputation: 0
Post: #19
skunkm0nkee Wrote:Nice one! I never knew about the preloaditems tag at all so have gone through all the views that have images in the container (such as Wall Stream and Panel Stream) and have now updated the code to do background loading and pre-loading of images so hopefully that will run a bit smoother for you.

I don't have a usable version of XBMC here at the moment so I haven't tested any of these code changes but I'll be testing them over the next few days to make sure they work before making another release.

Thanks again for the feedback and if anyone has any other issues/suggestions please let me know and I'll see what I can do.

Thanks a lot, I'll download the SVN and I'll let you know if it is smoother.
(This post was last modified: 2010-01-29 03:36 by Jezz_X.)
find quote
empty Offline
Senior Member
Posts: 147
Joined: Jan 2007
Reputation: 0
Location: Germany
Post: #20
An old ugly bug Smile when you go back in a tv-series:

http://img193.imageshack.us/i/xbmc0003.jpg/
http://img189.imageshack.us/i/xbmc0004.jpg/
http://img18.imageshack.us/i/xbmc0005.jpg/
http://img43.imageshack.us/i/xbmc0006.jpg/
http://img96.imageshack.us/i/xbmc0007.jpg/
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #21
empty Wrote:An old ugly bug Smile when you go back in a tv-series:

http://img193.imageshack.us/i/xbmc0003.jpg/
http://img189.imageshack.us/i/xbmc0004.jpg/
http://img18.imageshack.us/i/xbmc0005.jpg/
http://img43.imageshack.us/i/xbmc0006.jpg/
http://img96.imageshack.us/i/xbmc0007.jpg/

What version of XBMC and what platform are you running it on?

I use those views for TV and can't remember every seeing anything like that bug. Has anyone else seen something similar?
find quote
rob87 Offline
Junior Member
Posts: 44
Joined: May 2009
Reputation: 0
Post: #22
looks very nice.

unfortunately the switch between the movies in media preview works not flawless like in the confluence skin.
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #23
rob87 Wrote:looks very nice.

unfortunately the switch between the movies in media preview works not flawless like in the confluence skin.

Not sure what you mean? Do you mean the smoothness when navigating a specific view for movies? If so then the code changes mentioned above should help when I release the next version.
find quote
empty Offline
Senior Member
Posts: 147
Joined: Jan 2007
Reputation: 0
Location: Germany
Post: #24
skunkm0nkee Wrote:What version of XBMC and what platform are you running it on?

I use those views for TV and can't remember every seeing anything like that bug. Has anyone else seen something similar?

In every version do you see this bug, i'm using linux,windows newest svn und this bug you can see when you select a serie und then switching back you see this for a very short (for me long) time. I could make a video if you want to
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #25
empty Wrote:In every version do you see this bug, i'm using linux,windows newest svn und this bug you can see when you select a serie und then switching back you see this for a very short (for me long) time. I could make a video if you want to
No need for a video, I'm just concerned that I haven't seen it. Will have to check it out properly tonight. Thanks for the feedback.
find quote
empty Offline
Senior Member
Posts: 147
Joined: Jan 2007
Reputation: 0
Location: Germany
Post: #26
great, I saw this in the first release but was to lazy to post Tongue hope you can fix this! Smile btw. are there any previews of your new skin? maybe some concept/mockup pictures? Smile
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #27
Nope, far too early for public viewing at this time I'm afraid as I'm still trying to finalise the character and feel for the new skin. Once I'm happy with it and am sure it's heading in the right direction then I may post some screenshots but it'll stay mostly under wraps until it's ready.
find quote
rob87 Offline
Junior Member
Posts: 44
Joined: May 2009
Reputation: 0
Post: #28
Quote:Not sure what you mean? Do you mean the smoothness when navigating a specific view for movies? If so then the code changes mentioned above should help when I release the next version.

thats exactly what i mean
find quote
MockY Offline
Junior Member
Posts: 43
Joined: Jan 2009
Reputation: 0
Post: #29
So in versions later than MediaStream v1.60, it will become smoother to navigate through lists (whether it being movies, episodes, or shows)? There were a couple of post previously that mentioned jerkiness with the version they tried, but I'm not really sure if they mean the same as what I found. If it is, then you have my sincere apologies that I repeated it again.

What I instantly noticed was that scrolling through any type of list is very choppy, especially when I hit page down. The letter that used to smoothly appear, showing what letter you are currently on when you held down page down, does no longer appear and the picture is just skipping instead of smoothly scrolling.
I changed back to MediaStream 1.0 and it's smooth again. I am running Jauty Jakalope with XBMC 9.04 so that might have to with it? Or did the power requirements change (my current box is not a speed demon)?
find quote
skunkm0nkee Offline
Team Razorfish
Posts: 1,886
Joined: Aug 2007
Location: London
Post: #30
MockY Wrote:So in versions later than MediaStream v1.60, it will become smoother to navigate through lists (whether it being movies, episodes, or shows)? There were a couple of post previously that mentioned jerkiness with the version they tried, but I'm not really sure if they mean the same as what I found. If it is, then you have my sincere apologies that I repeated it again.

What I instantly noticed was that scrolling through any type of list is very choppy, especially when I hit page down. The letter that used to smoothly appear, showing what letter you are currently on when you held down page down, does no longer appear and the picture is just skipping instead of smoothly scrolling.
I changed back to MediaStream 1.0 and it's smooth again. I am running Jauty Jakalope with XBMC 9.04 so that might have to with it? Or did the power requirements change (my current box is not a speed demon)?

Sounds like your XBMC is well out of date, try updating it to at least 9.10 (Camelot) and see if that works any better for you.

I'll be releasing a newer version in the next day or two which should (hopefully) smooth things out a bit more.
find quote