IMDB scraper stopped updating the "Year" field

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Spider_mp3 Online
Member
Posts: 51
Joined: Aug 2009
Reputation: 0
Post: #1
Since last week, the IMDB scraper stopped updating the "Year" field when scanning for new content. All other movie info is being fetched correctly, just the "Year" fields are left empty. I have tried it out on two different computers, one running Windows XP SP3, the oher running Windows 7 Ultimate x64, with the same result. Both machines are running XBMC 9.11 R26017.

I'm wondering if IMDB changed their site, and the scraper is not working anymore?
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #2
imdb changed their site, and the scraper has been updated some 2 months ago to reflect this fact. obviously not updated in the 9.11 release.
find quote
jpf55 Offline
Fan
Posts: 393
Joined: Dec 2008
Reputation: 3
Post: #3
Quote:imdb changed their site, and the scraper has been updated some 2 months ago to reflect this fact. obviously not updated in the 9.11 release.

It seems to me that the problem started only a couple of weeks ago.

But if you are correct, the answer would be to install a more recent svn, if so which version is the most stable since 9.11 ?

thanks

[Image: sigpic_40821_de64ff3d5cbbcb955be34459103dba35.png]
iMac 27" 2.93gHz i7, OS X 10.9.4
SymLinked to
MacMini 2.3gHz i7, OS X 10.9.4
Running Eden 13.1 and Transparency! 6.0.7 on both computers
(This post was last modified: 2010-03-17 17:17 by jpf55.)
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #4
latest nightly have it. i have no idea nor any interest in which of them are the most stable - try it and see if it works for you. it's built from a codebase in constant development, so it may be a bit hairy.
find quote
forcedalias Offline
Donor
Posts: 44
Joined: Nov 2008
Reputation: 1
Post: #5
Is there a way I can update the scraper without having to replace my XBMC install with an SVN build or is it out of the question?
find quote
mathius Offline
Junior Member
Posts: 45
Joined: Apr 2009
Reputation: 0
Post: #6
forcedalias Wrote:Is there a way I can update the scraper without having to replace my XBMC install with an SVN build or is it out of the question?
I'll second that - the nightly builds just won't download for me. They time out, reporting whole days as an ETA... I'm in Australia.
find quote
forcedalias Offline
Donor
Posts: 44
Joined: Nov 2008
Reputation: 1
Smile  Just an XML, Phew!
Post: #7
Thankfully, the scrapers aren't hard coded. They're just XML files.

http://hotfile.com/dl/33853563/c768343/i...x.rar.html

Unpack the file above into your XBMC install directory overwriting the existing imdb.xml
find quote
brian_M Offline
Junior Member
Posts: 18
Joined: Nov 2009
Reputation: 0
Post: #8
thanks !
find quote
Gordonx42 Offline
Junior Member
Posts: 27
Joined: Dec 2008
Reputation: 0
Post: #9
Thanks from me too!

forcedalias Wrote:Thankfully, the scrapers aren't hard coded. They're just XML files.

http://hotfile.com/dl/33853563/c768343/i...x.rar.html

Unpack the file above into your XBMC install directory overwriting the existing imdb.xml
find quote
twinflower Offline
Member
Posts: 74
Joined: Mar 2010
Reputation: 0
Location: Norway
Post: #10
Does the same applies to "Tag Line" ?
I keep getting blank tag lines in movie information, even after refreshing.
TMDB gets it, but I prefer IMDB because of their rating/scoring-system
find quote
hebjor Offline
Junior Member
Posts: 11
Joined: Jan 2009
Reputation: 0
Post: #11
Copying the imdb.xml from SVN works like a charm, but I had a 170 movies with missing year due to this change from IMDB.

I was worried I had to drop my whole library OR manually re-scan the movies with missing year. I found a workaround that seem to work ok for me at least:

1) Download sqlite client for your O/S if you do not already have it (http://www.sqlite.org/download.html or "sudo apt-get install sqlite3" for Ubnutu)

2) To be sure quit XBMC and backup your database file (.xbmc/userdata/Database/MyVideos34.db)

3) Open the database with the sqlite client (sqlite3 MyVideos34.db)

4) To check the number of movies with wrong year run this sql:

SELECT count(*) FROM movie WHERE movie.c07 = 0;

5) To delete these movies from the library use these sqls:

DELETE FROM path WHERE idpath IN (SELECT idpath FROM path WHERE idpath IN (SELECT idpath FROM files WHERE idfile IN (SELECT idFile FROM movie WHERE movie.c07 = 0)));

DELETE FROM files WHERE idfile IN (SELECT idFile FROM movie WHERE movie.c07 = 0);

DELETE FROM movie WHERE movie.c07 = 0;

6) Quit sqlite client by typing ".quit"

7) Start XBMC and do a "update library"

WARNING: Use at own risk, I did not dig too deep into the data model and I guess this could cause problems Smile
(This post was last modified: 2010-05-06 13:00 by hebjor.)
find quote
Shinu Offline
Posting Freak
Posts: 792
Joined: Jul 2010
Reputation: 3
Location: Trinidad & Tobago
Post: #12
Great!!!
find quote
Odin Offline
Junior Member
Posts: 2
Joined: Oct 2010
Reputation: 0
Post: #13
Hey,

I'm having a problem with the IMDB scraper too, since the website change. However, my missing info is not the date, but the title and rating for the movie...

Anyone else having this problem? I changed the xml file to the new one, with no result...

TVDB scraping is still working fine, so I'm pretty sure it must be the website change issue.

Um...debug log? Not sure where to get/start that...

Any help greatly appreciated!
Thanks.
find quote
musti Offline
Junior Member
Posts: 43
Joined: Nov 2009
Reputation: 0
Post: #14
Odin Wrote:Hey,

I'm having a problem with the IMDB scraper too, since the website change. However, my missing info is not the date, but the title and rating for the movie...

Anyone else having this problem? I changed the xml file to the new one, with no result...

TVDB scraping is still working fine, so I'm pretty sure it must be the website change issue.

Um...debug log? Not sure where to get/start that...

Any help greatly appreciated!
Thanks.

Same problem here! Not sure what's going on....
find quote
musti Offline
Junior Member
Posts: 43
Joined: Nov 2009
Reputation: 0
Post: #15
Here's my pastebin, not sure what the problem is:
http://pastebin.com/6sd5HauK
find quote
Post Reply