[iMac G3] EXC_BAD_INSTRUCTION when Play Video or enable Auto Thumb

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Raptusis Offline
Junior Member
Posts: 2
Joined: Mar 2010
Reputation: 0
Post: #1
(sorry for my english...)

OS Version: 10.4.11 (Build 8S165)
Platform: iMac G3 500mhz
Install Method dmg
Version: 9.04.1 (SVN-20686M)

XBMC CRASH :
When I Play Video (I hear 2 or 3 second of audio but no video and so crash)
When I Enable Auto Thumbs and I go to see the thumb

XBMC.log : http://pastebin.com/BSvwkLk6
XBMC.crash.log : http://pastebin.com/nGdCT1gu
Console.log : http://pastebin.com/MwZZKFjm

All XBMC and skin work well, but i can't play videos

With VLC,QuickTime,Mplayer the videos work well-
I have installed perian,flip4mac, etc

I Think the problem is lib2mpeg o something..
I Have in G3 ffmpeg ,mencoder codec etc


Thanks in advance,
I Love XBMC
I Have XBMC in PowerMac g4 733 and work ALL well!!
(This post was last modified: 2010-03-21 17:42 by Raptusis.)
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,387
Joined: Feb 2008
Reputation: 64
Post: #2
Raptusis Wrote:(sorry for my english...)

OS Version: 10.4.11 (Build 8S165)
Platform: iMac G3 500mhz
Install Method dmg
Version: 9.04.1 (SVN-20686M)

XBMC CRASH :
When I Play Video (I hear 2 or 3 second of audio but no video and so crash)
When I Enable Auto Thumbs and I go to see the thumb

XBMC.log : http://pastebin.com/BSvwkLk6
XBMC.crash.log : http://pastebin.com/nGdCT1gu
Console.log : http://pastebin.com/MwZZKFjm

All XBMC and skin work well, but i can't play videos

With VLC,QuickTime,Mplayer the videos work well-
I have installed perian,flip4mac, etc

I Think the problem is lib2mpeg o something..
I Have in G3 ffmpeg ,mencoder codec etc


Thanks in advance,
I Love XBMC
I Have XBMC in PowerMac g4 733 and work ALL well!!

I suspect it's ffmpeg expecting a G4. The crash is in avcodec_default_get_buffer which is an ffmpeg routine. An iMac G3 500mhz is really not fast enough to play any video content, maybe music.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Raptusis Offline
Junior Member
Posts: 2
Joined: Mar 2010
Reputation: 0
Post: #3
Ok, I understand... Sad

There's nothing that I can do ? I see the videos with all other program in g3... Sad
For example, a mp4 video, with very low resolution don't work, but with quicktime and other work perfectly...


Maybe encode the video in low resolution ? or in other format ? or use other codec ?

Is very very very very beautiful see XBMC run in Imac G3 !!! Sad
(This post was last modified: 2010-03-21 17:09 by Raptusis.)
find quote