Problem getting Broadcom Crystal HD BMC70015 to work with XBMC

  Thread Rating:
  • 4 Votes - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
amet Offline
Retired Team-Kodi Member
Posts: 4,113
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #1
This is official CrystalHD issues report thread.

Please use latest recommended drivers at all the times and Latest SVN nightly builds before reporting on any issues as your problem might be fixed already.

here is what is needed for the proper report:
[INDENT][INDENT]1.Full xbmc debug log
2.Media info for the offending file
3.Describe the issue in as many details as you can
4.50-100MB file clip (optional but preferred)

[/INDENT][/INDENT]Before posting, look at the CrystalHD thread for the known issues, if they are there, devs know about it.

Note:
[INDENT]
  • all +1 posts will be deleted
  • all incomplete reports will be deleted
  • all posts from other platform specific forums will be merged here or deleted
  • no discussions here, lets try and keep the thread clean and easy for devs to go trough and retrieve relevant information
  • please do not paste debug logs and media info in the posts, use pastebin.com and post the link to it here
[/INDENT]

Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
(This post was last modified: 2010-09-20 18:27 by amet.)
find quote
matthoffman Offline
Junior Member
Posts: 44
Joined: Sep 2008
Reputation: 0
Post: #2
I have an AppleTV setup running Ubuntu 8.04
-Latest crystalhd r26 drivers are compiled and installed
-XBMC SVN 28078 is being used. Later builds are currently unstable.

-Full XBMC debug before crash: http://pastebin.com/xpQqZ1uH

-Movie: This happens with all MKV files not one specific movie

-Issue I have is the following.
I can watch all movies with crystalhd card just fine. HD or SD using h264. Problem that I have having is when I skip to next chapter, fast forward in movie. AppleTV 90% of the time will reboot (Orange light on front will start blinking) then I see linux kernel booting up. I can reproduce this problem very easily. Very rare is it that I can get chapters to actually work. I have been using crystalhd for a while now and know that fast forwarding in movie has had it's issue. Issue I am posting about now may very well still be a known problem just wanted to check. Resume function seems to work just fine if I want to continue watching a movie at a later time.
find quote
necross_o Offline
Junior Member
Posts: 1
Joined: Apr 2010
Reputation: 0
Post: #3
Hi guys.
i have this Full HD movie that exits after 26 minutes. it works fine on the computer on several players.

xbmc.log: http://paste2.org/p/756442
file info: http://paste2.org/p/756461

cheers,
Oded.
(This post was last modified: 2010-04-05 04:41 by necross_o.)
find quote
icedtrip Offline
Member
Posts: 51
Joined: Mar 2010
Reputation: 0
Post: #4
Description:
When playing a MakeMKV rip of the King Arthur BD, artifacts in the video flicker in and out every 1-2 seconds. Frames are not dropping, vq and aq stay close to 99%, but never dropping below 80% for vq. I have tested both over the network and on a local drive with the same results. On a separate, more powerful machine, video plays fine. Not using the Broadcom card for rendering, the video plays without artifacts, but with frequent dropped frames due to CPU usage getting maxed out.

I have attached 2 screenshots showing with and without artifacts.

Machine:
Mac Mini 2.0 GHz (2GB RAM) - OS 10.6.3
XBMC r28256
Broadcom driver 1.0.3 (binary download and r26 compiled on 10.6, both with same results)

Pastbin info:
xbmc.log - http://pastebin.com/ReTCd3VS
Media File - http://pastebin.com/4SVupKYU

[Image: 4516044141_6ea4e78efa_b.jpg]


[Image: 4516679226_b71fd0a024_b.jpg]
find quote
wyild1 Offline
Senior Member
Posts: 182
Joined: Jan 2007
Reputation: 0
Post: #5
Morning!

I have been having issues with the CrystalHD card as well. 720p h264 files play great but i am getting hit and miss on 1080p h264 files. I also have a set of h264 that love to crash my xbmc. Lets see if i can get all the details down:

Computer: Dell Inspiron 9400 C2D 2.0GHz
2GB RAM
nVidia Corporation GeForce Go 7900 GS

uname -a
Linux HOBAG 2.6.24-27-generic #1 SMP Fri Mar 12 01:10:31 UTC 2010 i686 GNU/Linux
Ubuntu 8.04.3 LTS
The output of lspci says this about the CrystalHD card:
Multimedia controller: Broadcom Corporation Unknown device 1612 (rev 01)
CrystalHD drivers version 26
XBMC version r28184
xorg.conf: http://pastebin.com/bYCKarqs

Most of the 1080p files play at a rate of 5-8 fps. There are no frame drops, and the audio never pops or drops. The CPU load is low (~20%). Below is the media info for ones that do not work properly:

Aeon Flux - http://pastebin.com/hrmGQtBK
A Clockwork Orange - http://pastebin.com/eBpsU6KS
American Psycho - http://pastebin.com/sduMRMC0
Armored - http://pastebin.com/4GrAHDbc
Bitch Slap - http://pastebin.com/ihmUTpEL
Boondock Saints 2 - http://pastebin.com/jetJEXwv
The Cell - http://pastebin.com/BDUgsraC
Couples Retreat - http://pastebin.com/wFqU5AEn
Cube - http://pastebin.com/e3b16Rju
Die Hard - http://pastebin.com/Dsn5pd6P
Die Hard 2 - http://pastebin.com/u7ZdPgdS
Die Hard 3 - http://pastebin.com/MwjGTr07
Doom - http://pastebin.com/xjHMSce2
Eternal Sunshine of the Spotless mind - http://pastebin.com/vTP7Lk2e
Fight Club - http://pastebin.com/z08E9VF7
Hitchikers Guide to the Galaxy - http://pastebin.com/7iaFX853
Hitman - http://pastebin.com/LKStbeht
The Incredibles - http://pastebin.com/Gy3ZzwT1
The Informant! - http://pastebin.com/murD6VWg
Die Hard 4 - http://pastebin.com/wjiUXgPA
The Men who Stare at Goats - http://pastebin.com/zk8dvCFe
Office Space - http://pastebin.com/XE4D9Bq1
RocknRolla - http://pastebin.com/fRiG4Juv
Saw VI - http://pastebin.com/YJUbz91j
Sherlock Holmes - http://pastebin.com/9jWmZa2M
Sin City - http://pastebin.com/Mbp9e3dL
Smash Cut - http://pastebin.com/M2HvfL27
Smokin Aces - http://pastebin.com/mjh9841R
Smokin Aces 2 - http://pastebin.com/wtAmCbLe
Snatch - http://pastebin.com/eXRyNEy4
SpaceBalls - http://pastebin.com/HUe26y6x
Star Trek - http://pastebin.com/tTsy1wsw
Starship Troopers - http://pastebin.com/jNTQ2XHm


Ones that do work:
Batman Begins - http://pastebin.com/auW5EUzN
Boondock Saints - http://pastebin.com/qAphA7qS
Ekusu Makina (Appleseed) - http://pastebin.com/5a6ufZL4
Ferris Bullers Day off - http://pastebin.com/tM7CRJve
Friday the 13th - http://pastebin.com/XmBudnyS
Gladiator - http://pastebin.com/QjgLQM9K
Lord of the Rings Trilogy - http://pastebin.com/CCUipuMC
http://pastebin.com/sz0Q70bW
http://pastebin.com/WaMAZVKM
Ninja Assasin - http://pastebin.com/MyCZfCzY
Predator - http://pastebin.com/cff3yffR
Robocop - http://pastebin.com/FuuFXEe8
The Running Man - http://pastebin.com/51KYvXaD (FPS drops once in a while for 10 sec then syncs back up most times. Sometimes have to stop and start the video again)
Star Wars 2 - http://pastebin.com/GjU2maqB
Star Wars 3 - http://pastebin.com/VyeL1wEN

Some screenshots of ones with poor frame rates:
http://img17.imageshack.us/img17/2485/sc...t008rf.png
http://img189.imageshack.us/img189/1917/...ot009x.png
http://img248.imageshack.us/img248/6944/...ot013h.png

xbmc.log - http://pastebin.com/CFAmYdc7

Please let me know if you need anything else!
Cheers!
(This post was last modified: 2010-04-25 20:11 by wyild1.)
find quote
wyild1 Offline
Senior Member
Posts: 182
Joined: Jan 2007
Reputation: 0
Post: #6
Also, when i pause any h264 file and then press play, the video stutters. I have to pause/play a few times or quit the video and resume it for the video to play again properly. same goes for hitting tab and switching back to the GUI and then back to the video.

Cheers!
find quote
matthoffman Offline
Junior Member
Posts: 44
Joined: Sep 2008
Reputation: 0
Post: #7
matthoffman Wrote:I have an AppleTV setup running Ubuntu 8.04
-Latest crystalhd r26 drivers are compiled and installed
-XBMC SVN 28078 is being used. Later builds are currently unstable.

-Full XBMC debug before crash: http://pastebin.com/xpQqZ1uH

-Movie: This happens with all MKV files not one specific movie

-Issue I have is the following.
I can watch all movies with crystalhd card just fine. HD or SD using h264. Problem that I have having is when I skip to next chapter, fast forward in movie. AppleTV 90% of the time will reboot (Orange light on front will start blinking) then I see linux kernel booting up. I can reproduce this problem very easily. Very rare is it that I can get chapters to actually work. I have been using crystalhd for a while now and know that fast forwarding in movie has had it's issue. Issue I am posting about now may very well still be a known problem just wanted to check. Resume function seems to work just fine if I want to continue watching a movie at a later time.

This issue appears to be resolved. For some odd reason my MaxCPUState C2 did not take. When I tried again it took this time and these issues seemed to go away.
find quote
arteqw Offline
Junior Member
Posts: 4
Joined: May 2010
Reputation: 0
Post: #8
Hello,

I have a strange problem with CrystalHD. The problem appears suddenly. How do I run any HD movie is a failure XBMC for a while. The film does not start or displays very slowly.

I use Archlinux.

Full XBMC Log
http://pastebin.com/RfPqmTg0
Crash log
http://pastebin.com/0TCaNEG9
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #9
arteqw Wrote:Hello,

I have a strange problem with CrystalHD. The problem appears suddenly. How do I run any HD movie is a failure XBMC for a while. The film does not start or displays very slowly.

I use Archlinux.

Full XBMC Log
http://pastebin.com/RfPqmTg0
Crash log
http://pastebin.com/0TCaNEG9

Your xbmc.log show less than one second of playback before you stopped it. How can we see what's going on if you do this. Start xbmc, navigate directly to the video in question, play it and leave it playing for at least 10-15 mins, then stop and quit xbmc. Now you have a nice xbmc.log that JUST contains info regarding your issue... pastebin it.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
arteqw Offline
Junior Member
Posts: 4
Joined: May 2010
Reputation: 0
Post: #10
Ok.
http://pastebin.com/f0HXrMUw

There some changes. New distro(Debian squeeze) with crystalhd 1.0.3.
find quote
beytarj Offline
Member
Posts: 59
Joined: May 2010
Reputation: 0
Post: #11
i have mac mini 1.66, osx 10.6.3, xbmc r28256, crystal driver 1.0.3.

all mkv files play good for 1 hour. after that the movie pause and i have to stop movie. when i resume movie its play in software render. i have to load the driver again.
xbmc log: http://pastebin.com/h43taJ21
dmesg: http://pastebin.com/WyAKmTFs
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #12
beytarj Wrote:i have mac mini 1.66, osx 10.6.3, xbmc r28256, crystal driver 1.0.3.

all mkv files play good for 1 hour. after that the movie pause and i have to stop movie. when i resume movie its play in software render. i have to load the driver again.
xbmc log: http://pastebin.com/h43taJ21
dmesg: http://pastebin.com/WyAKmTFs

That's a new error in dmesg, have never seen that one.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
curlyjs Offline
Member
Posts: 88
Joined: Dec 2009
Reputation: 0
Post: #13
Hi,

having some issues with those two files. When watching the files, small block appears and the video shutters.

File1
http://paste2.org/p/838912

File 2
http://paste2.org/p/838913

log
http://paste2.org/p/838915

Thanks
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #14
curlyjs Wrote:Hi,

having some issues with those two files. When watching the files, small block appears and the video shutters.

File1
http://paste2.org/p/838912

File 2
http://paste2.org/p/838913

log
http://paste2.org/p/838915

Thanks

1280 x 720, High@L3.1 with 7 reference frames, noted.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
MisaVN Offline
Junior Member
Posts: 4
Joined: May 2010
Reputation: 0
Post: #15
Hi,

I have an Apple TV which is runing 3.0.1 firmware.
I have patched with atvpatchstick ....
I have also installed the driver for BroadCom crystall HD ( 1.0.3) and the nightly build of XBMC R26768.

I can select the render method in XBMC is Broadcom Crystal HD. I have also checked XBMC.log, the status of Crystal card with dmesg command as well. Anything is seem working well but I can't watch any 1080p mkv movies ( lagged ).

Here is my XBMC.log.

http://pastebin.com/1mw7fczZ

Please help me to find out what is happening with my job.

Thanks so much
MisaVN
find quote
Post Reply