Problem getting Broadcom Crystal HD BMC70015 to work with XBMC

  Thread Rating:
  • 4 Votes - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
davilla Offline
Team-XBMC Developer
Posts: 11,389
Joined: Feb 2008
Reputation: 64
Post: #16
MisaVN Wrote:Hi,

I have an Apple TV which is runing 3.0.1 firmware.
I have patched with atvpatchstick ....
I have also installed the driver for BroadCom crystall HD ( 1.0.3) and the nightly build of XBMC R26768.

I can select the render method in XBMC is Broadcom Crystal HD. I have also checked XBMC.log, the status of Crystal card with dmesg command as well. Anything is seem working well but I can't watch any 1080p mkv movies ( lagged ).

Here is my XBMC.log.

http://pastebin.com/1mw7fczZ

Please help me to find out what is happening with my job.

Thanks so much
MisaVN

09:36:56 T:2684407808 M: 36114432 DEBUG: Loading: libcrystalhd.dylib
09:36:56 T:2684407808 M: 3358720 ERROR: CrystalHD: device open failed
09:36:56 T:2684407808 M: 3358720 INFO: CrystalHD: broadcom crystal hd not found


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
.:B:. Offline
Fan
Posts: 349
Joined: Mar 2010
Reputation: 0
Post: #17
Okay Smile.

Bah... I don't know why this always happens to me Sad. I installed the same package as before (31021), play the same file that dropped frames on me every few seconds, and now all of a sudden it barely drops any! Anyway there are still framedrops, so here we go.

Media info for the first test file

Media info for the second test file

Media info for the third test file

Xbmc log file

Xbmc log file for the third movie

The initial dropped frames occur when the movie is loaded (which should be normal as I understood), the ones at 10:46 were caused by pulling up the OSD. The first test file ran pretty smoothly (it dropped as many frames as the second one though the past days). Playback of the second file starts at 10:53:57 more or less. First major dropped frames occur around 10:59:03, where I could see the card's buffer unfill dramatically. I checked CPU usage and that was fine at the time. Network traffic looked fine too (150 KBps upstream torrent traffic, router can handle that just fine), I also tried with rtorrent not running yesterday to make sure it wasn't interfering, frames were still being dropped at the same rate.

Crystalhd kernel module and userspace library are both 1.0.3.

I hope I'm not wasting your time, yesterday it was all choppy and dropped frames galore, and a lot of the time the CrystalHD buffer wouldn't even fill past 50%. Now it played fine for a while and the dropped frames don't occur as frequently, it's very bizarre. I also recall watching another 1080p movie with 30874 and that - apart from a few occasional hiccups - played fine, I didn't check for any dropped frames there with the overlay, thought it was the encode since I rewinded and it occured a second time at the same moment. If you want I can try that again and post the log too.

* Netgear WNDR3700, OpenWrt Attitude Adjustment 12.09.1 :: HP Procurve V1410-8G switch
* OpenELEC 4 b3: HTPC Zotac Nano AD10 with Pulse-Eight CEC adapter, Sony KDL52-NX800 :: Desktop Phenom II X4 980 BE / AMD HD6950 / 23" Dell Full HD
* Debian Jessie x86_64: Celeron G1610, HTTP/NFS/MySQL/ZFS server
* Blog
(This post was last modified: 2010-06-14 17:36 by .:B:..)
find quote
Tijntje Offline
Junior Member
Posts: 49
Joined: Jan 2010
Reputation: 0
Post: #18
.:B:. Wrote:Okay Smile.

Bah... I don't know why this always happens to me Sad. I installed the same package as before (31021), play the same file that dropped frames on me every few seconds, and now all of a sudden it barely drops any! Anyway there are still framedrops, so here we go.

Media info for the first test file

Media info for the second test file

Xbmc log file

The initial dropped frames occur when the movie is loaded (which should be normal as I understood), the ones at 10:46 were caused by pulling up the OSD. The first test file ran pretty smoothly (it dropped as many frames as the second one though the past days). Playback of the second file starts at 10:53:57 more or less. First major in-move dropped frames occur around 10:59:03, where I could see the card's buffer unfill dramatically. I checked CPU usage and that was fine at the time. Network traffic looked fine too (150 KBps upstream torrent traffic, router can handle that just fine), I also tried with rtorrent not running yesterday to make sure it wasn't interfering, frames were still being dropped at the same rate.

Crystalhd kernel module and userspace library are both 1.0.3.

I hope I'm not wasting your time, yesterday it was all choppy and dropped frames galore, and a lot of the time the CrystalHD buffer wouldn't even fill past 50%.

I'm having similar issues. Sometimes everything is working ok, a reboot later without touching the installation I'm having a lot of frame drops with the same movie. I'm on ubuntu karmic with 1.0.3 libs and switching between 28744 and svn trunk. I notice that the current SVN builds have less frame drops when you start a movie and on skipping, but they seem less stable
overall.

For example Shutter Island 1080p mediainfo plays almost fine @ 28744, unwatchable @ svn trunk.

r28744log: http://pastebin.com/KbxWKtpF

r31087log: http://pastebin.com/RgDeui21
(This post was last modified: 2010-06-13 21:31 by Tijntje.)
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,389
Joined: Feb 2008
Reputation: 64
Post: #19
1080p H@L4.1 with 5 ref frames seems to be a common issue.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
beytarj Offline
Member
Posts: 58
Joined: May 2010
Reputation: 0
Post: #20
mac mini 1.66, osx 10.6.4, xbmc r31168, crystal driver 1.0.3

all mkv files have freezes for few secondes every few minutes. there are no frame drops. the r28256 play these files good.
xbmc log:

http://pastebin.com/UEPcVEvm
find quote
beytarj Offline
Member
Posts: 58
Joined: May 2010
Reputation: 0
Post: #21
in ver xbmc-r31463 for osx, when i press seek, the picture is freeze but sound go on, in all mkv files. crystalhd ver 1.0.3.
log:
http://paste-it.net/public/l8b75f4/
find quote
homer_doh Offline
Junior Member
Posts: 22
Joined: Jul 2010
Reputation: 1
Post: #22
Mac mini 1.83GHz C2D/1GB RAM with Crystal HD BCM70012.
Mac OS X 10.6.4.
XBMC r31452.
CrystalHD lib/driver r115 compiled by me, when building kext I got 5 warnings, all about "flags" not being initialized in crystalhd_hw.c (and some others) but the build succeeded. --- UPDATE: Warnings disappear if "Development" config is chosen.

Tried playing "killa sampla" (bird scene from BBC) in XBMC and nothing is shown. Have also tried other MKV files, sometimes get audio but never video. Have to kill XBMC, can't end playback or quit.

After trying to play "killa sampla" I tried starting an AVI file (SD material) but nothing happened. Killed XBMC shortly after that.

See log info.

I have now removed r115 driver from the system and the same files play fine in XBMC r31452, albeit choppy without hardware acceleration.
(This post was last modified: 2010-07-04 08:53 by homer_doh.)
find quote
Tijntje Offline
Junior Member
Posts: 49
Joined: Jan 2010
Reputation: 0
Post: #23
homer_doh Wrote:Strange. I've cleaned all targets in Xcode and rebuilt both library and driver and verified that the only libcrystalhd.dylib on the machine is the one from r115. There's still "INFO: CrystalHD(old): device opened" in xbmc.log, see http://pastebin.com/jpM1si1P. Confused



OK, I have tested "killa sampla" with driver 1.03 and XBMC r28256, there were some problems with dropped frames, but the video was shown.

This time I used Pioneer One episode 1. Same result, audio but no video. Seen it before without Crystal HD, no problems.

EDIT: This is repeatedly logged on the command line where XBMC was started:
COULD not find free MDATA

I am running ubuntu karmic and lib r115.
xbmc also says crystalhd(old)
100% sure i'm runnning the freshly comiled r115!

strange errors in dmesg:
[ 437.156797] Invalid Line Number[269488144]
[ 444.362385] Invalid Line Number[269488144]
[ 444.443354] Invalid Line Number[269488144]
[ 446.993654] Invalid Line Number[269488144]
[ 447.074619] Invalid Line Number[269488144]
[ 452.660981] Invalid Line Number[269488144]
[ 457.437729] Invalid Line Number[269488144]
[ 459.063618] Invalid Line Number[269488144]

dmesg: http://pastebin.com/Lg4TC5d2
xbmc log: http://pastebin.com/wBpqukts
(This post was last modified: 2010-07-01 23:32 by Tijntje.)
find quote
homer_doh Offline
Junior Member
Posts: 22
Joined: Jul 2010
Reputation: 1
Post: #24
I've done some testing, here are log files and command line output:

XBMC r31542 with lib/kext 1.03: audio and video but only black & white. --- UPDATE: My mistake, software rendering was chosen, with hardware rendering video is in color. Old driver means no sleep.

XBMC r31542 with lib/kext r115: audio but no video, when playback is stopped this is written to the prompt:

DtsCloseDecoder: Ioctl failed: 10
Clearing PendMdata 0x30247fa 1
Clearing PendMdata 0x30247d6 2
...
Clearing PendMdata 0x3021d3a 131

At the same time this is logged to kernel.log:

Jul 3 14:07:32 macmini kernel[0]: BroadcomCrystalHD::start
Jul 3 14:07:32 macmini kernel[0]: opening HW
Jul 3 14:07:32 macmini kernel[0]: crystalhd_hw_open: setting up functions, device = Link
Jul 3 14:07:32 macmini kernel[0]: Starting Crystal HD Device
Jul 3 14:07:32 macmini kernel[0]: Opening HW. hw:0x5a43404, hw->adp:0x5d0f500
Jul 3 14:07:32 macmini kernel[0]: Closing HW
Jul 3 14:07:32 macmini kernel[0]: Stopping Crystal HD Device
Jul 3 14:07:32 macmini kernel[0]: BroadcomCrystalHD: Registering power handler
Jul 3 14:07:32 macmini kernel[0]: BroadcomCrystalHD: Found HW and started driver SW.
Jul 3 14:07:32 macmini kernel[0]: BroadcomCrystalHD: Turning off
Jul 3 14:07:32 macmini kernel[0]: BroadcomCrystalHD::setPowerStateOff
Jul 3 14:07:32 macmini kernel[0]: Nothing To Do Suspend Success
Jul 3 14:08:01 macmini kernel[0]: Opening new user[0] handle
Jul 3 14:08:01 macmini kernel[0]: opening HW
Jul 3 14:08:01 macmini kernel[0]: crystalhd_hw_open: setting up functions, device = Link
Jul 3 14:08:01 macmini kernel[0]: Starting Crystal HD Device
Jul 3 14:08:01 macmini kernel[0]: Opening HW. hw:0x4216e04, hw->adp:0x5d0f500
Jul 3 14:08:01 macmini kernel[0]: allocated 26 elem
Jul 3 14:08:01 macmini kernel[0]: Initializing Dio pool 18 1024 305c 0x4249324
Jul 3 14:08:01 macmini kernel[0]: crystalhd_link_download_fw entered
Jul 3 14:08:02 macmini kernel[0]: Firmware Downloaded Successfully
Jul 3 14:08:33 macmini kernel[0]: DelQAddr:0 RelQAddr:0
Jul 3 14:08:39 macmini kernel[0]: number of rx success 0 and failure 0
Jul 3 14:08:39 macmini kernel[0]: Capture Stop: 29 List0:Sts:0 List1:Sts:0
Jul 3 14:08:59 macmini kernel[0]: Firmware command T/O
Jul 3 14:08:59 macmini kernel[0]: FwCmd Failed.
Jul 3 14:08:59 macmini kernel[0]: fw cmd 7376311b failed
Jul 3 14:09:20 macmini kernel[0]: Firmware command T/O
Jul 3 14:09:20 macmini kernel[0]: FwCmd Failed.
Jul 3 14:09:20 macmini kernel[0]: fw cmd 73763101 failed


XBMC r31542 with lib/kext r123: slow start, driver won't load ("INFO: CrystalHD: broadcom crystal hd not found").
(This post was last modified: 2010-07-03 14:36 by homer_doh.)
find quote
homer_doh Offline
Junior Member
Posts: 22
Joined: Jul 2010
Reputation: 1
Post: #25
Tried XBMC r31632 with lib/kext r137 and the freezes are gone.

Don't know if this needs attention (from kernel.log):

Jul 6 08:32:40 macmini kernel[0]: Invalid Line Number[-2139062144]
Jul 6 08:32:44: --- last message repeated 1 time ---
Jul 6 08:32:40 macmini kernel[0]: MISSING 3 PICTURES
Jul 6 08:32:44 macmini kernel[0]: FETCH TIMEOUT
Jul 6 08:32:45 macmini kernel[0]: Invalid Line Number[269488144]
Jul 6 08:33:14: --- last message repeated 501 times ---
Jul 6 08:33:14 macmini kernel[0]: FETCH TIMEOUT

xbmc.log, kernel.log and command line output.
find quote
frumpy_uk Offline
Fan
Posts: 300
Joined: Jun 2006
Reputation: 0
Post: #26
Problems here with some, others are just great.
This is on linux on an aTV (aTV v1.1, pin87a's minimal Ubuntu 8.0.4 (co-existing with aTV OS), XBMC SVN31642, Crystal HD r137, Confluence).

Examples

Anvil 720p
1. http://pastebin.com/mX2VFaQC
2.
Code:
General
Complete name                    : X:\Documents\Movies\Anvil! The Story of Anvil\Anvil! The Story of Anvil 2008 720p Blu-ray AAC x264.mkv
Format                           : Matroska
File size                        : 5.09 GiB
Duration                         : 1h 20mn
Overall bit rate                 : 9 039 Kbps
Encoded date                     : UTC 2010-05-26 14:07:25
Writing application              : mkvmerge v3.4.0 ('Rapunzel') built on May 15 2010 09:38:20
Writing library                  : libebml v0.8.0 + libmatroska v0.9.0

Video
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.1
Format settings, CABAC           : Yes
Format settings, ReFrames        : 9 frames
Muxing mode                      : Container profile=Unknown@4.1
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 1h 20mn
Width                            : 1 276 pixels
Height                           : 720 pixels
Display aspect ratio             : 16/9
Frame rate                       : 25.000 fps
Resolution                       : 24 bits
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Writing library                  : x264 core 94 r1583 7608d73
Encoding settings                : cabac=1 / ref=9 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / psy_rd=1.20:0.15 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-3 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=5 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=1 / weightb=1 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc=crf / mbtree=0 / crf=16.3 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:0.70
Language                         : English

Audio #1
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : No
Codec ID                         : A_AAC
Duration                         : 1h 20mn
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Rear: L R, LFE
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : 5.1 audio
Language                         : English

Audio #2
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : No
Codec ID                         : A_AAC
Duration                         : 1h 20mn
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : 2.0 audio
Language                         : English

Audio #3
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : Yes
Format settings, PS              : No
Codec ID                         : A_AAC
Duration                         : 1h 20mn
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : Commentary with Steve "Lips" Kudlow, Robb Reiner and Sacha Gervasi

Audio #4
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : Yes
Format settings, PS              : No
Codec ID                         : A_AAC
Duration                         : 1h 20mn
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Title                            : Commentary with Sacha Gervasi, Rebecca Yeldman and Andrew Dickler
Language                         : English

Text
Format                           : UTF-8
Codec ID                         : S_TEXT/UTF8
Codec ID/Info                    : UTF-8 Plain Text
Language                         : English

Chapters
Language                         : English
1                                : 00:00:00.054 00:00:00.054
2                                : 00:00:00.054 00:00:00.054
3                                : 00:00:00.097 00:00:00.097
4                                : 00:00:00.097 00:00:00.097

3. Video and audio very stuttery from the start

REC 720p
1.http://pastebin.com/YMg11vpd
2.
Code:
General
Complete name                    : X:\Documents\Movies\REC\[REC]2007 DvDrip-H264[Dual Audio]Spanish English-AC3[DD]5.1[DXO].avi
Format                           : AVI
Format/Info                      : Audio Video Interleave
Format profile                   : OpenDML
File size                        : 975 MiB
Duration                         : 1h 15mn
Overall bit rate                 : 1 811 Kbps
Writing application              : AVI-Mux GUI 1.17.8, Aug 30 2008  12:36:58

Video
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : Main@L5.1
Format settings, CABAC           : Yes
Format settings, ReFrames        : 2 frames
Codec ID                         : H264
Duration                         : 1h 15mn
Bit rate                         : 1 163 Kbps
Width                            : 624 pixels
Height                           : 336 pixels
Display aspect ratio             : 1.857
Frame rate                       : 29.970 fps
Resolution                       : 24 bits
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.185
Stream size                      : 626 MiB (64%)
Writing library                  : x264 core 58 svn-736bm
Encoding settings                : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x1:0x131 / me=umh / subme=7 / brdo=1 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=0 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=2 / nr=1 / decimate=1 / mbaff=0 / bframes=2 / b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=0 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=1163 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30

Audio #1
Format                           : AC-3
Format/Info                      : Audio Coding 3
Codec ID                         : 2000
Bit rate mode                    : Constant
Bit rate                         : 320 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Surround: L R, LFE
Sampling rate                    : 48.0 KHz
Stream size                      : 172 MiB (18%)
Alignment                        : Aligned on interleaves
Interleave, duration             : 64 ms (1.92 video frames)
Interleave, preload duration     : 192 ms
Title                            : Spanish 5.1

Audio #2
Format                           : AC-3
Format/Info                      : Audio Coding 3
Codec ID                         : 2000
Bit rate mode                    : Constant
Bit rate                         : 320 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Surround: L R, LFE
Sampling rate                    : 48.0 KHz
Stream size                      : 172 MiB (18%)
Alignment                        : Aligned on interleaves
Interleave, duration             : 64 ms (1.92 video frames)
Interleave, preload duration     : 192 ms
Title                            : English 5.1

General
Complete name                    : X:\Documents\Movies\REC\[REC]2007 DvDrip-H264[Dual Audio]Spanish English-AC3[DD]5.1[DXO].English.srt
Format                           : SubRip
File size                        : 70.9 KiB

Text
Format                           : SubRip
3. Very very long gaps between video and audio playback. Like a stutter but these are bi-i-i-i-g long gaps

thanks!

aTV 2

iPad 2

[Image: watched-fanart.jpg]
find quote
ElectricMayhem Offline
Junior Member
Posts: 6
Joined: Jul 2010
Reputation: 0
Post: #27
First, let me say that I am very grateful to the volunteer developers that are trying to perfect CrystalHD on AppleTV.

When I try to play a 1080i video (Top Gear) over the network from my FreeNAS box using SMB, it plays a few seconds of audio (without showing the video) and then the screen goes blank, with the Apple logo appearing as though it were rebooting (but it seems to be locked up to an extent that only power cycling will help).

I trust there is sufficient information in the following logs, but if further info is required I can supply.

Console log: http://pastebin.ca/1898056
xbmc log: http://pastebin.ca/1898058
CrashReporter log: http://pastebin.ca/1898062
find quote
davidhildreth Offline
Junior Member
Posts: 14
Joined: Mar 2009
Reputation: 0
Post: #28
So, I'm an editor and this morning I figured I'd try out a 2k QT I got from the producers of a short film I might finish. This isn't usually part of my workflow but I wanted to give it a shot on my ChrystalHD ATV.

It's 2k at 1:2, but low bit-rate and encoded with QT 7. The picture didn't display correctly, there was a large green bar on the left side and the whole image flickered. I don't know how take a screen shot on my ATV or I would have. When I tried the software decoder it rendered correctly but unsurprisingly at about 12fps.

Code:
Format                           : MPEG-4
Format profile                   : QuickTime
Codec ID                         : qt  
File size                        : 565 MiB
Duration                         : 36mn 16s
Overall bit rate                 : 2 178 Kbps
Encoded date                     : UTC 2010-06-28 01:50:46
Tagged date                      : UTC 2010-06-28 01:51:03
Writing library                  : Apple QuickTime

Video
ID                               : 2
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : Main@L4.0
Format settings, CABAC           : No
Format settings, ReFrames        : 2 frames
Codec ID                         : avc1
Codec ID/Info                    : Advanced Video Coding
Duration                         : 36mn 16s
Bit rate mode                    : Variable
Bit rate                         : 1 407 Kbps
Width                            : 2 048 pixels
Height                           : 1 024 pixels
Display aspect ratio             : 2.000
Frame rate mode                  : Constant
Frame rate                       : 23.976 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.028
Stream size                      : 365 MiB (65%)
Language                         : English
Encoded date                     : UTC 2010-06-27 22:58:41
Tagged date                      : UTC 2010-06-28 01:51:03
Color primaries                  : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio
ID                               : 1
Format                           : PCM
Format settings, Endianness      : Little
Format settings, Sign            : Signed
Codec ID                         : sowt
Duration                         : 36mn 16s
Bit rate mode                    : Constant
Bit rate                         : 768 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 24.0 KHz
Bit depth                        : 16 bits
Stream size                      : 199 MiB (35%)
Language                         : English
Encoded date                     : UTC 2010-06-27 22:58:41
Tagged date                      : UTC 2010-06-28 01:51:03

http://pastebin.com/cHb7JAPz

I can PM a link to a clip of the file if you'd like.
find quote
andy204 Offline
Senior Member
Posts: 215
Joined: Jan 2010
Reputation: 0
Location: Austria
Post: #29
opened another thread in the OSX / ATV subforum. but here it should be right Smile

all i did was starting an episode (mkv)
Debug Log: http://pastebin.com/c31Ax0an

backtrace: http://pastebin.com/0SvgWzBA

CrystalHD Installer XBMC Community Forum Thread -
Apple TV CrystalHD Installer Announcement - Broadcom CrystalHD Installer
http://www.sartori.at/ - my weblog

Sync your MAC and Google Account (+ Google Apps) - Click here for 5$ Discout

Living Room: HFX Micro black - Zotac IONITX G - Intel X25V - Hama remote
Bedroom: Linux AppleTV - CrystalHD
find quote
JeanLuc7 Offline
Junior Member
Posts: 9
Joined: Jul 2010
Reputation: 0
Location: Berlin, Germany
Post: #30
Have read different threads for about 8 hours until now. I just bought a Crystal HD foe my Mac mini early 2006 (upgraded with an 2.16 GHz CPU and a BluRay Drive). I experienced that using the Crystal HD creates massive frame drops with VC1 and AP@L3 but works flawless with others. After reading all those threads I understand this is a problem of either the container used (mine is MKV) or the Codec used (which is this VC1). So my only help is to transcode the problematic films to h.264/mp4, right?

Tested VC1 movies were "Inside man" and "where Eagles dare".

Logs for "Inside Man":

XBMC Log
Movie Info
find quote
Post Reply