AppleTV and DVD ISO load time

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Must4rd Offline
Junior Member
Posts: 17
Joined: Mar 2010
Reputation: 0
Post: #1
I have Apple TV upgraded to Version 3
I am running XBMC Build Pre 10.5 R28256 Compiled Mar 1 2010
Wired 200mbps Homeplug to
Windows Home Server


I have recently upgraded from Xbox 1 to Apple TV and noticed there is a massive delay when playing DVD ISO's whereas my Xbox1 plays them instantly.

The appletv is set to 720p, and I have included the advancedsettings.xml in the userdata directory for the statfiles. I read somewhere that it may help.

I have also copied one iso into another folder to see if that sped things up but it didnt. I am not sure how to post a log, so bear with me if you need that information too.

Someone please help, because at present the appletv doesnt appear to be the step up I had hoped for.

Many thanks

Alex
find quote
davilla Online
Team-XBMC Developer
Posts: 11,363
Joined: Feb 2008
Reputation: 64
Post: #2
see my sig on how to get xbmc.log


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Must4rd Offline
Junior Member
Posts: 17
Joined: Mar 2010
Reputation: 0
Post: #3
http://pastebin.com/6En0Hv8x

Thanks Davilla, I hope this covers it.
find quote
davilla Online
Team-XBMC Developer
Posts: 11,363
Joined: Feb 2008
Reputation: 64
Post: #4
libdvdnav/libdvdread seems to take a long time retrieving the dvd key when packed up in an ISO. Not sure why. It would be interesting to see if a dvd outside of the ISO takes the same amount of time. Also if the ISO is on the local disk rather than an SMB share.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Must4rd Offline
Junior Member
Posts: 17
Joined: Mar 2010
Reputation: 0
Post: #5
Davilla, what do you mean by a dvd outside of the ISO?
I am currently uploading an ISO to AppleTV so I can repost the log.

The weird thing is it only happens when it first reads the disk. After it has played once, the DVD iso loads up almost immediately.

Thanks

Alex
find quote
Dawg Offline
Junior Member
Posts: 6
Joined: Mar 2009
Reputation: 0
Post: #6
For what it's worth, I have the exact same load time issues with ISOs.

If I unpack the ISO into its component DVD files - .ts .vob .ifo etc. - =then it loads as quick as an AVI.

My Media files are stored on a Vista (i know) PC and accessed vie 100Meg Ethernet.

i have not tried it with the files locally on the ATV.
find quote
davilla Online
Team-XBMC Developer
Posts: 11,363
Joined: Feb 2008
Reputation: 64
Post: #7
Must4rd Wrote:Davilla, what do you mean by a dvd outside of the ISO?
I am currently uploading an ISO to AppleTV so I can repost the log.

The weird thing is it only happens when it first reads the disk. After it has played once, the DVD iso loads up almost immediately.

Thanks

Alex

libdvdnav/libdvdread will cache the DVD key once it's found. You can see that in the logs.

Mount the IOS, take the all the items inside and place them in a new folder. The DVD contents are now "outside" the ISO.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
xaos01 Offline
Junior Member
Posts: 35
Joined: Apr 2009
Reputation: 0
Post: #8
Think of an iso as a bucket. Inside the iso is a VIDEO_TS folder and maybe an AUDIO_TS folder.

Platform - AppleTV
AppleTV Version - 3.0.1
Launcher version - 3.2.4
Install Method - Patchstick
SVN Revision - 9.11 R28256
(2)Seritek 5PM Chassis' :: 12TB
find quote
Bobby Blixberg Offline
Donor
Posts: 371
Joined: Apr 2009
Reputation: 1
Post: #9
Until now I thought it is normal when XBMC needs longer to load DVD content than it takes to play mkv-files for instance.

Loading the DVD menu takes about 12 sec. here, another approx. 15 seconds to start the main movie., regardless whether it's an ISO or a folder containing the Video_TS files.

All movie content is stored on a NAS with Samba shares.

Davilla, could you please take a look at my xbmc.log:
http://pastebin.com/L9hVBjju

Thank you and kind regards,
Bobby

MIFcom Mini-ITX ASUS ION2 | 4GB RAM | 120 GB SSD | XBMCbuntu
Philips 42PFL8684
find quote
Must4rd Offline
Junior Member
Posts: 17
Joined: Mar 2010
Reputation: 0
Post: #10
I have copied an ISO to the hdd in the apple tv and it started instantly. It must be an issue with the network.

Is there anything else I can look at. If I plug in the xbox 1 the DVD ISO loads very quickly.
find quote
interceptor121 Offline
Fan
Posts: 507
Joined: Feb 2009
Reputation: 1
Post: #11
Are you connecting over ethernet or Wifi?
Sorry I did not see the homeplug. You will know that those are actually real 85 mbps not 200
If it is a network buffering issue you can try with the network tweak
http://wiki.awkwardtv.org/wiki/Network_Tweaks
(This post was last modified: 2010-03-28 17:50 by interceptor121.)
find quote
Bobby Blixberg Offline
Donor
Posts: 371
Joined: Apr 2009
Reputation: 1
Post: #12
It's definitely a network issue in my case, but the network tweak had no effect unfortunately. My apple TV is connected over ethernet.

Any more suggestions?

MIFcom Mini-ITX ASUS ION2 | 4GB RAM | 120 GB SSD | XBMCbuntu
Philips 42PFL8684
find quote
Must4rd Offline
Junior Member
Posts: 17
Joined: Mar 2010
Reputation: 0
Post: #13
The weird thing is it all works fine on my xbox1. The delay launching an iso can be as long as 3 minutes. I have very little or no delay on my xbox.

I just cant fathom it out
find quote
xploid Offline
Junior Member
Posts: 15
Joined: Mar 2010
Reputation: 0
Post: #14
Hello,

Im having the same issue. DVDISOs take up to 20minutes to start playing. However when i just have the Folder structure it plays instantly.
Hope this will be fixed. I'm playing my files from a 100mbit NAS.

Thanks
find quote
davilla Online
Team-XBMC Developer
Posts: 11,363
Joined: Feb 2008
Reputation: 64
Post: #15
xploid Wrote:Hello,

Im having the same issue. DVDISOs take up to 20minutes to start playing. However when i just have the Folder structure it plays instantly.
Hope this will be fixed. I'm playing my files from a 100mbit NAS.

Thanks

pastebin xbmc.log. it's the only way we can "see" what is happening since we are not by your side and that damm crystal ball stopped working.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Post Reply