XBMC Crash on TV Banner Fetch

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
aldenpotamus Offline
Junior Member
Posts: 21
Joined: Apr 2010
Reputation: 0
Post: #1
Hey All,

Still loving the remote, having an interesting issue with XBMC itself crashing (the remote just goes D/C, but doesn't receive the TV banner in question) when the remote tries to fetch the TV Show banner for "Greg the Bunny"... I've remove that show from my library but it still crashes on some other ones two. I have the XBMC crash log, though I can't post the whole thing here. Let me know if there any additional information I can provide and where I can put it.

Everything else is working fine, currently experiencing the bug with:

XBMC PRE-10.5 r28256
And the most recent version of the remote from SVN

Incidentally the crash happens both when I passively pull down the banner by loading the TV Shows mode and scroll to the show and also when I use the new download covers mode.

Cheers,
Alden
find quote
Paranormal Offline
Junior Member
Posts: 31
Joined: Nov 2009
Reputation: 0
Post: #2
Paste the entire log at http://pastebin.com/ and link to it
find quote
aldenpotamus Offline
Junior Member
Posts: 21
Joined: Apr 2010
Reputation: 0
Post: #3
Here's the log...

XBMC Side: http://pastebin.com/JSHp8Wsb
XBMC Remote Side: http://pastebin.com/VkMi8Mca

Cheers,
Alden

Edit - Added the remote side log, incidentally it was taken against a different version of XBMC, I was trying out the more recent SVN version to see if it was fixed... but the behavior is the same, it tried to get the Greg the Bunny banner and crashes.
(This post was last modified: 2010-04-29 06:35 by aldenpotamus.)
find quote
stibbons Offline
Junior Member
Posts: 18
Joined: Dec 2009
Reputation: 0
Post: #4
I've created a new issue for this, Issue 240. Everything I know about it so far is in there.

I'd suggest you add your logs and anything else you can dig up to that issue.
find quote
aldenpotamus Offline
Junior Member
Posts: 21
Joined: Apr 2010
Reputation: 0
Post: #5
Just to update this, the issue is resolved with these versions:

Remote: r643+
XBMC: r29743+

Though I'm having lots of problems with scrapers and some scripts in 29743 and the current, so if anyone finds a good version that is scraping TMDB, TVDB, and Allmusic well let me know, in the meantime i'm stuck with 28256 crashing when I accidentally hit the TV library Smile

Cheers,
Alden
find quote
stibbons Offline
Junior Member
Posts: 18
Joined: Dec 2009
Reputation: 0
Post: #6
This afternoon I got around to building both XBMC and XBMC Remote from source (I had everything I needed for the remote, but getting XBMC itself built is annoying if you've never done it before)

Can confirm that, with XBMC r29916 and XBMC Remote r634, the thumb downloading is working properly. I can also confirm that the TV Show activity looks freaking sweet. Smile Seems to have a little bit of lag refreshing on scrolls, but it's coming along well.

aldenpotamus Wrote:Though I'm having lots of problems with scrapers and some scripts in 29743

Yeah, I'm missing some of the scrapers that haven't been ported to the new system yet. But on the whole I'm pleased with the move.
find quote