CrystalHD & current SVN builds of XBMC?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
aaronjb Offline
Junior Member
Posts: 47
Joined: May 2009
Reputation: 0
Location: England
Post: #1
It's been a while since I've been around, and I did something rash last night.. and updated to the latest SVN build from SSHCS; 30813 (now 30831).. Since then I've noticed two things;

1) Much higher CPU utilisation when CrystalHD rendering is being used (75-100% CPU in r30831 vs. 30-40% CPU in r27288) and
2) The first file plays using hardware acceleration from CrystalHD, but the second file I play fails to open the CrystalHD hardware and falls back to software.

Prior to this I was running SVN 27288 which was working flawlessly (I know.. why fix something that wasn't broken, Aaron...), and I'm still running the same CrystalHD drivers (1.0.3) without change.

It doesn't seem to matter what files I play, though I'll include a MediaInfo from the file shown in the example debug-enabled xbmc.log.

This is all on my Mac Mini (Intel GMA950 based, 2Ghz Core2Duo, and still running OSX 10.5.8).


So, pastebin of the bad behaviour in r30831: http://pastebin.com/ah9vKesG

Example pastebin of r27288 working fine (I quit r30831 and opened r27288 and while the later SVN could no longer open the CrystalHD card, the earlier SVN had no problems): http://pastebin.com/cxtF2zWT
(Ignore the database errors above - the new SVN has of course upgraded my videoDB.. d'oh)

MediaInfo for the file I was playing: http://pastebin.com/81hqc21L


Apologies if this is old news and/or I'm simply not meant to be using recent SVNs, I had a peruse of the older CrystalHD threads and all the threads I found people were still back at r27xxx which does make me wonder if I did do something silly last night :o


Having said that - the new skin looks gorgeous, and the new database looks great, too! Just a shame I can't actually, er.. play anything :o
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,378
Joined: Feb 2008
Reputation: 64
Post: #2
aaronjb Wrote:It's been a while since I've been around, and I did something rash last night.. and updated to the latest SVN build from SSHCS; 30813 (now 30831).. Since then I've noticed two things;

1) Much higher CPU utilisation when CrystalHD rendering is being used (75-100% CPU in r30831 vs. 30-40% CPU in r27288) and
2) The first file plays using hardware acceleration from CrystalHD, but the second file I play fails to open the CrystalHD hardware and falls back to software.

Prior to this I was running SVN 27288 which was working flawlessly (I know.. why fix something that wasn't broken, Aaron...), and I'm still running the same CrystalHD drivers (1.0.3) without change.

It doesn't seem to matter what files I play, though I'll include a MediaInfo from the file shown in the example debug-enabled xbmc.log.

This is all on my Mac Mini (Intel GMA950 based, 2Ghz Core2Duo, and still running OSX 10.5.8).


So, pastebin of the bad behaviour in r30831: http://pastebin.com/ah9vKesG

Example pastebin of r27288 working fine (I quit r30831 and opened r27288 and while the later SVN could no longer open the CrystalHD card, the earlier SVN had no problems): http://pastebin.com/cxtF2zWT
(Ignore the database errors above - the new SVN has of course upgraded my videoDB.. d'oh)

MediaInfo for the file I was playing: http://pastebin.com/81hqc21L


Apologies if this is old news and/or I'm simply not meant to be using recent SVNs, I had a peruse of the older CrystalHD threads and all the threads I found people were still back at r27xxx which does make me wonder if I did do something silly last night :o


Having said that - the new skin looks gorgeous, and the new database looks great, too! Just a shame I can't actually, er.. play anything :o

crystalhd is in flux.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
aaronjb Offline
Junior Member
Posts: 47
Joined: May 2009
Reputation: 0
Location: England
Post: #3
Gotcha. I should probably roll back to r27288 then Smile I wish I'd taken the precaution of backing up my database now.. d'oh!

Thanks davilla.
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 25,669
Joined: Oct 2003
Reputation: 169
Post: #4
IIRC the database "downgrade" isn't too taxing? Check UpdateOldVersion in VideoDatabase.cpp on trac and compare the two versions perhaps?

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
aaronjb Offline
Junior Member
Posts: 47
Joined: May 2009
Reputation: 0
Location: England
Post: #5
jmarshall Wrote:IIRC the database "downgrade" isn't too taxing? Check UpdateOldVersion in VideoDatabase.cpp on trac and compare the two versions perhaps?

Y'know, had my brain actually been engaged this morning that would have been an awfully logical thing to do.. :o

I'll have a gander anyway, and post up what needs to be done.. just in case someone else wants to do the same thing in the future Smile
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 25,669
Joined: Oct 2003
Reputation: 169
Post: #6
Yeah - I can't remember when I added the improvements to export to XML, otherwise you could just export, downgrade, import. IIRC it was after 27xxx.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
anton_kg Offline
Junior Member
Posts: 16
Joined: Apr 2010
Reputation: 0
Post: #7
davilla Wrote:crystalhd is in flux.

Sad what a disaster! I've been waiting and using SVN for the last 6 month with more or less working crystalhd and now it's gone Frown

Please, please! Put it back! In fact, it's about time to release at least a beta version with crystal.hd support, even it got a lot of bugs.

Meanwhile, I'm going to try linux version with svn 28256 and crystal.hd ... Sam.Nazarko might have a better understanding of people's needs.

Honestly, I've regretted that i've got an appletv. Now, I'm getting close to regret that I've bought crystal.hd card. I should just buy something which does support full HD out the box and be a happy user long time ago.

Sorry for this letter, I just can't help myself.
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,378
Joined: Feb 2008
Reputation: 64
Post: #8
anton_kg Wrote:Sad what a disaster! I've been waiting and using SVN for the last 6 month with more or less working crystalhd and now it's gone Frown

Please, please! Put it back! In fact, it's about time to release at least a beta version with crystal.hd support, even it got a lot of bugs.

Meanwhile, I'm going to try linux version with svn 28256 and crystal.hd ... Sam.Nazarko might have a better understanding of people's needs.

Honestly, I've regretted that i've got an appletv. Now, I'm getting close to regret that I've bought crystal.hd card. I should just buy something which does support full HD out the box and be a happy user long time ago.

Sorry for this letter, I just can't help myself.

I see a lot of bitching here and no real info as to what's wrong. Seems to be working for me so if you can't give proper debug info, then not much I can do.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
iscraigh Offline
Member
Posts: 77
Joined: Jul 2008
Reputation: 0
Post: #9
I'll ask a question not complaining at all or trying to rush everyone just like messing around on the bleeding edge.

On the new version svn 30831 I notice in my decoders I no longer have a choice of crystal hd but I do have a check box that says enable hardware acceleration (crystalhd). I chose auto and left the checkbox ticked. Apologies for not including the required logs. I was able to play a hi-def movie it took about 2 minutes to sync up but then played fine.

Is this checkbox the new way of selecting crystal-hd ?

Craig
find quote
Riderzzz Offline
Senior Member
Posts: 206
Joined: Sep 2007
Reputation: 1
Location: DK
Post: #10
anton_kg Wrote:Sad what a disaster! I've been waiting and using SVN for the last 6 month with more or less working crystalhd and now it's gone Frown

Please, please! Put it back! In fact, it's about time to release at least a beta version with crystal.hd support, even it got a lot of bugs.

Meanwhile, I'm going to try linux version with svn 28256 and crystal.hd ... Sam.Nazarko might have a better understanding of people's needs.

Honestly, I've regretted that i've got an appletv. Now, I'm getting close to regret that I've bought crystal.hd card. I should just buy something which does support full HD out the box and be a happy user long time ago.

Sorry for this letter, I just can't help myself.



No Are you taking yourself serious saying this? This is an open source project with a great achievment already. It works near perfectly and when you bought it you knew it was in development.

So indeed just help the community and report bugs/errors logs. Otherwise just enjoy the most stable version around and look from a distance (that means, don't talk)

Good luck davilla (and the rest) with all the stuff whats going on. Its hard to wait but its definately worth it!
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,378
Joined: Feb 2008
Reputation: 64
Post: #11
iscraigh Wrote:I'll ask a question not complaining at all or trying to rush everyone just like messing around on the bleeding edge.

On the new version svn 30831 I notice in my decoders I no longer have a choice of crystal hd but I do have a check box that says enable hardware acceleration (crystalhd). I chose auto and left the checkbox ticked. Apologies for not including the required logs. I was able to play a hi-def movie it took about 2 minutes to sync up but then played fine.

Is this checkbox the new way of selecting crystal-hd ?

Craig

"Is this checkbox the new way of selecting crystal-hd ?", that's a silly question to ask. You don't see it in the render settings anymore right ?

"I was able to play a hi-def movie it took about 2 minutes to sync up but then played fine.", standard xbmc debug prayer -> xbmc.log, mediainfo output.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Sam.Nazarko Offline
Posting Freak
Posts: 845
Joined: Dec 2009
Reputation: 14
Location: London
Post: #12
anton_kg Wrote:Sad what a disaster! I've been waiting and using SVN for the last 6 month with more or less working crystalhd and now it's gone Frown

Please, please! Put it back! In fact, it's about time to release at least a beta version with crystal.hd support, even it got a lot of bugs.

Meanwhile, I'm going to try linux version with svn 28256 and crystal.hd ... Sam.Nazarko might have a better understanding of people's needs.

Honestly, I've regretted that i've got an appletv. Now, I'm getting close to regret that I've bought crystal.hd card. I should just buy something which does support full HD out the box and be a happy user long time ago.

Sorry for this letter, I just can't help myself.

Umm I hope this is a joke. CrystalHD performance fluctuates between builds. To progress forward you need to tweak the builds, meaning that at times performance will degrade. Davilla referred to this a while ago as "two steps forward, one step backward". Soon enough it'll all be sorted.

And you say the SVN is "gone". How? You can re-install the old subversion build you know.

If you wanted something doing full HD out of box then why didn't you buy something that did? Eventually aTV will, but still you can't blame purchase decisions on devs.
find quote
iscraigh Offline
Member
Posts: 77
Joined: Jul 2008
Reputation: 0
Post: #13
Quote:"Is this checkbox the new way of selecting crystal-hd ?", that's a silly question to ask. You don't see it in the render settings anymore right ?

LOL Seems obvious but I wanted to confirm, tough dealing with idiots like me.
Sorry about no logs Davilla
I was posting @ work no access to the box but I will post what I can tonight.

Thanks

Craig
find quote
iscraigh Offline
Member
Posts: 77
Joined: Jul 2008
Reputation: 0
Post: #14
Here are some logs

I played a recording from my mythbox hdpvr capture
then a movie that was choppy.

xbmc log

http://pastebin.ca/1878769

dmesg

http://pastebin.ca/1878772

media info first recording

http://pastebin.ca/1878774

I am sorry I can't get media info for the recording I am having a network issue with my pc but I will include it as soon as I can.

media info second recording

http://pastebin.ca/1878790


Craig
(This post was last modified: 2010-06-08 03:17 by iscraigh.)
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,378
Joined: Feb 2008
Reputation: 64
Post: #15
iscraigh Wrote:Here are some logs

I played a recording from my mythbox hdpvr capture
then a movie that was choppy.

xbmc log

http://pastebin.ca/1878769

dmesg

http://pastebin.ca/1878772

media info first recording

http://pastebin.ca/1878774

I am sorry I can't get media info for the recording I am having a network issue with my pc but I will include it as soon as I can.

media info second recording

http://pastebin.ca/1878790


Craig

1st recoding used chd, second ffmpeg.

*ERR*:/Users/davilla/Documents/crystalhd-for-osx/trunk/crystalhd/driver/darwin/crystalhd_hw.c:2251: Insufficient resources

memleak issue. known problem.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Post Reply