[DEPRECIATED] XBMC Subtitles - Addon Script (previously OpenSubtitles OSD)

  Thread Rating:
  • 7 Votes - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #16
frater Wrote:I think you fixed a bug I wasn't aware of.
What I meant was that "bierdopje" doesn't work for movies. Only for TV-shows. Well, that's what it says when you lookup a movie.

Am I mistaken by thinking it's a message from your script?

If you know it doesn't work for movies and only for TV-shows, why are you showing it in "Movies"?
But hey... it's only a minor issue.....

to keep the main part of the script simple and easy for future service additions, we do not filter services. if the service doesnt support the video you are looking for it will just display the warning and you can always use other services in the list, or disable the unwanted service altogether.


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find
CosyCat Offline
Senior Member
Posts: 263
Joined: Mar 2005
Reputation: 0
Location: Sweden
Post: #17
31042 and settings I set.. not saved.

[Image: cosycat.gif]
find
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #18
CosyCat Wrote:31042 and settings I set.. not saved.

fixed, http://trac.xbmc.org/changeset/31062


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find
zipleen Offline
Junior Member
Posts: 12
Joined: Feb 2009
Reputation: 0
Post: #19
Great script! Trying with the latest xbmc build r31064.

Can you confirm podnapisi.net support is working correctly? Because with the other services subtitles appear in the search, but it doesnt find any results in podnasipi (and there are, because i searched in the website and they have the subtitle).

How can i help debug this problem?

XBMC-svn on Q8800 / 8600GT / Gentoo Linux / vdpau (main tv/hdmi/spdif) || XBMC on Q8600 / 9600GT / Mac x86 (brother's bedroom) || XBMC on iMac ppc / ATI (kitchen) || XBMC on Xbox 1.1 (bedroom) || XBMC (live) on Acer Revo 3600 (another bedroom)
find
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #20
zipleen Wrote:Great script! Trying with the latest xbmc build r31064.

Can you confirm podnapisi.net support is working correctly? Because with the other services subtitles appear in the search, but it doesnt find any results in podnasipi (and there are, because i searched in the website and they have the subtitle).

How can i help debug this problem?

podnapisi works for me, please post the debug log. my signature has how-to


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find
zipleen Offline
Junior Member
Posts: 12
Joined: Feb 2009
Reputation: 0
Post: #21
Amet Wrote:podnapisi works for me, please post the debug log. my signature has how-to

Code:
DEBUG: Alloc resources: 8.18ms (5.18 ms skin load)
00:52:23 T:2819611504 M:2196070400  NOTICE: Regex File Se: 02, Ep: 02,
00:52:23 T:2819611504 M:2195308544   DEBUG: Manual Search : [True]
                                            Default Service : [Podnapisi]
                                            Services : ['Podnapisi', 'Sublight', 'OpenSubtitles']
                                            Temp?: [False]
                                            File Path: [/home/torrents/Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
                                            Year: []
                                            Tv Show Title: [Royal Pains]
                                            Tv Show Season: [2]
                                            Tv Show Episode: [2]
                                            Movie/Episode Title: [Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
                                            Subtitle Folder: [/home/torrents]
                                            Languages: [Portuguese] [PortugueseBrazil] [English]
                                            Parent Folder Search: [False]
00:52:23 T:3029358448 M:2196578304   DEBUG: ------ Window Deinit (VideoOSD.xml) ------
00:52:23 T:2819611504 M:2196324352   DEBUG: File Size [367078898]
                                            File Hash [0659584149b5097a]
00:52:23 T:2819611504 M:2196324352   DEBUG: Search by hash_pod [Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
00:52:23 T:2819611504 M:2196324352   DEBUG: Languages : [['32', '48', '2']]
                                            Hash : [['0659584149b5097a']]
00:52:24 T:2819611504 M:2195668992   DEBUG: Filter : [{'status': 200, 'search_restrict': True, 'search_langs': ['32', '48', '2']}]
                                            Auth : [{'status': 200, 'search_restrict': False, 'search_langs': []}]
00:52:25 T:2819611504 M:2196176896   DEBUG: Search by name_pod [Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
00:52:25 T:2819611504 M:2196176896   DEBUG: http://www.podnapisi.net/ppodnapisi/search?tbsl=1&sK=Royal+Pains&sJ=32&sY=&sTS=2&sTE=2&sXML=1
                                            Searching subtitles by name_pod [Royal+Pains]
00:52:33 T:3029358448 M:2196086784   DEBUG: LIRC: Update - NEW at 2351404:000B 00 enter SonyBDRemote (enter)
00:52:33 T:3029358448 M:2196086784   DEBUG: OnKey: 11 pressed, action is Select
00:52:33 T:2819611504 M:2195324928   DEBUG: In 'On click' selected : [OpenSubtitles]
00:52:34 T:2819611504 M:2195324928   DEBUG: OpenSubtitles Search String [ Royal+Pains+S02E02 ]
00:52:34 T:2819611504 M:2195324928   DEBUG: File Size [367078898]
                                            File Hash [0659584149b5097a]
00:52:34 T:2819611504 M:2195324928   DEBUG: Search by hash and name Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi
00:52:42 T:2819611504 M:2196869120   DEBUG: Token:[lu2lq08c0s7dkra61erfk4eot4]
00:52:50 T:3029358448 M:2197856256   DEBUG: LIRC: Update - NEW at 2367521:0056 00 down SonyBDRemote (down)
00:52:50 T:3029358448 M:2197856256   DEBUG: OnKey: 167 pressed, action is Down
00:52:51 T:3029358448 M:2197282816   DEBUG: LIRC: Update - NEW at 2369065:000B 00 enter SonyBDRemote (enter)
00:52:51 T:3029358448 M:2197282816   DEBUG: OnKey: 11 pressed, action is Select
00:52:51 T:2819611504 M:2197282816   DEBUG: In 'On click' selected : [Podnapisi]
00:52:51 T:2819611504 M:2197282816   DEBUG: File Size [367078898]
                                            File Hash [0659584149b5097a]
00:52:51 T:2819611504 M:2197282816   DEBUG: Search by hash_pod [Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
00:52:51 T:2819611504 M:2197282816   DEBUG: Languages : [['32', '48', '2']]
                                            Hash : [['0659584149b5097a']]
00:52:52 T:2819611504 M:2196885504   DEBUG: Filter : [{'status': 200, 'search_restrict': True, 'search_langs': ['32', '48', '2']}]
                                            Auth : [{'status': 200, 'search_restrict': False, 'search_langs': []}]
00:52:53 T:2819611504 M:2196885504   DEBUG: Search by name_pod [Royal.Pains.S02E02.Lovesick.HDTV.XviD-FQM.avi]
00:52:53 T:2819611504 M:2196885504   DEBUG: http://www.podnapisi.net/ppodnapisi/search?tbsl=1&sK=Royal+Pains&sJ=32&sY=&sTS=2&sTE=2&sXML=1
                                            Searching subtitles by name_pod [Royal+Pains]

the code looks good, but the search url returns empty results. maybe its someing with my languages.. i dont really know about the url query of podnapisi i only saw that site in your acript 30 minutes ago Tongue)

or maybe its someing stupid i'm doing Frown

XBMC-svn on Q8800 / 8600GT / Gentoo Linux / vdpau (main tv/hdmi/spdif) || XBMC on Q8600 / 9600GT / Mac x86 (brother's bedroom) || XBMC on iMac ppc / ATI (kitchen) || XBMC on Xbox 1.1 (bedroom) || XBMC (live) on Acer Revo 3600 (another bedroom)
find
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #22
zipleen Wrote:the code looks good, but the search url returns empty results. maybe its someing with my languages.. i dont really know about the url query of podnapisi i only saw that site in your acript 30 minutes ago Tongue)

or maybe its someing stupid i'm doing Frown

you are not doing anything wrong that I can see, apart from pasting the debug in forum Smile

http://www.podnapisi.net/ppodnapisi/sear...E=2&sXML=1 returns no results, thats all

here is what I get,

[Image: RP.jpg]


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
(This post was last modified: 2010-06-13 08:34 by amet.)
find
zipleen Offline
Junior Member
Posts: 12
Joined: Feb 2009
Reputation: 0
Post: #23
Amet Wrote:you are not doing anything wrong that I can see, apart from pasting the debug in forum Smile

http://www.podnapisi.net/ppodnapisi/sear...E=2&sXML=1 returns no results, thats all

here is what I get,

oops sorry, pastebin right?

the url does not get me any results because the sJ=32 is portuguese and it doesn't have any subtitles for pt. but my second choice is pt-BR witch has sJ=48 but i dont see any request for that url. shoulnd't it search for the 3 languages?
changing my preferences to pt-br as my first choice, it still doesnt return any matches but the url now returns one match: http://www.podnapisi.net/ppodnapisi/sear...E=2&sXML=1

debug log
http://pastebin.com/4jXDtEGD

maybe it's something wrong with my python modules/libraries :/

XBMC-svn on Q8800 / 8600GT / Gentoo Linux / vdpau (main tv/hdmi/spdif) || XBMC on Q8600 / 9600GT / Mac x86 (brother's bedroom) || XBMC on iMac ppc / ATI (kitchen) || XBMC on Xbox 1.1 (bedroom) || XBMC (live) on Acer Revo 3600 (another bedroom)
find
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #24
zipleen Wrote:oops sorry, pastebin right?

hehe, Smile

zipleen Wrote:the url does not get me any results because the sJ=32 is portuguese and it doesn't have any subtitles for pt. but my second choice is pt-BR witch has sJ=48 but i dont see any request for that url. shoulnd't it search for the 3 languages?
changing my preferences to pt-br as my first choice, it still doesnt return any matches but the url now returns one match: http://www.podnapisi.net/ppodnapisi/sear...E=2&sXML=1

debug log
http://pastebin.com/4jXDtEGD

maybe it's something wrong with my python modules/libraries :/

strange, post the whole log please, it helps with the XBMC rev and has a lot of useful info in it.

EDIT: it only lists first language url, I will fix that in the next rev


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
(This post was last modified: 2010-06-13 10:05 by amet.)
find
zipleen Offline
Junior Member
Posts: 12
Joined: Feb 2009
Reputation: 0
Post: #25
Amet Wrote:hehe, Smile



strange, post the whole log please, it helps with the XBMC rev and has a lot of useful info in it.

EDIT: it only lists first language url, I will fix that in the next rev

cool, tks!
full debug log: http://pastebin.com/dJPaymq0

in the debug:
opensubtitles works and i got results, podnapisi.net doesn't

XBMC-svn on Q8800 / 8600GT / Gentoo Linux / vdpau (main tv/hdmi/spdif) || XBMC on Q8600 / 9600GT / Mac x86 (brother's bedroom) || XBMC on iMac ppc / ATI (kitchen) || XBMC on Xbox 1.1 (bedroom) || XBMC (live) on Acer Revo 3600 (another bedroom)
find
mr_blobby Offline
Skilled Python Coder
Posts: 111
Joined: Mar 2010
Reputation: 0
Post: #26
Subscene.com support has been added to the new version of the script (v.1.7.3). Smile
find
frater Offline
Fan
Posts: 312
Joined: Jan 2005
Reputation: 0
Post: #27
mr_blobby Wrote:Subscene.com support has been added to the new version of the script (v.1.7.3). Smile

It is getting better all the time ;-)
Auto-update works as a charm....
I hope some more can be added and when uploading is realized in the future it will mean subtitles are added together with their framerate....
find
adsoto Offline
Senior Member
Posts: 133
Joined: Sep 2009
Reputation: 0
Location: Spain
Post: #28
mr_blobby Wrote:Subscene.com support has been added to the new version of the script (v.1.7.3). Smile

I am still running the old OpenSubtitles until there's a official release of a new XBMC but I thank you for the effort.
XBMC subtitles it's a wonderful addition to have and subscene.com it's one of my favourite places to get subs.
I hope the new version gets past the problems of hanging when you run it several times in the same XBMC session.

XBMC on Win 7 Professional (32 bit)
Intel E7300
Gigabyte GA-E7AUM-DS2H board
Nvidia 9400 chipset
4GB RAM
Pioneer 436 XDE Plasma TV
Yamaha YSP-1000 Digital Sound Projector
find
amet Offline
How do ya like them apples?
Posts: 4,085
Joined: Jul 2009
Reputation: 39
Location: Novi Sad / Dubai
Post: #29
adsoto Wrote:I hope the new version gets past the problems of hanging when you run it several times in the same XBMC session.

That was XBMC issue and has been resolved in the trunk. You can try official nightly builds and see how that works for you.


Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find
Riderzzz Offline
Senior Member
Posts: 206
Joined: Sep 2007
Reputation: 1
Location: DK
Post: #30
I've got some problems with the new subtitle script.

I search subs and select them, but when he tries to resume the movie it quits xbmc. Without an error but just the apple-logo (running on ATV)

Im running on the last build (15 june) and the newest subs scipt (15 june)

here is the xbmc.log
http://pastebin.com/8Gv5tNya

sometime it happens too when i try to fire up the script.

if i can give more info, please tell me what to give Smile
find
Thread Closed