CouchPotato - Automatic Movie Downloader via NZB & Torrents

  Thread Rating:
  • 11 Votes - 4.55 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Pr.Sinister Offline
Fan
Posts: 659
Joined: Sep 2007
Reputation: 14
Location: Montreal, Canada
Post: #31
RuudBurger Wrote:I'll look into the alternative/foreign movie titles. It uses the MovieDB as default btw, I'll check out if they have an alternative title list or something..

Adding a movie does a "force search" for that specific movie, so forcing a search just after adding it isn't necessary..
Platoon 1080p does download here. Did you configure your SABnzbd connection correctly? Check the log file.

Thanks for the feedback!

edit:
Tried adding RoboGeisha (720p), which is found just fine. Any other movies that don't work for you?


Like i said, where is the log file?

Everything is configured properly... I am running MovieManager on a different
machine than SABNzbd because stupid pywin won't install on my main machine
since it can't find python even though it's installed...

------------------------------------------
[4 XBMC Clients + 3 Norco RPC-4224 Media Servers w/74 TB HDD Space]
If my post helped, thank me by adding to my reputation! :)
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #32
Logfile should be in the same dir. But there isnt any if you installed it as a WindowsService.
Try running it with "/path/to/python/paster.exe serve --log-file moviemanager.log --reload config.ini" assuming you're using Windows on the other machine
find quote
compcentral Offline
Fan
Posts: 626
Joined: Apr 2010
Reputation: 2
Post: #33
finally what I've been looking for! can't wait to give it a try.
find quote
Pr.Sinister Offline
Fan
Posts: 659
Joined: Sep 2007
Reputation: 14
Location: Montreal, Canada
Post: #34
RuudBurger Wrote:Logfile should be in the same dir. But there isnt any if you installed it as a WindowsService.
Try running it with "/path/to/python/paster.exe serve --log-file moviemanager.log --reload config.ini" assuming you're using Windows on the other machine

Ya it is installed as a WindowsService.

I stopped the service, ran it like you said and it found the movies right away...

Maybe i needed to restart after filling out the config...

-Pr.

------------------------------------------
[4 XBMC Clients + 3 Norco RPC-4224 Media Servers w/74 TB HDD Space]
If my post helped, thank me by adding to my reputation! :)
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #35
The WindowsService doesnt call the script with the --reload comment.. so I think you are right. Stupid me Wink

I'll try and rework the script and see if a can reload the config stuff in another way.. --reload is for developing only, so I'm using it in a bad way.
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #36
Latest version contains:
a better logger (should work for WindowsService).
Trailer downloading
User defined search interval


Edit:
I want to create an .nfo file at the renaming process. This file will include ONLY an imdb-url.
As described on the wiki page:
Quote:will parse it for a direct URL to the scraper info page
Any idea's on this? I don't know how all the nfo-Media Manager handle this..
(This post was last modified: 2010-06-26 17:14 by RuudBurger.)
find quote
chalk4 Offline
Junior Member
Posts: 21
Joined: Jun 2010
Reputation: 0
Post: #37
I have installed Movie-Manger and I think the concept is great! I am running into a few problems that i am hoping you can clear up.

1) under config for nzbs.org for the key and id... is this meant to be found under User specific feeds ??

2) i am unable to install the IMDB user script. I keep getting an error 'document' is undefined

Also.. i am not showing anything in my log file. I downloaded the latest version this morning.


Thanks for the help.
(This post was last modified: 2010-06-26 17:15 by chalk4.)
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #38
Key and id can be found here (after login):
[Image: content]

For the userscript i'm assuming you're using a recent version of Chrome or the Firefox GreaseMonkey addon? Do you get the error on "install" or on imdb.com?
find quote
chalk4 Offline
Junior Member
Posts: 21
Joined: Jun 2010
Reputation: 0
Post: #39
ok i got the proper ID and Key in the config file. Thanks!

I also got the script working.. i was using IE.. i changed over to chrome and it worked fine. Movie Manager is still not showing anything in the log file and it just sits "Now Checking" mode when i added a movie.

thoughts?
find quote
ECEC Offline
Fan
Posts: 374
Joined: Sep 2007
Reputation: 0
Post: #40
This is going to be awesome! Smile I'm trying to get it setup and running into a few issues/questions that hopefully you can help me out on:

- I want to let SAB handle my movie renaming, but I want to use this for trailer downloading. Is that supported?
- I've got everything up and running, but when I add a movie and go to search, nothing happens. I checked the log file and it's blank. If I go to the logs via MovieManger itself, I receive an internal server error.

This is the latest version downloaded from git, on a Windows Home Server. I followed the directions on the git page to install it as a service and have restarted the service after making config changes as well as after adding the movie.
find quote
chalk4 Offline
Junior Member
Posts: 21
Joined: Jun 2010
Reputation: 0
Post: #41
ECEC... i am stuck at the exact same point. I followed the instructions on GIT.. but when i add a movie it just sits at the "now checking" and never downloads anything.

I am using SAB and Movie Manager on a single win xp machine.
find quote
xeonicxpression Offline
Senior Member
Posts: 236
Joined: May 2008
Reputation: 0
Post: #42
ECEC Wrote:- I want to let SAB handle my movie renaming, but I want to use this for trailer downloading. Is that supported?

I was thinking the same thing. SABNZBd does movie renaming just fine. I would love for NZBMM to take care of downloading the trailer though. I hacked together a small python program that does it for me using trailer addicts, but it only got about 300/500 of my moviesNo.
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #43
Latest update should fix the WindowsService and empty log file problem.
Do a "WindowsService.py stop", "WindowsService.py update", "WindowsService.py start" to update Wink


For the trailers, I was thinking of making an "find missing trailers"-button. It fetches the trailers from Youtube though, so for the lesser known movies, it isn't that accurate.
(This post was last modified: 2010-06-27 21:08 by RuudBurger.)
find quote
chalk4 Offline
Junior Member
Posts: 21
Joined: Jun 2010
Reputation: 0
Post: #44
Can you shed any light on this error in the log file?

error: [Errno 10054] An existing connection was forcibly closed by the remote host

thanks
find quote
RuudBurger Offline
CouchPotato Author
Posts: 401
Joined: Jun 2010
Reputation: 13
Post: #45
Have no idea.. can you still access the app after that error?
find quote
Post Reply