White screen (disable flash hardware 3D acceleration)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
lmxu Offline
Junior Member
Posts: 3
Joined: Jun 2010
Reputation: 0
Post: #1
Hello All,

Newbies here.

I tried to play videos (avi, flv, etc) in XBMC, a white screen comes up, but with audio. This is the exact same behavior when I try to view flash videos in the browser and do full screen (white screen with audio as well)

Normally, in the browser, I have to unclick "3D Hardware acceleration" in order for the flash videos to display full screen.

But I can't seem to do that in XBMC with right click to have the flash setting come up. How do I configure it so that 3D hardware acceleration is disabled?


Thanks
find quote
SlaveUnit Offline
Posting Freak
Posts: 1,736
Joined: Oct 2008
Reputation: 14
Location: San Diego
Post: #2
Some system info would be nice. What video card do you have?

Main - Intel E6750 C2D (2.66ghz)/Geforce 240
Bedroom - Intel E3300 C2D (2.5ghz)/Geforce 210
Guest Bedroom - Acer Revo 1600/ION LE
Test Desktop - Intel Q9300 C2Q (2.5ghz)/Geforce 9600 GSO
find quote
lmxu Offline
Junior Member
Posts: 3
Joined: Jun 2010
Reputation: 0
Post: #3
I forgot. It was a real old one I bought back in 2003? (Maxtor I think). CPU AMD XP 2100. Does not support hardware acceleration 4 sure.

It's just that I took a look at the XBMC log and it seems like XBMC is falling back to Flash (even the white screen looks exactly like when flash is in full screen mode) and I know for a fact that flash does not work in full screen with 3D hardware acceleration on my PC.

Just curious if I can turn off that switch..... or I'll have to get XBMC to launch my KMPlayer, maybe that's a better route? Since KMPlayer plays everything nice and smooth on my pc.

Thanks
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #4
Your gpu doesn't support pixel shaders 2.0, has nothing to do with flash.
find quote
lmxu Offline
Junior Member
Posts: 3
Joined: Jun 2010
Reputation: 0
Post: #5
Thanks Bob. I guess that log confused me a bit.

Anyway, I'll have to configure KMPlayer to play them then.

Thanks.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,236
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #6
lmxu Wrote:Anyway, I'll have to configure KMPlayer to play them then.

Or use an OpenGL build of XBMC instead.

JR
find quote
CrystalP Offline
Team-XBMC Developer
Posts: 822
Joined: Apr 2010
Reputation: 18
Location: The Great North
Post: #7
Install the latest DirectX runtime of Microsoft and graphics card drivers first. If that doesn't help, your card it too old for XBMC.

Always read the XBMC online-manual, FAQ, Wiki and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote