No resume form standby with vista remote after 2.6.32-23 #37 Kernel version

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
taliz Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #196
Just wanted to say that for me it was "US15" that was my MCE remote. Most seem to point at USB0 etc, but that doesn't work for everyone..
And it was on usb device 4-1, so what I ended up with in /etc/rc.local was this:

echo US15 > /proc/acpi/wakeup
echo enabled > /sys/bus/usb/devices/4-1/power/wakeup

I found the 4-1 by running "dmesg |grep mceusb", and US15 I found by simply enabling everything in /proc/acpi/wakup and working my way down by disabling device by device until suspend stopped working.

This makes my Zotac ION machine wake up from suspend if I press the power button on my MCE remote(sometimes I need to press it twice though).
BTW I'm running Ubuntu 11.10 and XBMC 11 Eden Beta 1.
(This post was last modified: 2012-01-21 00:22 by taliz.)
find quote
InsaneNutter Offline
Junior Member
Posts: 28
Joined: Sep 2008
Reputation: 0
Post: #197
This worked for me on XBMC 11.0 - Eden (XBMCbuntu) with the Microsoft Windows Media Remote running on an Acer Aspire Revo R3600

The nettop will now wake up from sleep perfectly after following the instructions below:

(2010-11-30 19:15)Shadow_Mx Wrote:  I got resume from standby to work with Maverick and latest linux kernel by doing this:

dmesg | grep mceusb
Code:
[   17.403131] mceusb [b]2-5[/b]:1.0: Registered Philips eHome Infrared Transceiver on usb3:2

Take note of:
mceusb 2-5

cat /proc/bus/input/devices

And look for your the entry with your remote information:

Code:
I: Bus=0003 Vendor=15c2 Product=0038 Version=0001
N: Name="iMON Remote (15c2:0038)"
P: Phys=usb-0000:00:0b.0-6/input0
S: Sysfs=/devices/pci0000:00/0000:00:0b.0/usb2/2-5/2-6:1.0/rc/rc0/input5
U: Uniq=
H: Handlers=kbd mouse1 [b]event5[/b]
B: EV=100007
B: KEY=fff 0 0 400000 108c0320 2d50082 0 0 30000 4 119000 4196 14100801 809e1680 0 2000000 10004002
B: REL=103

Take note of:
Handlers= ... event5

Then do
sudo dpkg-reconfigure lirc

And select:
Linux input layer (/dev/input/event5) << replace #
IR transmitter select "none"

Reboot, and run:
sudo dpkg-reconfigure lirc
Select the proper remote again (MCE remote in my case)

And last, I edited my /etc/rc.local to include:
echo "USB0" > /proc/acpi/wakeup
echo "SMB0" > /proc/acpi/wakeup
echo enabled > /sys/bus/usb/devices/2-5/power/wakeup

Just replace my 2-5 with your set up.

For me:

mceusb2-4
Handlers= event2

Thanks a lot Shadow_Mx Smile

XBMC user since 2004, My XBMC devices:

Main: (2010 - Present) - Acer Aspire Revo R3600 - Running 11.0 Eden (XBMCbuntu)
Secondary: (2012 - present) - 2x Apple TV 2's - Running 11.0 Eden
Old: (2004-2009) - Xbox with Xecuter X3 Modchip + LCD Screen, Running 8.10 Atlantis

Storage: 8TB NAS - Served by a HP ProLiant MicroServer
(This post was last modified: 2012-03-25 03:58 by InsaneNutter.)
find quote
sibeer Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #198
(2010-11-30 19:15)Shadow_Mx Wrote:  Then do
sudo dpkg-reconfigure lirc

And select:
Linux input layer (/dev/input/event5) << replace #
IR transmitter select "none"

Reboot, and run:
sudo dpkg-reconfigure lirc
Select the proper remote again (MCE remote in my case)

And last, I edited my /etc/rc.local to include:
echo "USB0" > /proc/acpi/wakeup
echo "SMB0" > /proc/acpi/wakeup
echo enabled > /sys/bus/usb/devices/2-5/power/wakeup

Just replace my 2-5 with your set up.

Great to find a thread with a solution to my problem (Thanks Shadow_Mx)

Unfortunately I am very lacking in knowledge in these things and am struggling with the advice.

When I run:

sudo dpkg-reconfigure lirc

Under the first page "Configuring lirc" the closest option for Remote Control Configuration is

Linux input layer (/dev/input/eventX)

How do you input your own event name into this?
(This post was last modified: 2012-03-29 18:24 by sibeer.)
find quote
sibeer Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #199
Uh oh, pressed enter on:

"Linux input layer (/dev/input/eventX)"

Then escaped keyed my way out. Now the remote does nothing at all, USB keyboard works fine though.
(This post was last modified: 2012-03-29 18:58 by sibeer.)
find quote
sibeer Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #200
Any help is much appreciated, no resume from standby was annoying but no remote is a real killer.
find quote
pezlin Offline
Junior Member
Posts: 37
Joined: Oct 2009
Reputation: 1
Post: #201
(2012-04-03 18:48)sibeer Wrote:  Any help is much appreciated, no resume from standby was annoying but no remote is a real killer.

I think you can just continue with the following that Shadow_Mx wrote:
Reboot, and run:
sudo dpkg-reconfigure lirc
Select the proper remote again (MCE remote in my case)

And last, I edited my /etc/rc.local to include:
echo "USB0" > /proc/acpi/wakeup
echo "SMB0" > /proc/acpi/wakeup
echo enabled > /sys/bus/usb/devices/2-5/power/wakeup

Just replace my 2-5 with your set up.
find quote
sibeer Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #202
Tried that with no joy when first killed it, though may have done it wrong. Will have another go when I get home from work.
find quote
nick999 Offline
Junior Member
Posts: 18
Joined: Aug 2007
Reputation: 0
Post: #203
Worked for me, many thanks.
find quote
tripkip Offline
Fan
Posts: 422
Joined: Aug 2010
Reputation: 2
Location: Belgium
Post: #204
I found this and it worked for me:
http://geekparadise.de/2012/01/usb-wakeu...ktivieren/

[Image: all-thin-banner.jpg]


find quote
Post Reply