[RELEASE] cdART Manager Script

  Thread Rating:
  • 6 Votes - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
gibxxi Offline
Fan
Posts: 364
Joined: Oct 2011
Reputation: 4
Post: #1996
(2014-04-03 00:25)bolter Wrote:  
(2014-04-02 20:51)gibxxi Wrote:  
(2014-04-02 10:39)bolter Wrote:  If I have added some cdart to my music collection, how do I get CDart manager to add them to its list. Every time I update CDart manager, all it wants to do is go off to fanart.TV and see if there are any new artwork. It doesn't want to grab any of the local stuff. I've created them via "Gimp" software and called them cdart.PNG but the addon doesn't add them.

Edit: have just change over to Gotham beta 3 and noticed that I can not see any cdART in the add on any more. I can see logos, thumbnails etc. But no CDs. Don't know if it was like this before updating to beta 3. Have just spent 3 hours updating the database but still no CD art. I can see the name of the album, but no artwork.

If your on Windows and using NFS, then your art may not be appearing due to a bug with NFS library bundled with XBMC. It only fails for Windows users who have shares accessed over NFS. If this isn't your scenartio, ignore this post.

Thanks for the reply, but I'm using SMB for my transfer

AFAIK cdART Manager will only display a list of arts it downloaded, not manually added ones (I could be wrong on this, but I have witnessed the same issue). BUT, as long as the cdart.png files are in the folder with their respective album, or for other artwork, in the "additional artwork" folder (as defined for fanart, clearlogos, thumbnails, etc) it should work in so far as your skin is concerned. You may want to create a seperate backup of your custom files, or maybe try copying them to the cdART "backup" folder as well, using the naming scheme cdART manager already uses. As this is a 'Backup' and should work on fresh installs too, doing a restore may see the custom files then be listed by cdART manager. Worth a shot at any rate.

[Image: all-thin-fanart@2x.jpg]
DT: Intel Core-i7 - 4770K / Nvidia GTX-770 | HTPC: Athlon X2 4850e / AMD Radeon 4670
TV: Sony KDL-40EX524 | AVR: Onkyo TX-NR515 | SPK: 2x Pioneer CS-7070 / 3x Tannoy F1 Custom
find quote
bottom Offline
Junior Member
Posts: 5
Joined: Mar 2014
Reputation: 0
Post: #1997
I'm still in need for help with my problem... any ideas?
bottom

(2014-04-16 13:20)bottom Wrote:  Im having trouble running the script with the amber skin. With confluence its working totally fine, but with cofluence the scripts gui doesnt open up - seems to be some kind of skin related issue.
Reinstalling (+ removing all files) did not resolve the problem...
Starting the script (with amber) produces the following errors in the log file:
Code:
13:00:56 T:2734683200   ERROR: EXCEPTION: XML File for Window is missing
13:00:56 T:2734683200   ERROR: Traceback (most recent call last):
13:00:56 T:2734683200   ERROR:   File "/home/pi/.xbmc/addons/script.cdartmanager/default.py", line 535, in <module>
13:00:56 T:2734683200   ERROR:     ui = gui.GUI( "script-cdartmanager.xml" , __addon__.getAddonInfo('path'), "Default")
13:00:56 T:2734683200   ERROR: RuntimeError: XML File for Window is missing
In case its needed: here are the complete logs:
normal log: http://pastebin.com/KSdpNYhk
debug log: http://pastebin.com/xtVkDynA

I would really appreciate any kind of help!
Greetings bottom
find quote
Post Reply