[RELEASE] iPhoto Plugin Addon for XBMC

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
erickatz Offline
Junior Member
Posts: 9
Joined: Nov 2011
Reputation: 0
Post: #196
(2012-11-10 21:05)jingai Wrote:  Have you tried images in a different album?

Does the path it is complaining about actually exist? Can you navigate to it in the Finder?

edit: What version of XBMC are you using, Eden or a Frodo nightly? And are you using the 2.0.0b4 version of my plugin, or 1.9.3?

I am running XBMC Eden, and I'm using the 2.0.0b4 version. I am a little unclear as to why you believe there are unicode characters in the filenames, there are not. The log file snippet I included only mentioned a single file name, all printable ASCII characters: Halloween '04/IMG_0467.JPG.
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #197
(2012-11-12 19:10)erickatz Wrote:  
(2012-11-10 21:05)jingai Wrote:  edit: What version of XBMC are you using, Eden or a Frodo nightly? And are you using the 2.0.0b4 version of my plugin, or 1.9.3?

I am running XBMC Eden, and I'm using the 2.0.0b4 version. I am a little unclear as to why you believe there are unicode characters in the filenames, there are not. The log file snippet I included only mentioned a single file name, all printable ASCII characters: Halloween '04/IMG_0467.JPG.

I don't think there are unicode characters in your file -- I just was testing your issue along with meso's at the same time.

Does this happen with all albums, or just this one? And does the path actually exist? Can you navigate to the path mentioned in the log using the Finder (or even better, cd to it in the Terminal if you wouldn't mind -- remember to wrap it in quotes to escape the spaces). Specifically, in Terminal, type this:

Code:
cd "/Volumes/Photo Album/2004/Halloween '04/IMG_0467.JPG"

Also, please try 2.0.0b5 and see if the issue persists.
find quote
erickatz Offline
Junior Member
Posts: 9
Joined: Nov 2011
Reputation: 0
Post: #198
Yes, the path actually exists, the built in photo viewer in XBMC works OK. One thing to note is that this is off of an NFS mount, if that makes a difference. Both the iPhoto library and the images are on NFS.
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #199
(2012-11-12 19:19)erickatz Wrote:  Yes, the path actually exists, the built in photo viewer in XBMC works OK. One thing to note is that this is off of an NFS mount, if that makes a difference. Both the iPhoto library and the images are on NFS.

Can you answer my other questions please?
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #200
2.0.0 is being released tomorrow. Last chance to let me know of any issues Smile
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #201
2.0.0 is being pushed up. It'll be available shortly.
find quote
Trexx Offline
Junior Member
Posts: 41
Joined: Sep 2010
Reputation: 0
Post: #202
Thanks for the great plugin. Once question is there a way to change a pictures orientation during playback? If I have pictures that are in portrait mode instead of landscape, how do I rotate them during display (or even in thumbnails)?

Thanks again for your help,
T.
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #203
Enable "Rotate pictures using EXIF information" in Pictures Settings if your photo editor stores such information and it will do it automatically.

You can rotate manually as well. This is a function of XBMC itself (not my plugin) and by default is mapped to either 'Enter' or 'r' while viewing a picture.
find quote
signal.quest Offline
Junior Member
Posts: 11
Joined: Feb 2013
Reputation: 0
Post: #204
Would it be possible to add support to playback HD video clips in the iphoto library via the plugin? Thanks for your hard work. :-)
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #205
I don't personally have videos in my iPhoto library, but I think this should just automagically work. Check the option to "Show video files in listings" in System->Pictures->File Lists.
find quote
signal.quest Offline
Junior Member
Posts: 11
Joined: Feb 2013
Reputation: 0
Post: #206
I have tried this previously and I only get a blank screen with no audio. Is there a log file I can check for errors? I am using ubuntu. Thanks again.
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #207
My plugin doesn't handle actual playback, so it's not likely that the issue is there. However, if you post a debug log I'll see if I can help you.
find quote
hidalgo_x Offline
Junior Member
Posts: 2
Joined: Feb 2013
Reputation: 0
Post: #208
I like this add-on very much. But I’d like to change the default style of view in my albums. How can I have all my albums to show up as thumbnails and not have to change the view in every album itself by hand?
find quote
jingai Offline
Skilled Skinner
Posts: 1,071
Joined: Mar 2010
Reputation: 12
Post: #209
(2013-02-09 16:00)hidalgo_x Wrote:  I like this add-on very much. But I’d like to change the default style of view in my albums. How can I have all my albums to show up as thumbnails and not have to change the view in every album itself by hand?

XBMC doesn't provide a good way for addons to force or suggest certain view types, unfortunately; however, I did provide a workaround in the addon's configuration to force views, but it only works for select skins (currently, Confluence and Metropolis).

If you use either of those skins, go into the addon configuration and set the view there.
find quote
signal.quest Offline
Junior Member
Posts: 11
Joined: Feb 2013
Reputation: 0
Post: #210
I can view video clips fine. But I have a problem viewing pictures:

ERROR: CGUIWindowSlideShow::RenderErrorMessage - cant get label control!

It seems I only have this problem with pictures in the landscape orientation. This is 99% of my pictures. Please help if possible. Thanks.

I also get this message for multiple files:

ERROR: Texture manager unable to load file: /mnt/pics/iPhoto Library//Masters/2013/02/28/20130228-044730/DSC01712.JPG
find quote
Post Reply