[RELEASE] iPhoto Plugin Addon for XBMC

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #331
Yes, you can point the add-on at your NAS if your iPhoto Library is stored there.
find quote
Perlbo Offline
Junior Member
Posts: 12
Joined: Nov 2013
Reputation: 0
Post: #332
Hi ... how can i reset Plugin config / imported library info ? Tested a lot and it seems there are some link to old iphoto library. Now i want to reset all (plugin only) and import right iphoto library (managed by iphoto) again. Deinstallation of the plugin seem not delete all of plugin config
(This post was last modified: 2014-04-11 13:06 by Perlbo.)
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #333
Hi,
are Xmbc 12.3 + Mavericks 10.9.2 + iphoto 9.5.1 + iphoto plugin 2.1.10 compatible?
(This post was last modified: 2014-05-02 00:29 by fabutch.)
find quote
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #334
Yes, it has worked fine for me. Are you having a problem?
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #335
Yes, it doesn't work for me.
I'm an xmbc noob.

The structure of iphoto is imported (albums, faces...) but no photo displayed (black screens)
Thanks
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #336
Here is my log :
https://www.mediafire.com/?gc373a7ud4b1bbx

Thanks
find quote
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #337
The relevant error is:

Code:
ERROR: Error loading the current image 0: /Users/fabien/Pictures//Masters/2004/4 juil_2. 04/IMG_4640.JPG

First thing to check is to see if you can navigate to that file in Finder and open it in Preview or something. Make sure the path is exactly as shown. To be absolutely certain it exists, you can type this in Terminal:

Code:
cd "/Users/fabien/Pictures//Masters/2004/4 juil_2. 04"

If the file does not exist, there is likely a problem in the iPhoto add-on's configuration. Is your library managed or unmanaged?

If the file exists, unfortunately I don't know what's going on with XBMC. The actual process of displaying the images is a function of XBMC itself, so you'd need to ask in the XBMC support forum.
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #338
In the terminal if I type :
cd "/Users/fabien/Pictures//Masters/2004/4 juil_2. 04"
I get :
-bash: cd: /Users/fabien/Pictures//Masters/2004/4 juil_2. 04: No such file or directory

My iphoto library is managed.

In the plugin configuration :
If the path to iphoto is "/users/fabien/pictures", the structure of iphoto is imported (albums, faces...) but no photo displayed (black screens).
If the path to iphoto is "/users/fabien/pictures/bibliotheque iphoto/", I get "library import failed"
find quote
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #339
For some reason, it's detecting your library as Aperture. Is this library shared between Aperture and iPhoto?

edit: and really, "/users/fabien/pictures/bibliotheque iphoto/" should be the correct path. "/users/fabien/pictures" really shouldn't work at all, or.. hmm, I forget how I handled it, but it's possibly picking the default location; in which case, it could be importing your Aperture library, if you even have one.

Either way -- point the addon at "/Users/fabien/Pictures/Bibliothèque iPhoto" and re-try the import. Then send me the log file.
(This post was last modified: 2014-05-06 19:12 by jingai.)
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #340
I have Aperture but never launched it. So no library shared between Aperture and Iphoto.

I've point the add-on to "/Users/fabien/Pictures/Bibliothèque iPhoto", library import failed as usual.

There are 2 iphoto library in "Bibliothèque iPhoto". Is that bad for the add-on ?

I've sent the links (xmbc log + screenshot finder) with private message. Thanks.
find quote
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #341
What do you mean you have two libraries in Bibliothèque iPhoto? iPhoto handles switching of libraries, but I'm pretty sure you can't have two in the same directory like that?

edit: Nevermind. Found the problem -- it's the è in the pathname. Can you try renaming the folder to "Bibliotheque iPhoto"? Then point the add-on at the new path and try to import again.

If this works for you, you can hold Option while loading iPhoto and tell it to use the newly-named folder too. I'll look into getting it fixed in the add-on, but this will likely at least get it to work for you for now.
(This post was last modified: 2014-05-06 20:34 by jingai.)
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #342
Yeahhhhh! The "è" was the troublemaker!

Everything works now, thank you very much!
find quote
jingai Offline
Skilled Skinner
Posts: 1,072
Joined: Mar 2010
Reputation: 12
Post: #343
No problem. It's hard for me to test all of the unicode stuff since I am only an English speaker Smile But I will look into this more when I get the chance.

Sorry it took so long to sort out -- have just been really busy at work.
find quote
fabutch Offline
Junior Member
Posts: 9
Joined: Apr 2014
Reputation: 0
Post: #344
No problem at all Wink
thanks for the great support Smile
find quote
enzuccio1110 Offline
Junior Member
Posts: 1
Joined: Sep 2014
Reputation: 0
Thumbs Up  RE: [RELEASE] iPhoto Plugin Addon for XBMC
Post: #345
Good morning to everyone!sorry for the question but i'm new for xbmc
I bought a minix where is installed xbmc gotham and i'd like to see the photos that i have on my mac (i use iphoto) on xbmc:i installed the addon but i don't know how to configure it:can u help me step-by-step?
thanks to everyone!!
find quote
Post Reply