XBMC Freezes after s3 resume with rapier skin

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #1
Hi all,

I have a weird problem with the rapier skin, when I resume my asrock ion 330 from standby modus. It resumes like normal and I can do anything I want. But after about 5 minutes, the screen freezes completely and is not responsive anymore to the remote. The audio keeps on playing until the song is finished, and I can go to the normal console with ctrl+alt+f1

When I wait for about 15 minutes, the system returns as normal and is responsive again.

I don't have this problem with other skins, so this must be something in rapier. Anyone recognizes this and has a solution for this?
find quote
filigran Offline
Senior Member
Posts: 192
Joined: Oct 2009
Reputation: 0
Post: #2
Anything in the debug log?

Do you do anything special everytime it freezes? Hit a certain button, go into a certain section, play a certain song or movie etc.?

Have you tried removing the skin and reinstalling it? Tried removing/renaming the entire .xbmc folder in your homedir (shut xbmc down, open a console, mv ~/.xbmc ~/.xbmcold, start xbmc .. or do it through nautilus/kde's equiv., if you prefer that)?

Have you tried qualars mod, does it do the same?

What have you done..? Smile
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #3
Ok here is the following from the debug log from my last crash:

<seems that it's to long, so I'll add more replies with snippets of the log>


I tried qualars mod too, and this mod seems to be working without any problems.

I did not try to remove the skin and reinstall it completely. Also not renaming the xbmc folder. Thanks for those tips, I will try that.

Maybe you can make anything out of the debug log?
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #4
13:01:43 T:3077482384 M:1625219072 ERROR: DBus: org.freedesktop.DBus.Error.NoReply - Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
13:01:43 T:3077482384 M:1626193920 NOTICE: Resume: Running resume jobs
13:01:43 T:3077482384 M:1625939968 ERROR: GLX: Same window as before, refreshing context
13:01:43 T:3077482384 M:1625767936 ERROR: GLX: Same window as before, refreshing context
13:01:43 T:3077482384 M:1625767936 NOTICE: Resume: Restarting lirc
13:01:43 T:3077482384 M:1625767936 NOTICE: Resume: Restarting lcd
13:01:43 T:3077482384 M:1625767936 ERROR: XLCDproc::SetBackLight - Unable to write to socket
13:01:43 T:3077482384 M:1625767936 NOTICE: UpdateLibraries - Starting video library startup scan
13:01:43 T:3077482384 M:1625767936 ERROR: Control 402 in window 10133 has been asked to focus, but it can't
13:01:45 T:3048209264 M:1626877952 ERROR: GetDirectory - Error getting /htpc/misc/_movies/Growth 2009/
13:01:45 T:3048209264 M:1626877952 ERROR: GetDirectory - Error getting /htpc/misc/_movies/Ice Age 3/
13:01:45 T:3048209264 M:1626877952 ERROR: GetDirectory - Error getting /htpc/misc/_movies/Ice Age/
13:01:45 T:3077482384 M:1625354240 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/focus/english-movies-text-focus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/focus/English-movies-text-focus.png>
13:01:45 T:2894064496 M:1625354240 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/english-programs-text-nofocus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/English-programs-text-nofocus.png>
13:01:45 T:2894064496 M:1625354240 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/english-pictures-text-nofocus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/English-pictures-text-nofocus.png>
13:01:45 T:2794404720 M:1625354240 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/english-videos-text-nofocus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/English-videos-text-nofocus.png>
13:01:46 T:2894064496 M:1626447872 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/english-general-text-nofocus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/nofocus/English-general-text-nofocus.png>
13:01:46 T:3077482384 M:1626447872 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/images/homecategories/focus/english-tvshows-text-focus.png> instead of </home/nims/.xbmc/skin/Rapier/images/homecategories/focus/English-tvshows-text-focus.png>
13:01:49 T:3077482384 M:1626333184 ERROR: Texture manager unable to load file: special://skin/images/studios/.png
13:01:49 T:3048209264 M:1626206208 ERROR: GetDirectory - Error getting /htpc/movies/90210/
13:01:50 T:3048209264 M:1626210304 ERROR: GetDirectory - Error getting /htpc/movies/V 2009/
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E10.Flu.Fiction.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E11.MythBusters.Top.25.Moments.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E12.Car.Conundrum.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E13.Busters.Cut.Alcohol.Myths.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E14.HDTV.XviD-aAF.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E15.Busters.Cut.Knock.Your.Socks.Off.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E16.Busters.Cut.Viewer.Special.Threequel.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:54 T:3048209264 M:1617141760 ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode /htpc/series/Mythbusters/MythBusters.S08E17.Busters.Cut.Bottle.Bash.HDTV.XviD-FQM.avi online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.
13:01:55 T:3048209264 M:1617195008 ERROR: GetDirectory - Error getting /htpc/series/_movies/A.View.from.Space.with.Heavenly.Music.2006.1080p.HDDVD/
13:01:55 T:3048209264 M:1617104896 ERROR: GetDirectory - Error getting /htpc/series/_movies/I.Now.Pronounce.You.Chuck.and.Larry.2007.PROPER.1080p.BluRay.x264-aAF/
13:01:55 T:3048209264 M:1617104896 ERROR: GetDirectory - Error getting /htpc/series/_movies/Mary.and.Max.2009.DVDRip.XviD.TheWretched/
13:01:55 T:3048209264 M:1617104896 NOTICE: My Videos: Scanning for video info using worker thread, operation took 00:11
13:02:00 T:3077482384 M:1596727296 WARNING: GetLabel - Unknown nodetype requested 12
13:02:00 T:3077482384 M:1596846080 ERROR: Texture manager unable to load file: special://skin/images/studios/.png
13:02:00 T:3077482384 M:1596846080 ERROR: Texture manager unable to load file: special://skin/images/studios/.png
13:02:04 T:3077482384 M:1605804032 ERROR: DeleteFile - cant delete file </home/nims/.xbmc/userdata/Thumbnails/Video/f/ffffffff.tbn>. trying lower case </home/nims/.xbmc/userdata/thumbnails/video/f/ffffffff.tbn>
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #5
13:02:04 T:3077482384 M:1605804032 ERROR: Delete - Error deleting file /home/nims/.xbmc/userdata/Thumbnails/Video/f/ffffffff.tbn
13:02:04 T:3077482384 M:1605804032 ERROR: Delete - Error deleting file special://masterprofile/Thumbnails/Video/f/ffffffff.tbn
13:02:04 T:3077482384 M:1605857280 WARNING: GetLabel - Unknown nodetype requested 12
13:02:05 T:3077482384 M:1605423104 NOTICE: DVDPlayer: Opening: /htpc/movies/Desperate Housewives/Desperate.Housewives.S06E19.HDTV.XviD-NoTV.avi
13:02:05 T:3077482384 M:1605296128 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:02:05 T:2741062512 M:1605296128 NOTICE: Creating InputStream
13:02:05 T:2741062512 M:1605296128 NOTICE: Creating Demuxer
13:02:06 T:2741062512 M:1601597440 NOTICE: Opening video stream: 0 source: 256
13:02:06 T:2741062512 M:1601597440 NOTICE: Creating video codec with codec id: 13
13:02:06 T:2741062512 M:1601597440 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-4 part 2
13:02:06 T:2741062512 M:1601470464 NOTICE: Creating video thread
13:02:06 T:2741062512 M:1601470464 NOTICE: Opening audio stream: 1 source: 256
13:02:06 T:2741062512 M:1601470464 NOTICE: Finding audio codec for: 86017
13:02:06 T:2688613232 M:1601470464 NOTICE: running thread: video_thread
13:02:06 T:2741062512 M:1601470464 NOTICE: Creating audio thread
13:02:06 T:2678123376 M:1601470464 NOTICE: running thread: CDVDPlayerAudio::Process()
13:02:06 T:3077482384 M:1601470464 ERROR: XLCDproc::SetBackLight - Unable to write to socket
13:02:06 T:2678123376 M:1601757184 NOTICE: Creating audio device with codec id: 86017, channels: 2, sample rate: 48000, no pass-through
13:02:06 T:2688613232 M:1602719744 NOTICE: fps: 23.976025, pwidth: 624, pheight: 352, dwidth: 624, dheight: 352
13:02:06 T:2688613232 M:1602719744 NOTICE: Display resolution DESKTOP : 1920x1080 @ 50.00 - Full Screen (12)
13:02:06 T:3077482384 M:1602314240 WARNING: CreateFile, successfuly opened </home/nims/.xbmc/skin/Rapier/720p/VideoFullscreen.xml> instead of </home/nims/.xbmc/skin/Rapier/720p/VideoFullScreen.xml>
13:02:06 T:3077482384 M:1602486272 NOTICE: Using GL_TEXTURE_2D
13:02:06 T:3077482384 M:1602486272 NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
13:02:06 T:3077482384 M:1602486272 NOTICE: GL: NPOT texture support detected
13:02:13 T:2751552368 M:1620975616 NOTICE: -->Python Interpreter Initialized<--
13:02:14 T:3077482384 M:1620893696 ERROR: XLCDproc::SetBackLight - Unable to write to socket
13:02:15 T:2751552368 M:1620905984 NOTICE: SVN Latest Version :[ 1.52]
13:02:15 T:2751552368 M:1620905984 NOTICE: True
13:02:17 T:3077482384 M:1620746240 ERROR: GetDirectory - Error getting ?
13:02:17 T:3077482384 M:1620746240 ERROR: CGUIMediaWindow::GetDirectory(?) failed
13:02:21 T:3077482384 M:1620660224 ERROR: Texture manager unable to load file: special://skin/images/
13:02:21 T:3077482384 M:1620660224 ERROR: Texture manager unable to load file: special://skin/images/
13:02:21 T:3077482384 M:1620660224 ERROR: Texture manager unable to load file: special://skin/images/
13:02:22 T:3077482384 M:1620660224 ERROR: Texture manager unable to load file: special://skin/images/
13:02:22 T:3077482384 M:1620660224 ERROR: Texture manager unable to load file: special://skin/images/
13:02:42 T:3077482384 M:1620721664 NOTICE: Samba is idle. Closing the remaining connections
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #6
Well just a quick note that today, after an s3 resume, it was still working. I must say that I also updated to the nightly dharma and that I update the rapier skin to the add-on structure that dharma has. So hoping it now will stay this way Big Grin.
find quote
filigran Offline
Senior Member
Posts: 192
Joined: Oct 2009
Reputation: 0
Post: #7
It's recommended to use pastebin to post logs. Smile

Glad it's working, let's hope it continues to do so.
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #8
Well I am not sure because yesterday I had another hang on my new setup. If it happens again I'll let you know.
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #9
Well it happened again Yesterday. So something is still wrong here. Is there any way to get more detailed info, or debug info to find out what is going wrong here?
find quote
filigran Offline
Senior Member
Posts: 192
Joined: Oct 2009
Reputation: 0
Post: #10
You need to enable debugging in either inside XBMC or in advancedsettings.xml. More info here: http://wiki.xbmc.org/index.php?title=Log..._Debugging

And use sites like http://www.pastebin.com http://www.pastie.org or http://gist.github.com to post your log, alot easier to read for everyone trying to help you. Smile
find quote
qualar Offline
Fan
Posts: 731
Joined: Sep 2009
Reputation: 0
Post: #11
filigran Wrote:You need to enable debugging in either inside XBMC or in advancedsettings.xml. More info here: http://wiki.xbmc.org/index.php?title=Log..._Debugging

And use sites like http://www.pastebin.com http://www.pastie.org or http://gist.github.com to post your log, alot easier to read for everyone trying to help you. Smile

Is this only happening in Rapier?
find quote
filigran Offline
Senior Member
Posts: 192
Joined: Oct 2009
Reputation: 0
Post: #12
qualar Wrote:Is this only happening in Rapier?

I asked him that too, and he said:
nims Wrote:I tried qualars mod too, and this mod seems to be working without any problems.

Btw, nims:
Did you try reinstalling XBMC, removing the skin entirely, removing your .xbmc directory (with guisettings.xml in it, among other things) like I asked earlier?
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #13
Yes I can confirm this is only in Rapier. On the new install I switched now to confluence and this is working without any problems. I will enable all the debug logging, and post any new logs (via pastebin Wink ) in this thread.
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #14
filigran Wrote:Btw, nims:
Did you try reinstalling XBMC, removing the skin entirely, removing your .xbmc directory (with guisettings.xml in it, among other things) like I asked earlier?

Yes I did this. I upgraded even to Dharma.
Changed rapier to match the new dharma structure myself (just renaming and adding an xml).

And it went very well for a couple of days. But after these days, it started again.
find quote
nims Offline
Member
Posts: 93
Joined: Jan 2010
Reputation: 0
Post: #15
Ok I had another freeze, but not after an s3 resume so don't know if it's related. What I did:
1) I was looking a tv show.
2) Opened the subtitle OSD
3) Tried to open sublight.si, but this hanged.
4) I wanted to exit the plug and entered 'S' on my keboard.
5) I chose reload skin, and then it froze.

I see a lot in my debug log, so maybe someone has a clue?

Here's the pastebin
http://pastebin.com/ZhG7rJWy
find quote
Post Reply