DVDPlayer playback fails on r32806 (meego)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
lordmozilla Offline
Member
Posts: 61
Joined: Jan 2010
Reputation: 0
Exclamation  DVDPlayer playback fails on r32806 (meego)
Post: #1
I can't play files using dvdplayer on my netbook (samsung NC10) running meego (1.0 - latest stable at time of post). It's running XBMC dharma branch r32806, I had the problem on r32343, so I updated before posting this to check the bug was still there.

I did find a few posts about similar issues but they where very old and didn't provide any solutions...

Full debug is attached at the bottom. Thanks for any help!

Edit : The NeAACDecSetConfiguration could be related to faad2 from what I've read. I'm running version 2.6.1 and faac 1.25 i anyone knows any problems with these versions.

Configure options where :
Quote:--enable-external-libraries --disable-external-ffmpeg --disable-hal --disable-avahi --disable-vdpau --disable-dvdcss --disable-external-python --enable-debug

Intersting lines from xbmc.log
Quote:06:59:50 T:3061208880 M:1953783808 NOTICE: DVDPlayer: Opening: /home/brendan/big_buck_bunny_480p_h264.mov
06:59:50 T:3061208880 M:1953783808 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
06:59:50 T:2842671984 M:1953656832 DEBUG: thread start, auto delete: 0
06:59:50 T:2842671984 M:1953656832 NOTICE: Creating InputStream
06:59:50 T:2842671984 M:1953656832 INFO: CDVDFactorySubtitle::GetSubtitles, searching subtitles
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: START
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: Checking for common subdirs...
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: Done (time: 3 ms)
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: Searching for subtitles...
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: Done (time: 4 ms)
06:59:50 T:2842671984 M:1953656832 DEBUG: CacheSubtitles: END (total time: 9 ms)
06:59:50 T:2842671984 M:1953656832 INFO: CDVDFactorySubtitle::GetSubtitles, searching subtitles done
06:59:50 T:2842671984 M:1953656832 NOTICE: Creating Demuxer
06:59:50 T:2842671984 M:1953656832 DEBUG: SECTION:LoadDLL(special://xbmcbin/system/players/dvdplayer/avutil-50-i486-linux.so)
06:59:50 T:2842671984 M:1953656832 DEBUG: Loading: /usr/lib/xbmc/system/players/dvdplayer/avutil-50-i486-linux.so
06:59:50 T:2842671984 M:1953529856 DEBUG: SECTION:LoadDLL(special://xbmcbin/system/players/dvdplayer/avcodec-52-i486-linux.so)
06:59:50 T:2842671984 M:1953529856 DEBUG: Loading: /usr/lib/xbmc/system/players/dvdplayer/avcodec-52-i486-linux.so
06:59:50 T:2842671984 M:1953529856 ERROR: Unable to load /usr/lib/xbmc/system/players/dvdplayer/avcodec-52-i486-linux.so, reason: /usr/lib/xbmc/system/players/dvdplayer/avcodec-52-i486-linux.so: undefined symbol: NeAACDecSetConfiguration
06:59:50 T:2842671984 M:1953529856 ERROR: CDVDDemuxFFmpeg::Open - failed to load ffmpeg libraries
06:59:50 T:2842671984 M:1953529856 ERROR: OpenDemuxStream - Error creating demuxer
06:59:50 T:2842671984 M:1953529856 NOTICE: CDVDPlayer::OnExit()
06:59:50 T:2842671984 M:1953529856 NOTICE: CDVDPlayer::OnExit() deleting input stream
06:59:50 T:2842671984 M:1953529856 DEBUG: Thread 2842671984 terminating
06:59:50 T:3061208880 M:1953529856 DEBUG: CAnnouncementManager - Announcement: PlaybackStopped from xbmc
06:59:50 T:3061208880 M:1953529856 ERROR: Playlist Player: skipping unplayable item: 0, path [/home/brendan/big_buck_bunny_480p_h264.mov]

Full XBMC.log

HTPC : Acer Revo R3600 / 2GB PC6400 / 2x500GB Samsung 2.5" SATAII / Roland UA1-EX
Software : Arch linux / LUKS / Openbox / xbmc-svn

(This post was last modified: 2010-08-16 09:39 by lordmozilla.)
find quote
lordmozilla Offline
Member
Posts: 61
Joined: Jan 2010
Reputation: 0
Post: #2
I've upgraded faac to 1.28 and faad2 to 2.7 which are both the latest but my problem is no different.

I may be a little closer, On my 64bit Arch linux desktop :

I'll try rebuild with ./configure --disable-external-ffmpeg --disable-hal --disable-avahi --disable-vdpau --disable-dvdcss --enable-debug the desktop was built with no options...

Quote:[brendan@holm xbmc-dharma]$ file xbmc/cores/dvdplayer/Codecs/ffmpeg/libavcodec/libavcodec.so.52
xbmc/cores/dvdplayer/Codecs/ffmpeg/libavcodec/libavcodec.so.52: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped
[brendan@holm xbmc-dharma]$ ldd xbmc/cores/dvdplayer/Codecs/ffmpeg/libavcodec/libavcodec.so.52
linux-vdso.so.1 => (0x00007fff8a713000)
libavutil.so.50 => /usr/lib/libavutil.so.50 (0x00007fd0e57f5000)
libfaad.so.2 => /usr/lib/libfaad.so.2 (0x00007fd0e55b4000)
libva.so.1 => /usr/lib/libva.so.1 (0x00007fd0e53a9000)
libm.so.6 => /lib/libm.so.6 (0x00007fd0e5127000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fd0e4f0f000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007fd0e4cf1000)
libc.so.6 => /lib/libc.so.6 (0x00007fd0e4995000)
libdl.so.2 => /lib/libdl.so.2 (0x00007fd0e4791000)
/lib/ld-linux-x86-64.so.2 (0x00007fd0e6558000)

On my Meego 32bit netbook:

Quote:[root@groves-wifi dvdplayer]# file avcodec-52-i486-linux.so
avcodec-52-i486-linux.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
[root@groves-wifi dvdplayer]# ldd avcodec-52-i486-linux.so
linux-gate.so.1 => (0xb77a3000)
libc.so.6 => /lib/libc.so.6 (0xb6c74000)
/lib/ld-linux.so.2 (0xb77a4000)

HTPC : Acer Revo R3600 / 2GB PC6400 / 2x500GB Samsung 2.5" SATAII / Roland UA1-EX
Software : Arch linux / LUKS / Openbox / xbmc-svn

(This post was last modified: 2010-08-16 20:06 by lordmozilla.)
find quote